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 Lesson 0: Course Introduction 

Oracle Siebel 8.1.x Business Analyst 1 

Practice 0-1: Class Setup 

Goals To invoke the classroom initialization routine to prepare your machine for the Siebel 
Business Analyst course 

Time 15 - 20 minutes 

Instructions: 
This practice is a prerequisite to running the remaining practices in this course. 

1. Prepare to run the course set up: 
a. Log out of all Siebel applications (select File > Log Out) and close the windows. 
b. Look in the task bar at the bottom of the screen.  Verify that the Siebel application and SQL 

icons:   do not appear. 
If you leave these applications running, this set up will fail.   

2. Invoke the course set up: 
a. Use Windows to navigate to D:\deployment. 
b. Double-click the “Deploy your Siebel Environment.html” shortcut.   
c. If necessary, click OK in the Information Bar box. 
d. If there is a security warning bar at the top of the web page saying “To help protect your 

security, Internet Explorer has restricted…”, right-click the bar and select Allow Blocked 
Content.  Click Yes. 

e. Select Business_Analyst from the drop down list in the middle of the page. 
f. Click GO. 
g. Click Run. You should get a command prompt window asking if you wish to deploy. 
h. Verify the course name (Siebel 8.1 Business Analyst). If it is correct, enter Y. 
i. You will then be prompted for a three letter code.  Enter BAF.   
j. Let the script run.  It should run about 10 minutes.  Do not close the window or run any other 

programs.   
k. When the script is complete you should see a line that the course files have been deployed 

similar to: 
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l. Close the command window.  If you do not see the command window, it may have already 
been closed by the script. 

m. Close the browser window. 

3.  Verify the set up: 
a. Use Windows to navigate to D:\deployment\logs. 
b. Double-click to open the latest log file.  Scroll to the end of the file.  You should see a line 

that indicates the Business_Analyst_Environment_Deployment completed with a time code.  
If you do not, please consult your instructor. 

c. Close the log file. 
d. Use Windows Explorer to navigate to D:\labs\BusinessAnalyst. 
e. Verify that you see these files and directories: 
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Practice 1-1 Introducing Siebel CRM Applications 

Goals Describe the features, functionality, and benefits of Siebel CRM applications. 

Time 5 - 10 minutes 

Instructions: 

1. Many Siebel CRM applications are available, including horizontal applications such as Siebel 
Call Center, Siebel Sales, and Siebel Partner Portal and industry applications such as Siebel 
Public Sector, Siebel Retail, and Siebel Transportation. How many different databases does 
Siebel use to support these different applications? Select all that apply. 
a. Two databases, one for internal applications and one for customer-facing applications. 
b. One database for each channel or support area (for example, Siebel Sales and Siebel eSales 

use the same database, but Call Center uses a different database). 
c. A different database is required for each horizontal application and each industry application. 
d. One database serves all applications. 

2. What are the types of Siebel applications? Select all that apply. 
a. Partner. 
b. Web. 
c. Customer. 
d. Employee. 

3. What is the difference between Siebel Sales and Siebel E-Commerce? Select all that apply. 
a. Siebel Sales is an employee application; Siebel E-Commerce is a customer application. 
b. Siebel Sales tracks accounts, opportunities, and contacts for sales representatives; Siebel E-

Commerce is an OnDemand application that provides the same functionality to smaller 
companies. 

c. Siebel Sales helps sales representatives identify top opportunities; Siebel E-Commerce 
allows customer to purchase products over the Web. 

d. Siebel Sales provides service information for each account; Siebel E-Commerce provides an 
interactive product catalog. 

4. BAF Company wants to allow its partners to be able to view product information and conduct 
business over the Web. Which product would you recommend?  Select all that apply. 
a. Siebel Partner Portal. 
b. Siebel Call Center. 
c. Siebel Sales. 
d. Siebel Partner Manager. 
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5. BAF Company wants to use Siebel CRM to help its employees manage technical support for the 
products it sells. Which product would you recommend?  Select all that apply. 
a. Siebel Partner Portal. 
b. Siebel Call Center. 
c. Siebel Sales. 
d. Siebel Partner Manager. 

6. Using a Siebel client in Standard Interactivity mode offers (select one): 
a. Less functionality than a High Interactivity client and fewer compatible browsers. 
b. Less functionality than a High Interactivity client, but more compatible browsers. 
c. More functionality than a High Interactivity client, but fewer compatible browsers. 
d. More functionality than a High Interactivity client and more compatible browsers. 
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Solutions 1-1  

Answers 

1. Many Siebel CRM applications are available, including horizontal applications such as 
Siebel Call Center, Siebel Sales, and Siebel Partner Portal and industry applications such as 
Siebel Public Sector, Siebel Retail, and Siebel Transportation. How many different 
databases does Siebel use to support these different applications? Select all that apply. 
d. One database serves all applications. 

2. What are the types of Siebel applications? Select all that apply. 
a. Partner. 
c. Customer. 
d. Employee. 

3. What is the difference between Siebel Sales and Siebel E-Commerce? Select all that apply. 
a. Siebel Sales is an employee application; Siebel E-Commerce is a customer application. 
c. Siebel Sales helps sales representatives identify top opportunities; Siebel E-Commerce 
allows customer to purchase products over the Web. 

4. BAF Company wants to allow its partners to be able to view product information and 
conduct business over the Web. Which product would you recommend?  Select all that 
apply. 
a. Siebel Partner Portal. 
d. Siebel Partner Manager. 

5. BAF Company wants to use Siebel CRM to help its employees manage technical support 
for the products it sells. Which product would you recommend?  Select all that apply. 
b. Siebel Call Center. 

6. Using a Siebel client in Standard Interactivity mode offers (select one): 
b. Less functionality than a High Interactivity client, but more compatible browsers. 
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Practice 1-2 Using Siebel Bookshelf 

Goals Explore Siebel Documentation 

Time 10 - 15 minutes 

Instructions: 

Siebel Bookshelf provides documentation guides in two file formats (PDF and HTML) along with 
two interfaces for listing, navigating, viewing, and searching them. In this lab, you will use the 
HTML format which is accessible from the classroom. The PDF version offers a format that can be 
printed easily and includes a searchable index that spans all Bookshelf volumes. 

1. Start Siebel 8.1 Bookshelf. 
a. Select Start > Programs > Internet Explorer. 
b. Enter Address: http://www.oracle.com/technology/documentation/siebel.html. 
c. Notice that you are presented with a page that lists various versions of Siebel documentation. 

Note: The Link column allows you to view the documentation via the Web site. The 
Download column allows you to download a full PDF version (which includes all books and 
allows searching across books). 

d. In the Description column, locate the "Siebel Business Applications 8.1 Documentation 
Library" and click the "View Library" link in that row. 

e. Notice that you can view the books alphabetically or by product line. 
f. Click the Individual Guides link. 

Note: This presents an alphabetical list of books. 

2. Use a book's content list to navigate and locate information. 
a. Click F. 

Note: This navigates to books starting with the letter F. 
b. Click Fundamentals.  

Note: This will open a book titled Siebel Fundamentals and position you at the Contents. 
c. Notice the links at the top that will navigate you back to the home page (Bookshelf Home), 

back to this contents list (Contents), to the index for this book (Index), and to a PDF version 
of this book. 

d. If necessary scroll down to locate and click "About the User Interface". 
e. Click "About the Site Map".  
f. What are the two ways to access the Site Map? 

 
             

g. At the top, click Contents. 
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h. Scroll down and locate the "Using iHelp" section. 
Note:  iHelp is an online help tool for Siebel users. 

i. Under the iHelp section, click "Using iHelp to Complete Tasks".  
j. What are the two ways a user can invoke iHelp to access assistance with basic tasks? 

 
             

k. At the top, click Contents. 
l. From the application-level menu, select Edit > Find (on This Page). 
m. Enter Keyboard and click Find Next. 
n. Continue to click Find Next until you locate "Keyboard Shortcuts". 
o. Click "Keyboard Shortcuts". 
p. Look in "Table 19. Data Management Keyboard Shortcuts". 
q. What is the keyboard shortcut to add a new record when in Extended Mode? 

 
             

3. Use the Index to locate and navigate topics. 
a. At the top, click Index. 
b. Mouse over the "activities" entry.  
c. Notice that the cursor does not change to a hand and no link is present. This means the word 

is just a heading. 
d. Under "activities" locate "calendar, typing directly in". 
e. Notice that there is a hyperlink after this listing ("1"). 
f. Click the 1 directly after "calendar, typing directly in".  

Note that information about adding a calendar activity appears. 

4. Work with the PDF version. 
a. At the top, click PDF. 
b. Notice that there is a left navigation page that displays the contents. 
c. To the left of "6 Using iHelp" click the plus sign to expand the topic. 
d. Click "Using iHelp to Complete Tasks". 
e. Notice that this is the same information you saw above in the HTML version. 
f. Scroll to the end of the left pane and click Index. 
g. Hover over topics and notice the cursor change to a hand for some indicating a link or 

drilldown is active. 
h. Under activities, click "calendar, typing directly in". 
i. Close the browser window. 

5. Close the main browser window. You are back at your desktop. 

6. Explore searching. 
a. In order to search across books, you would have to download the full PDF version from the 

main bookshelf page.  DO NOT DO THIS. 
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b. Instead, read through the steps to familiarize yourself with the process: 
i. In the left pane, scroll to the top and click Homepage. 
ii. To search for specific information throughout all the Bookshelf guides, click the Search 

button, located in the main window in the upper right. 
iii. Locate the Search pane (it may appear to the left). 
iv. Enter iHelp into the "What word or phrase would you like to search for?" text box.  
v. Verify that the "In the index named Siebel81.pdx" radio button is selected. This setting 

indicates that Search will use this pre-generated index for Siebel Bookshelf. 
vi. Click Search. 
vii. Notice that the search results return all instances of iHelp across all books in Bookshelf: 

 
viii. In the search results window, click the expand (+) button next to Siebel Fundamentals 

to expose all instances of iHelp in that book. 
ix. Click the second entry in the expanded list. Note that the document in the main window 

changes to correspond to search entry you clicked. 
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Solutions 1-2 

Answers 

2.f. What are the two ways to access the Site Map? 
1) From the application-level menu, choose Navigate > Site Map. 
2) Click the Site Map button on the application toolbar. 

2.j. What are the two ways a user can invoke iHelp to access assistance with basic tasks? 
From the application-level menu, choose View > Action Pane > iHelp. 
Click the How Do I button on the application toolbar. 

2.q. What is the keyboard shortcut to add a new record when in Extended Mode? 
CTRL+ N 
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Practice 2-1: Identifying User Interface Elements 

Goals Identify important Siebel user interface elements 

Time 5 - 10 minutes 

Instructions: 

In order to effectively navigate the Siebel user interface (UI), you should be able to quickly locate 
important interface elements, and to be able to communicate about navigation items with others.  

 
 

1. Place the appropriate letter (a - f) next to the term.  Not all terms are used:  
selected record   
application-level menu   
form applet (child)   
link bar  
screen tab  
view tab  
view  

a 
b 

d 

e 

c 

f 
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2. Place the appropriate letter (g - k) next to the term.  Not all terms are used:  
iHelp ("How do I")   
form applet (parent)  
list applet (child)  
view tab  
site map  
screen tab  
link bar  
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Solutions 2-1  

Answers 

1.  Place the appropriate letter (a - f) next to the term.  Not all terms are used. 
selected record  d 
application-level menu  a 
form applet (child)  e 
link bar  c 
screen tab  b 
view tab  
view  f 

2.  Place the appropriate letter (g - k) next to the term.  Not all terms are used.   
iHelp ("How do I")  h 
form applet (parent)  i 
list applet (child)  k 
view tab  j 
site map  g 
screen tab  
link bar  
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Practice 2-2: Navigating the User Interface (UI) 

Goal Navigate in Siebel Call Center 

Time 15 - 20 minutes  

Instructions: 

You are Casey Cheng, a call center representative at BAF Company. At the beginning of your shift, 
you review information related to service requests, contacts, and accounts to help you prepare for 
your day’s work.  

1. Start the Siebel Call Center Developer Web Client. 
Note:  This client is a local version of the Siebel Call Center application. 
a. Select Start > Programs > Siebel_Web_Client_81 > Siebel Web Client 8.1 > Siebel Call 

Center - ENU. 
b. Enter: 

User ID CCHENG 
Password CCHENG 
Connect to Sample 

c. Click OK. If prompted, click Install to install the Siebel High Interactivity Framework. This 
installs supporting Active-X controls and Java code. 

d. If prompted, click AutoFix and Run. 
e. Wait until the application has completely started and you see the Home page before 

continuing to the next step. This may take a minute or two. 

2. Use a form applet to view information for a service request. 
a. Select the Service screen tab. 
b. On the left side of the page, click My Open Service Requests. 
c. Click the hyperlink for SR# 176914-4624244 (it should be the first SR listed). 
d. Click the Show More button in the upper-right corner of the top applet to see all available 

fields. 
e. What is the value for the Phone #?_______________________________________________  
f. Notice that the Severity =  4-Low.  
g. Click the Email field and use the right arrow key to move the cursor to the right.  
h. Notice that the Email = paul_smith@honeywell.com 
i. Notice that Committed is similar to 03/10/2005 6:25:29 PM. 
j. Notice that Organization = PCS Technologies (HT ENU). 
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3. Use a view tab to view child data related to a parent service request. 
a. Select the Solutions view tab in the middle of the screen (under the top applet).  
b. In the list applet at the bottom, select Menu > Record Count.  
c. Notice that 2 is displayed in the dialog. This means that 2 solutions are associated with this 

service request. 
d. Click OK to close the dialog. 

4. Use a list and a form applet to add a contact record, then use a pop-up shuttle applet to associate 
an account with the contact. 
a. Select the Contacts screen tab. 
b. Click Contacts List on the link bar (directly under the screen tabs). 

Note: In subsequent steps, this navigation will be shortened to Contacts > Contacts List. 
c. In the top applet, click the New button to create a new contact record. 
d. Enter: 

Last Name Matthews-BAF 

First Name Jane 

Mr/Ms Ms. 

Work Phone # 415-999-5555 
e. Look in the bottom form applet. 
f. Notice that the value for Account is empty (or blank). The bottom applet is showing the same 

information as the top applet. 
g. In the list applet, click in the Account field. 

h. Click the Select  button, or use the F2 key on the keyboard, to open the pop-up shuttle 
applet.  
Note:  This is an MVG applet, which will allow you to add multiple child records to a parent  
record. In this case you will add only one. 

i. In the dialog, in the Starting With box in the upper right, type Pop and click Go. 
j. In the left list, select the Popular Computing Products. 
k. Click Add, located in the middle of the shuttle applet, to add the record to the Selected 

window on the right. 
l. Click OK. 
m. Look in the bottom form applet. 
n. Notice that the value for Account is now filled in. 

5. Examine relationships between a parent record in a form applet and its child records accessible 
via view tabs.  
a. Select Accounts > Accounts List. 
b. In the top applet, click the Query button.  

Note: You will perform a simple query to locate a specific account record. Queries are  
covered in detail in an upcoming lesson. 

c. In the Name field, type PCS Technologies Electronics. 
d. Click Go. 
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e. Click the hyperlink in the Name column to drill down. 
f. What is the relationship between the PCS Technologies Electronics record in the top form 

applet and the contacts in the bottom list applet?  
 
              

g. Select the Account Opportunities view tab (below the top applet - in the middle of the 
screen). 

h. Notice that you are seeing the account record in the top applet and its associated 
opportunities in the bottom applet. 

i. Note the state of screen tabs and view tabs. Which screen tab is currently selected? Which 
view tab is currently selected? 
 
              

j. In the bottom list applet, drill down on PCS Technologies Electronics Master SLA Renewal.  
k. Drill down on PCS Technologies Electronics Master SLA Renewal again. What screen and 

view tabs are selected now? 
 
              

l. Notice that you are seeing the opportunity record in the top applet and its associated contacts 
in the bottom applet. 

m. In the bottom applet, drill down on the last name Decamp. What screen tab is active? What 
does the view display?  
 
              

n. Based on this exercise, what can you tell about the relationship between the form applet that 
appears immediately below the screen tabs and the link bar, and the applets that appear when 
you select a view tab? 
 
              
 
              

6. Examine the thread bar.  
a. Note that it represents the sequence of views you have navigated to in this exercise. Click 

"Account:PCS Technologies Electronics" in the thread bar to navigate back to the account 
record you previously viewed. 

 
Note: Alternatively, you could have clicked the browser's back button repeatedly to return. 
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7. Use a text field that can store a large number of characters.  
a. Leave your Siebel Call Center session open. 
b. Use Windows to navigate to D:\labs\BusinessAnalyst. 
c. Double-click Oracle_Information.txt. 
d. From the Notepad menu, select Edit > Select All (Ctrl+A). 
e. Select Edit > Copy (Ctrl+C). 
f. Select File > Exit to close Notepad. 
g. Return to Siebel Call Center. 
h. Navigate to Accounts > Accounts List.  
i. In the list applet, click New. 
j. In the Name field, type Oracle-BAF. 
k. Step off the record to save it. 
l. Drill down on the record you just added. 
m. Click the Notes view tab. If you don't see it, use the drop-down at the end of the view tabs to 

select it. 
n. In the bottom applet, click New. 
o. Click in the Description field. 
p. Use Ctrl+V to paste the text you copied in an earlier step. 
q. Step off the record. 
r. Mouse over the Description field. What happens? 

 
              

8. Leave your Siebel Call Center session running. 
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Solutions 2-2  

Answers: 

2.e. What is the value for the Phone #? 
(973) 328-1621 

5.f.  What is the relationship between the PCS Technologies Electronics record in the top form 
applet and the contacts in the bottom list applet?  
The bottom applet lists contacts associated with the PCS Technologies Electronics account 
record in the top applet. 

5.i. Note the state of screen tabs and view tabs. Which screen tab is currently selected? Which 
view tab is currently selected? 
The Accounts screen tab and Account Opportunities view tab are currently active. This 
indicates that the account is the parent and opportunity is the child. 

5.k. Drill down on PCS Technologies Electronics Master SLA Renewal again. What screen and 
view tabs are selected now? 
The Opportunities screen tab and Contacts view tab are active. 

5.m. In the bottom applet, drill down on the last name Decamp. What screen tab is active? What 
does the view display?  
The Contacts screen tab and the Activities view tab are currently active. The contact details 
are displayed in the form applet at the top and the associated activities are shown in the 
bottom applet. 

5.n. Based on this exercise, what can you tell about the relationship between the form applet 
that appears immediately below the screen tabs and the link bar, and the applets that appear 
when you select a view tab? 
The information displayed when a view tab is selected is related to the record displayed in 
the top form applet. In general, the records in the list applet are child records of the parent 
record in the top form applet.  

7.r. Mouse over the Description field. What happens? 
The large amount of text in the Description field is displayed in a pop-up. 
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Practice 3-1 Querying for Siebel Data 

Goals Query for data in the Siebel user interface 

Time 20 - 30 minutes 

Instructions: 

You are Casey Cheng, a call center representative at BAF Company. As you work with your 
customers during your shift, you often need to locate service request information quickly.  In this 
lab, you will use Query, Query Assistant, and Pre-Defined Queries to locate information. 

1. Return to or if necessary, start Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID CCHENG 
Password CCHENG 
Connect to Sample 

c. Click OK. 

2. Use a query to locate a service request (SR) record. 
a. Select Site Map > Service Requests > Service Request List 

or… 
Click the Service screen tab, and then click Service Requests List on the link bar. 

b. In the list applet, select the Menu button then New Query (or use the keyboard shortcut 
ALT+Q).  
Note: In this course, we use the notation Menu > Operation to indicate execution of an 
operation from the applet menu. Using this notation, this step would be written:  
Select Menu > New Query. 

c. In the SR# field, enter 410194-12916544. 
d. Select Menu > Run Query or press the Enter key.  
e. Confirm that a single record matches your query. 
f. Refresh the Service Requests list by issuing an empty query.  

i. Click Query. 
ii. Do not enter data in any fields. 
iii. Click Go. This clears out the prior query and restores the list of records. This method for 

clearing a query is called an empty or null query. 
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g. Display all SRs owned by Betty Mason, another service representative. 
i. Select All Service Requests across Organizations in the Visibility Filter, which is the 

drop-down list immediately to the left of the list applet's Menu button.  
Note: You will learn about the role of the Visibility Filter in determining data visibility in 
a subsequent lesson. 

ii. Click Query. 
iii. In the Owner field, click the Select control . 
iv. In the Find drop-down, select User ID. 
v. In the Starting with field, enter BMASON. 
vi. Click Go. 
vii. Click Go. Verify that only records with Owner = BMASON appear in the list applet. 
viii. Issue an empty query to restore the SR list. 

3. Use the Service Request form applet to perform a query on a field not displayed.  
a. Select the My Service Requests in the Visibility Filter. 
b. In the list applet, execute a query for SRs with Area = Application. You should see two 

matching records. 

c. Use Next Record  in the child form applet to move between the two records in 
the query result set.  Verify that the two matching records have different values for Sub-Area: 
Productivity and License Keys. Also, note that Sub-Area is not displayed in the list applet. 

d. Execute an empty query to refresh the SR list applet. 
e. Execute a query to find all of CCHENG's SRs with Sub-Area = License Keys. 

i. In the child form applet, click Query. 
ii. In the Sub-Area field, click the drop-down arrow.  
iii. To avoid searching for a value in a long drop-down list, type Lic with the dropdown list 

displayed. As you type characters, the list will display the first matching value for the 
string you have entered. This will help you quickly find the correct value. When you 
have located License Keys, click it to select the value. 

iv. Click Go. 
v. Verify that a single matching record appears in the list and form applets. 

4. Use Columns Displayed to arrange columns in preparation for the remainder of this lab. 
a. Right-click anywhere in the list applet and then select Columns Displayed. 
b. You want the following columns to be displayed (in order): 

SR#, Severity, Owner, Priority, Opened, and Account. 
i. While holding down the CTRL key, select New, Team Space, Last Name, Area, 

Summary, and SR Type in the right list. 

ii. Click the left arrow  to move the columns over. You should have SR#, Account, 
Owner, and Priority remaining in the Selected Columns list. 

iii. In the left list, select Severity and Opened while holding down CTRL. 
iv. Click the right arrow   to move the columns to the Selected Columns list. 
v. Click the Severity column. 
vi. Click the up arrow  until the Severity column is immediately below SR#. 
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vii. Move the Account column to the end of the list of Selected Columns by selecting 
Account and clicking the End button . 

viii. Click Save. 
c. Resize column widths so that you can see all the columns. Verify that you see columns as 

shown: 

 

5. Use Query Assistant to query for records that were opened after a specific date. Query Assistant 
can help you enter complex queries. 
a. Execute an empty query to refresh the list applet. 
b. To sort the Opened column in ascending order, click the Opened column heading until the 

sort order triangle is pointing up, like this:  
c. Scroll down through the list, noticing the years in the Opened column. Verify that the SRs 

were opened in 2005 and 2008. 
d. Click Query. 
e. Click Query Assistant. 
f. Enter a query to display all SRs that have been opened since a specific date. 

i. Select Opened for the field 
ii. Select Is After for the operator 
iii. Enter 1/1/2007 for the value. Your query should look like this:  

 
g. Click Go to execute. 
h. Scroll down through the list, noticing the years in the Opened column. Verify that only year 

2008 appears. 
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6. Refine the last query to identify recently opened SRs that have Account = Honeywell 
International. 
a. Select Menu > Refine Query. 
b. What value is displayed in the Opened column? What does this value indicate? 

 
             

c. In the Account column, click the Select control. 
d. Select Honeywell International. 
e. Click Go. 
f. Verify that your refined query matched two SRs. 

7. Save the query you just created so you can use it later.  
a. From the application-level menu at the top, select Query > Save Query As. 
b. In the Query Name field, enter BAF Honeywell SRs since 2007. 
c. Click OK. 
d. Notice the query now appears in the Saved Queries drop-down list located in the upper right. 
e. Test the saved query. 

i. Execute an empty query to refresh the SR list. 
ii. Click the arrow in the Saved Queries drop-down. 
iii. Scroll down and select BAF Honeywell SRs since 2007. 
iv. Verify that the query returned two matching SRs. 

8. Use Refine Query and the IS NOT NULL operator to identify recent Honeywell International 
SRs that have Area defined. Casey Cheng uses Area to determine who to assign an SR to. 
a. Verify that you see two records that match the Honeywell SRs since 2007 query. If needed, 

use the Saved Queries list to re-execute this query. 
b. In the child form applet, select Menu > Refine Query. 
c. Verify that the upper applet shows values in both the Opened and Account columns. 
d. In the lower applet's Area field, type IS NOT NULL. You cannot select this value from the 

drop-down list. 
e. Click Go or press Enter. 
f. Verify that only one of CCHENG's SRs matches the query criteria. 

9. CCHENG is assigned to handle SRs for two major accounts: Honeywell International and 
Marriott International HQ. You will build and execute a query to identify SRs for these accounts. 
a. Execute an empty query in the SR list applet. 
b. Select Menu > Record Count (CTRL+SHIFT+3). Write down the number of SRs that  

CCHENG has:     _______________________________________  
c. Click OK to close the dialog. 
d. Click Query. 
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e. In the Account column, type "Honeywell International" OR "Marriott International HQ". Be 
sure to include the quotations.   
Note:  This query will look for SRs where the Account is an exact match to either Honeywell 
International or Marriott International HQ. In general, the OR operator is useful in finding 
records that match one of several different field values. 

f. Click Go. 
g. Scroll through the query result set and verify that only SRs for the two major accounts 

appear. 
h. Select Menu > Record Count. Verify that the number of matching SRs is less than the 

number you recorded above. 
i. Click OK. 

10. From the application-level menu, select File > Log Out to close the Siebel application. 
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Solutions 3-1  

Answers 

6.b. What value is displayed in the Opened column? What does this value indicate? 
> "01/01/2007 12:00:00 AM".  This value means "after 12am, January 1, 2007" 

9.b. Select Menu > Record Count (CTRL+SHIFT+3). Write down the number of SRs that  
CCHENG has:  
Approximately 31. 
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Practice 4-1 Exploring Common Siebel Entities 

Goals Explore Accounts, Contacts, Activities, and Service Requests 

Time 25 - 35 minutes 

Instructions: 
In this lab you will examine common Siebel entities: Accounts, Contacts, Activities, and Service 
Requests.  You will log in to Siebel Call Center as Vic Taylor, the call center manager for PCS 
Company. This is a different user than you previously used. 

1. Start the Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID VTAYLOR 
Password VTAYLOR 
Connect to Sample 

c. Click OK. 

2. Examine properties of accounts and their relationship to other entities. 
a. Click the Accounts screen tab to go to the Accounts home page. 

Note: This page has links to different types of accounts, such as My Accounts, where 
VTAYLOR is on the account team, or All Accounts.  

b. Click My Top Accounts. 
c. Examine the Saved Queries drop-down in the upper right. The query selected is “Top 

Accounts”.  
d. To see the query being executed, in the application-level menu, select Query > Refine Query.  

What is the query field and value(s)? 
 
              

e. Click Cancel in the top applet. 
f. In the Saved Queries dropdown, select All Accounts. Because the visibility filter is set to My 

Accounts, the All Accounts query only returns Accounts where VTAYLOR is on the 
Account team.   

g. Next, you will examine an account belonging to one of Vic Taylor’s reports, Casey Cheng. 
i. Select My Team’s Accounts in the Visibility Filter. 
ii. Locate and drill down on Honeywell International. Use the view tabs to answer the 

following.
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iii. What are the current and potential volumes for this account? (Under More Info). 

 
              

iv. Who is the primary contact at Honeywell International? 
 
              

v. What is the revenue of the largest opportunity at Honeywell International? 
 
              

vi. Who is the primary on the Honeywell International account team? 
 
              
Note: You could click the MVG control in the top applet's Account Team field to see the 
team members, but click the Coverage Team View to see the team in a list applet. 

h. Click Accounts List on the link bar. 
i. Select My Team’s Accounts in the visibility filter. 
j. Select the John Residential record. 
k. In the Account Team field, click the MVG control. 
l. Verify that VTAYLOR is not on the account team.  

Note: My Team's Account shows accounts where one or more of the user's subordinates are 
on the account team. 

m. Click OK. 
n. Click Charts from the link bar and wait until the charts applet is loaded.  
o. In the bottom applet, select State Analysis from the left-hand drop-down.  In what U.S. 

state(s) are most of the accounts located? 
 
              

3. Examine contacts and activities and the difference between personal and public contacts. 
a. Select Contacts > My Contacts. 
b. Create a contact record with: 

Last Name Aubergine-BAF 
First Name Augusto 
Work Phone # (321) 555-1111 

c. Drill down on the new contact’s last name. 
d. Create a new activity record with: 

Type Meeting 
Status Scheduled 
Description Introduction 
Start 2 hours from current time  

(click the calendar icon and enter time) 
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e. Create a second activity: 

Type Email - Outbound 
Status Not Started 
Description Follow up 
Start Current time 

tomorrow 
f. Click the Calendar view tab. If you do not see the tab, use the drop-down at the right end of 

the tab list. 
g. Drill down on the Introduction hyperlink. If you are prompted, click Install. 
h. You will be taken to a Calendar detail view displaying meeting participants’ availability.  

Take a few minutes to explore the availability applet. 
i. Select Contacts > My Personal Contacts. 
j. Create a new personal contact for Vic Taylor: 

Last Name Freesia-BAF 
First Name Filene 
Mr/Ms Ms. 
Work Phone # (853) 555-2110

k. Click Contacts List in the link bar. 
l. Does Ms. Freesia-BAF appear in the list of My Contacts for Mr. Taylor? 

 
              

m. Click Personal Contacts List in the link bar. 
n. In the detail applet below the Personal Contacts list, clear the Private check box for Ms. 

Freesia-BAF. 
o. Click Contacts List and verify that Filene Freesia-BAF now appears as a public contact. 

4. Vic Taylor has just sold a Tier 1 service plan to the Honeywell International account. Tier 1 
service includes quarterly service calls with the account's primary contact, as well as a more 
comprehensive annual meeting. After consulting with the primary Contact for Honeywell 
International, Joseph Armstrong, Vic Taylor creates Activities for each event using an activity 
template. 
a. Select Accounts > My Accounts. 
b. Drill down on Honeywell International. 
c. Locate the primary contact in the list. 
d. Drill down on his last name. 
e. Select the Activity Plans view tab. 
f. Create a new record. 
g. Select Template = Tier 1 Service 
h. Select Menu > Save Record. 
i. Notice that the Activities grand-child applet at the bottom is populated with four activities 

from this template.  Notice that the activity template has specified an interval of three months 
between each service call and meeting. 
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j. For each activity, click the Calendar control in the Start field and change the time to 2:00 
PM.  Do not change the date. 

k. Set the status of each of these four activities to Scheduled. You will use Change Records to 
set the status for all of the records together. 
i. In the Activities applet, press CTRL+A to select all records. 
ii. From the application-level menu, select Edit > Change Records. 
iii. In the 1st Field to Change, set: 

Field Status 
Value Scheduled 

iv. Click OK. 
v. Verify that all four activities have Status = Scheduled. 

l. Click the Calendar screen tab. If prompted, click Install. 
m. Click the Monthly tab. 
n. Click the Next arrow immediately to the right of the month text box. Continue clicking it 

until you see all four activities you just scheduled. The last activity should occur in exactly 
12 months. 

5. Vic Taylor creates a service request.  
a. Select Service > My Service Requests. 
b. Create a new Service Request (SR) and set: 

Note: You may need to click the Show More control in the bottom applet. 
Summary BAF InMotion networking problems 
Account Hibbings Mfg 
Last Name Ichihashi (with First Name Aya) 

Type Software 
Area Operating System 
Subarea Other 
Source Web 
Severity 2-High 
Reproducible Sometimes 

c. Verify that the Owner of the SR is VTAYLOR. 
Note: SRs have a single owner, who is identified by a User ID.  

d. In the Owner field, click the Select icon. 
e. In the top of the pick applet, use the drop-down list to select User ID. Next to this, enter 

AALEXIS and click Go. 
f. Click OK. 
g. Refresh My Service Requests by executing an empty query. The SR should no longer appear 

in the list, because it is no longer owned by VTAYLOR. You will learn more about record 
ownership and visibility in a later lesson. 

6. From the application-level menu, select File > Log Out. 
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Solutions 4-1  

Answers 

2.d. To see the query being executed, in the application-level menu, select Query > Refine 
Query.  What is the query field and value(s)? 
This query searches for accounts with Status LIKE Gold* 

2.g.iii. What are the current and potential volumes for this account? (Under More Info). 
$5,000,000 current and $20,000,000 potential volume 

2.g.iv. Who is the primary contact at Honeywell International? 
Select the Contacts view tab and notice the primary check mark.  Joseph Armstrong 

2.g.v. What is the revenue of the largest opportunity at Honeywell International? 
Select the Opportunities view tab.  $6,600,000 

2.g.vi. Who is the primary on the Honeywell International account team? 
Casey Cheng 

2.o. In the bottom applet, select State Analysis from the left-hand drop-down.  In what U.S. 
state(s) are most of the accounts located? 
CO.  

3.l. Does Ms. Freesia-BAF appear in the list of My Contacts for Mr. Taylor? 
No – she is a personal contact and will only appear in his Personal Contact List 
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Practice 5-1 Using Siebel Entities 

Goals Work through an implementation of a company’s business process that uses common 
Siebel entities 

Time 20 - 30 minutes 

Instructions: 
PCS Company has implemented Siebel Call Center and has mapped their company’s business 
practices to the Siebel application.  In this scenario, you are PCS telesales representative Casey 
Cheng. You will walk through the telesales scenario described by the following process diagram: 

 
The vertical access separates the steps in the process that are performed by different people. This 
business process has been implemented using as-delivered Siebel functionality. 

1. Start the Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID CCHENG 
Password CCHENG 
Connect to Sample 

c. Click OK. 
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2. Unhide views used in the scenario: 
a. From the application-level menu, select Tools > User Preferences. 
b. In the link bar (under the screen tab) at the far-right, click the drop-down and select Tab 

Layout. 
Note: This view allows a user to customize the visible screens and views he or she sees in the 
application. Only views that the user has been granted access to appear here. 

c. In the top applet, query for Name = Contact.  Select the record. 
d. In the bottom applet, query for Name = Opportunities. 
e. In the bottom applet, uncheck the Hide column for the Opportunities record. 

Note: This will make the Contact > Opportunities view visible to this user. 
f. In the top applet, query for Name = Opportunities.  Select the record. 
g. In the bottom applet, query for Name = Products. 
h. In the bottom applet, uncheck the Hide column for the Products record. 

Note: This will make the Opportunities > Products view visible to this user. 
i. Step off the record to save the change. 

3. Restart the application. 
a. From the application-level menu, select File > Log Out. 
b. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
c. Enter: 

User ID CCHENG 
Password CCHENG 
Connect to Sample 

d. Click OK. 

4. You receive a call from a customer, Mike Carlson. Locate this customer in the Contacts list.  In 
an upcoming lab, you will see that this step may be automated using Siebel Call Center’s 
computer-telephony integration (CTI) technology.  For now, you will manually locate the 
contact. 
a. Select Contacts > My Contacts. 
b. Query for Mike Carlson in the Contacts list. (Last Name = Carlson) 
c. Which columns in the Contacts list have hyperlinks? 

 
              
Note: These hyperlinks are provided in the as-delivered application, and additional ones can 
be added to simplify navigation. 

d. Drill down on Mike Carlson’s last name (click Carlson). You are taken to a view that 
displays Contact details and Activities for this Contact.  

e. You decide to re-familiarize yourself with Mr. Carlson. Click the More Info view tab. 
f. What is Mike Carlson’s hobby? (In the Comments field) 
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g. After asking him about his tennis game, you ask Mr. Carlson whether the contact information 
you have is correct.  He says no. 

h. In the bottom applet, enter his new Work Phone # = (301) 496-8128.   
i. He also mentions that he’s working at a new location. You will enter the new account 

address. 

i. In the top applet, in Address, click the MVG icon . 
ii. Click New. 
iii. Enter: 

Address 1 300 Terrace Drive 
City Bethesda 
State MD 
Zip Code 20814 
Country USA 

iv. Click Save. 
v. In the Account Addresses dialog, click OK.  
vi. Verify that the new address is displayed in Mike Carlson’s contact record. 

5. Document the call by creating an activity. 
a. Click the Activities view tab. 
b. Click New in the Activities list applet. 
c. Add a new activity with: 

Type  Call - Inbound 
Description Request for quote  
Start Current time  

Set by default 

6. Create an opportunity record for Mr. Carlson’s inquiry. PCS will use this opportunity record to 
schedule follow-up sales activities, such as a sales visit or demonstration, if necessary.  
a. Select the Opportunities view tab. You may need to use the drop-down at the right of the 

view tab line. 
b. Click New.  

Note: The Add Opportunities applet is displayed. You may select an existing Opportunity, 
which would result in Mike Carlson being added as a contact to that Opportunity. However, 
Mr. Carlson’s request is a new Opportunity. 

c. Click New. 
d. Which columns are pre-populated in the new Opportunity list entry? 

 
               

e. Mr. Carlson informs you that he wants a quote on 5 PCS S7000 Network Router units, so 
enter Opportunity Name BAF PCS S7000 Network Router and save the record. 
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f. Drill down on the Opportunity Name. 
g. First, add the products: 

i. Click the Products view tab. 
ii. Add a new record with the following attributes: 

Product PCS S7000 Network Router 
Quantity 5 

h. In the Opportunity form applet, enter: 
Sales Stage Data Entry 

7. Generate the quote for Mike Carlson.  
a. Click the Quotes view tab. 
b. Click Automatic Quote. You may have to wait a few seconds before you see a new Quote 

record.  
c. From which price list is the Quote generated? 

 
              

d. Drill down on the Name for the quote. 
e. Click the Show More control in the upper right corner of the top applet. How long is the 

quote valid? 
 
               
 

f. What is the total amount of the quote?          
g. In a real customer interaction you could email the quote to the contact by generating a report 

for the quote, and then emailing or printing and faxing the quote report. However, in the 
sample application you are using there is no report to display a quote. You would document 
this gap and communicate this to the implementation team.  

h. Notice the thread bar at this point in the transaction.  
Note: You could drill down on the Contact or Opportunity links to quickly navigate back to 
an earlier step in the process. For example, if Mike Carlson now wanted to give you an 
alternate phone number, you could click the "Contact: Carlson" link to return to the Contacts 
Screen. 

i. Mike Carlson accepts the quote and is ready to purchase the five network routers. Click Auto 
Order to generate a Sales Order from the Quote. 

j. In a production system, you would click Submit to send the order to an external order 
management system. The sample application that you are using does not have that integration 
available.   

8. From the application-level menu, select File > Log Out. 
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Solutions 5-1  

Answers 

4.c. Which columns in the Contacts list have hyperlinks? 
Last Name, Account, and Email 

4.f. What is Mike Carlson’s hobby? (In the Comments field)  
Tennis 

6.d. Which columns are pre-populated in the new Opportunity list entry? 
Account, Revenue, Probability %, Sales Method, and Sales Team 

7.c. From which price list is the Quote generated? 
PCS Technologies Price List (HT ENU) 

7.e. Click the Show More control in the upper right corner of the top applet. How long is the 
quote valid? 
One day - you should see tomorrow's date in the Effective Through field 

7.f. What is the total amount of the quote? 
$85,000.00 
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Practice 6-1 Siebel Sales Scenario: Opportunities 

Goals Review a sales scenario using Siebel Sales 

Time 20 - 30 minutes 

Instructions: 

You will walk through a scenario that uses Siebel Sales to manage Opportunities. You are Terry 
Smythe, a PCS sales representative. Mr. Smythe uses the Siebel Mobile Web Client so that he can 
access critical customer data even while disconnected from a network. Because the classroom is not 
configured to demonstrate synchronization with a remote Siebel Server, you will skip that typical 
step, and instead you will assume that synchronization was recently completed. The Developer Web 
Client is like the Mobile Web Client. 

1. Start the Siebel Sales Developer Web Client:  
Note: Log in as Terry Smythe, a sales representative. 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Sales – 

ENU. 
b. Enter: 

User ID TSMYTHE 
Password TSMYTHE 
Connect to Sample 

c. Click OK. 

2. You will review the information for a new opportunity. 
a. Notice that TSMYTHE has different screen tabs than you have seen for other users, such as 

CCHENG, because he has customized Siebel Sales to expose sales-related areas that he 
frequently uses. 

b. Select Opportunities > My Opportunities. 
c. Drill down on the opportunity named PCS 4700 Desktops - 2500 units. 
d. What is the Account for this Opportunity? 

 
              

e. Mr. Smythe will manage the opportunity and move it through the sales pipeline until the 
opportunity has been won or lost. As this occurs, the Opportunity Sales Stage will change to 
reflect the O\opportunity’s progress in the sales process.   

f. Find the Sales Stage drop-down in the detail applet. What is the Sales Stage? 
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g. What is the Revenue for this opportunity? 
 
              

h. What is the Probability of conversion of this opportunity? 
 
              

i. Click the More Info view tab. 
j. Scroll down and locate the "Revenue Information" section of the lower applet.   
k. The Expected Value is equal to revenue times the probability of conversion. What is the 

expected revenue for this Opportunity? 
 
              

l. Set Sales Stage to 05 - Building Vision in the top applet. 
m. What is the new Expected Value? 

 
              

n. Click the Products view tab.  
o. Compare the product price with the revenue estimate. 

Note: The revenue for an opportunity is the sum of its product prices. This amount is then 
multiplied by the win probability % to get the Expected value of the opportunity. 

3. You will use the Target Account Selling (TAS) data for this account to formulate a strategy for 
this opportunity. 
a. Click the Target Account Selling view tab. 
b. Review the information on the TAS Overview page. 
c. What is the approximate annual revenue of Marriott International? 

 
              

d. What is PCS’s unique business value for this Opportunity? 
 
              
 
              

e. Click Competitive Analysis in the child applet link bar (under the view tabs).  Who is the 
competitor for this opportunity? 
 
              

f. Click Organizational Analysis in the child applet link bar to inspect the customer’s 
organizational chart and the personal characteristics and views of important customer 
contacts.   

g. If prompted, click Run. 
h. Which contact is the Account’s CIO? 

 
              

i. Click Relationship Strategy in the child applet link bar.   
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j. Notice that each contact for this opportunity is listed, as well as their business and personal 
agendas.   

k. Notice that the right-most column is used to label the relationship strategy chosen for each 
contact. The values available in this column are Neutralize (for a contact with objections to 
the sale), Leverage (for a contact supportive of the sale), and Motivate (for an undecided or 
neutral contact). 

4. PCS’s North American VP of Sales has decided to adopt a new sales methodology. This new 
methodology has fewer stages in the “sales pipeline”.  You will make two changes as a result of 
this methodology change: first, you will change the methodology for the opportunity you have 
been working with, and second, you will change your user preferences so that all new 
opportunities will use this methodology. 
a. Click the More Info view tab. 
b. What is the value of Sales Method? 

 
              

c. Use the drop-down for the Sales Method field to select Accelerated Sales Process.  
d. Save the record. 

Note: Siebel Sales includes several popular sales methods. In addition, sales administrators 
can define new sales methods. 

e. Notice that the Opportunity’s Sales Stage has been cleared.  Set it to 02 - Qualification and 
save the opportunity. 

f. Now you will set your user preferences to use this new sales methodology by default: 
i. In the application-level menu, select Tools > User Preferences. 
ii. Click the link bar drop-down arrow and select Price List & Sales Methodology. 
iii. Set Sales Methodology to Accelerated Sales Process. 
iv. Click Save. 

g. Select Opportunities > My Opportunities. 
h. Create an Opportunity named BAF Test Opportunity. 
i. In the bottom applet, click the Sales Stage drop-down arrow.  
j. Verify that the four stages are displayed. 

5. Stay logged in to Siebel Sales as TSMYTHE. 
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Solutions 6-1  

Answers 

2.d. What is the Account for this Opportunity? 
Marriott International HQ 

2.f. Find the Sales Stage drop-down in the detail applet. What is the Sales Stage? 
07 - Selected 

2.g. What is the Revenue for this Opportunity? 
$3,321,000.00 

2.h. What is the Probability of conversion of this opportunity? 
70 

2.k. The Expected Value is equal to revenue times the probability of conversion. What is the 
expected revenue for this Opportunity? 
$2,324,700.00 

2.m. What is the new Expected Value? 
$1,328,400.00 

3.c. What is the approximate annual revenue of Marriott International? 
$10.2 billion ($10,152,000,000.00) 

3.d. What is PCS’s unique business value for this Opportunity? 
Our [PCS's] PCs offer the best quality and are priced very well. 

3.e. Click Competitive Analysis in the child applet link bar.  Who is the competitor for this 
opportunity? 
Bull Computers 

3.h. Which contact is the Account’s CIO? 
Bob Jones 

4.b. What is the value of Sales Method? 
Standard Sales Process 
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Practice 6-2 Siebel Sales Scenario: Forecasting 

Goals Review a sales scenario using Siebel Sales 

Time 5 - 15 minutes 

Instructions: 

In this scenario Terry Smythe and his regional sales manager, Madison Stern, use Siebel Sales’ 
forecasting capabilities to project individual and regional revenues. You will continue as Terry 
Smythe, open an active forecast, and submit it to your manager. You will then log in as Madison 
Stern (MSTERN) and view the region’s aggregated forecasts. 

1. You should still be logged in to Siebel Sales as TSMYTHE.  If not, log in using the instructions 
in the previous lab. You will generate a quarterly forecast of revenues. 
a. Click the Forecasts screen tab. 
b. Locate the PCS 2007 - Desktop Forecast with Details record. 
c. Drill down on the Forecast Date. 
d. The Forecast Revenue is the sum of all opportunities' revenues. What is the Forecast 

Revenue for this forecast? 
 
              

e. The Expected Revenue is the sum of all opportunities' expected revenues. Recall that 
expected revenue for an opportunity is the conversion probability multiplied by the revenue. 
What is the Expected Revenue for the forecast? 
 
              

f. Click Submit to submit the forecast to Madison Stern, Terry Smythe’s sales manager. 
Note: Madison Stern can analyze subordinates’ forecasts even if they haven’t submitted 
them. A company might require submission of forecasts as a method for sales personnel to 
provide verification of their final forecasts. Once submitted, a subordinate’s forecast 
becomes read-only. 

g. Notice that the Status = Submitted. 

2. From the application-level menu, select File > Log Out. 
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3. Start the Siebel Sales Developer Web Client:  
Note: Log in Madison Stern, a regional sales manager at PCS. 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Sales – 

ENU. 
b. Enter: 

User ID MSTERN 
Password MSTERN 
Connect to Sample 

c. Click OK. 

4. You will generate a new quarterly forecast for your regional sales team. 
a. Click the Forecasts screen tab. 
b. Locate the forecast with Forecast Date 7/31/2007. 
c. Drill down on the Forecast Date. 
d. The child applet displays forecast details. In the current view it shows individual 

opportunities for MSTERN’s sales team.  
e. To view forecasts for individual sales representatives, click the Subordinates view tab.  

Which sales representative has the highest forecasted revenues? 
 
              

f. Verify that TSMYTHE's forecast has status Submitted. The other sales representatives' 
forecasts are Active, which indicate that they have not been submitted. Madison Stern can 
analyze subordinates’ forecasts even if they haven’t submitted them. A company might 
require submission of forecasts as a method for sales personnel to provide verification of 
their final forecasts. Once submitted, a subordinate’s forecast becomes read-only. 

g. Click the Details view tab and click Chart on the child applet’s link bar.  
h. Use the drop-downs above the chart to show Revenue by Week (Calendar). 
i. Click Go.  Notice how the quarter’s revenues are weighted towards the end of the quarter. 
j. Spend a few minutes navigating through the Forecast views. 

5. From the application-level menu, select File > Log Out. 
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Solutions 6-2  

Answers 

1.d. The Forecast Revenue is the sum of all opportunities' revenues. What is the Forecast 
Revenue for this forecast? 
$4,207,550.00 

1.e. The Expected Revenue is the sum of all opportunities' expected revenues. Recall that 
expected revenue for an opportunity is the conversion probability multiplied by the 
revenue. What is the Expected Revenue for the forecast?  
$2,707,105.00 

4.e. To view forecasts for individual sales representatives, click the Subordinates view tab.  
Which sales representative has the highest forecasted revenues? 
WTAKUDA 
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Practice 7-1 Siebel Call Center Scenario 

Goals Complete a service call center scenario using Siebel Call Center 

Time 10 - 15 minutes 

Instructions: 
You will review a “day-in-the-life” scenario involving two PCS Company employees – Casey 
Cheng, a call center representative, and Jon Rubin, a product expert. These two employees handle a 
customer service request. 

1. Log in to Siebel Call Center Developer Web Client:  
Note: Log in as Casey Cheng, a call center representative. 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID CCHENG 
Password CCHENG 
Connect to Sample 

c. Click OK. 

2. You will handle an incoming phone call from customer James Manning. In a production 
environment an incoming call could be handled efficiently using the Multi-Channel 
Communication Toolbar.  It provides computer-telephony integration, as well as email and Web 
integration, and alerts the call center agent that an incoming work item is available. When the 
new work item, a phone call in this case, is accepted, the calling number is used to automatically 
populate the Customer Dashboard with matching contact information. Because this functionality 
is not available in the classroom, you will start by opening the Customer Dashboard and locating 
the contact manually. 
a. Open the Customer Dashboard by selecting View > Open Customer Dashboard from the 

application-level menu. 
b. Select Contacts > Contacts List. 
c. Query for Last Name = Manning. Your query will return a single contact: James Manning. 
d. Click Update in the Customer Dashboard. You have populated this applet with the contact’s 

information.  This would have occurred without agent intervention upon acceptance of a new 
inbound work item in the Communications Toolbar. 
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3. Review customer activities and service requests (SRs) to help you better serve Mr. Manning. 
a. Make sure Activities is selected in the Go To drop-down in the Customer Dashboard and 

click Go. 
b. Query for activities that do not have status = Done: 

i. Click Query in the Activities applet. 
ii. Type <> "Done" in the Status list column. 
iii. Click Go. 
iv. Verify that all the activities are inbound calls from Mr. Manning. 

c. Select Service Requests from the view bar drop-down list. 
d. Verify that Casey Cheng has several SRs for James Manning. 

4. You will create a new SR for Mr. Manning’s issue and fill in relevant SR detail. 
a. Click New in the Service Requests child applet. 
b. Drill down on the new record’s SR #. 
c. Expand the top applet by clicking Show More  
d. Enter: 

Summary BAF Bad print quality 
Detailed Description Streaks on printer output 
Severity 3-Medium 
Priority 2-High 

e. Save the record. 

5. You will manually assign the service request to the appropriate product specialist, Jon . You will 
perform this assignment manually here, but will learn automatic assignment using Assignment 
Manager in an upcoming lesson. 
a. What are the values of Status and Substatus for the SR? 

 
              

b. Set Owner to JRUBIN. 
c. Set the Substatus to Assigned. 
d. Click Service Requests List on the link bar. 
e. Why doesn’t the newly created SR, with summary “BAF Bad print quality”, appear in the 

My Service Requests list? 
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6. Log in as PCS product specialist Jon Rubin. 
a. Select File > Connect to disconnect as CCHENG. 
b. Enter: 

User ID JRUBIN 
Password JRUBIN 
Connect to Sample 

c. Click OK. 
d. Select Service > My New Service Requests. 
e. Verify that the recently created SR appears for JRUBIN (Summary = BAF Bad print quality). 
f. Drill down on this record’s SR # to get a description of the customer issue. 

7. Use the Solutions database to find a resolution to the SR. This is one simple approach to finding 
information regarding a customer issue. If a resolution was not found in the Solutions database, 
then he could also query on other SRs. A broader search could use Siebel Search, which allows 
searches on the entire Siebel application database.   
a. Select the Solutions view tab. 
b. You can access Solution information in this applet. Click Add. 
c. In the Add Solutions dialog box, use the Find and Starting With fields to query for a 

Description starting with *printer*. This will return all Solutions with the substring “printer” 
in their descriptions. This is a reasonable first step in finding a resolution to the SR. 

d. Which Solution looks as if it has something to do with print quality? 
 
              

e. Select the record named Inconsistent Printer Image and click Add. 

8. Take the actions necessary to close the SR: create an activity documenting the time JRUBIN 
spent on the SR, and setting its status to Closed. Normally, you would communicate the 
resolution to the customer by email or phone. 
a. Click the Activities view tab. 
b. Click New and enter: 

Description Used solutions database to resolve 
Type Analyst 
Start Current date 
Status Done  

c. Save the record. 
d. Set the SR’s Status to Closed. 
e. What is the new value for Substatus? 

 
              

9. From the application-level menu, select File > Log Out. 
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Solutions 7-1  

Answers 

5.a. What are the values of Status and Substatus for the SR? 
Open and Unassigned 

5.e. Why doesn’t the newly created SR, with summary “Bad print quality”, appear in the My 
Service Requests list? 
Service Requests have a single owner, and the My Service Requests view only displays SRs 
with Owner equal to the current user.  CCHENG no longer is the owner of the SR, so 
Casey Cheng no longer sees the record. 

7.d. Which Solution looks as if it has something to do with print quality? 
Inconsistent Printer Image 

8.e. What is the new value for Substatus? 
Resolved 
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Practice 8-1 Exploring Audit Trail  

Goals Explore Siebel Audit Trail functionality 

Time 5 - 10 minutes 

Instructions: 
In this lab, you will use Audit Trail to examine changes that have been made to opportunities.  

1. Start the Siebel Call Center Developer Web Client connecting to the Server database: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Server 

c. Click OK. 

2. Create an opportunity. 
a. Navigate to Opportunities > Opportunities List. 
b. Create a new opportunity record with:  

Opportunity Name BAF Plasma Monitor 
Sales Cycle Data Entry 
Close Date Current date 

In the detail applet 
c. Select Help > About Record and record the Row #:        
d. Click OK. 

3. Inspect the audit trail. 
a. Navigate to Audit Trail > Audit Trail Items.  You should see several records. 
b. Inspect the field values.   
c. Notice that the Employee Login is recorded so you know who made the change. 
d. Notice that the Business Component is recorded so you know the data entity. 
e. Various Fields are listed.  

Note: You can set up which fields you want to track in the Audit Administration screen. 
Several are entered as part of seed data and become active when auditing is turned on. 

f. Notice that the Operation is New Record and the New Value reflects what you entered. There 
is no value in Old Value since the record is new. 
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g. Scroll to the right to locate the Record ID. It should match the value you recorded above. 
Note: This allows you to determine the exact row/record that was added or changed. 

4. Change the opportunity record. 
a. Navigate to Opportunities > Opportunities List. 
b. Select BAF Plasma Monitor. 
c. Change the Opportunity Name to BAF Plasma Monitor-Update. 
d. Change the Sales Cycle to Approved. 

5. Examine how changes to existing records are reported in the audit trail. 
a. Navigate to Audit Trail > Audit Trail Items.   

Note: The audit trail should display the most recent changes at the top of the list. If it does 
not, sort by the Date column descending. 

b. Notice that the Operation is Modify. 
c. Notice that the old and new values are recorded. 

6. Examine the audit trail administration. 
a. Navigate to Administration - Audit Trail. 
b. Query for Bus Comp = Opportunity. 
c. Notice that you can set the type of operation to update (such as Update, New, Delete, and so 

on). 
d. In the bottom applet, you can set the data/fields you want to capture. 

Note: Other view tabs allow you to restrict auditing to specific positions, responsibilities, or 
users. You can work with your administrator to set up or change these items. 

7. In the application-level menu, select File > Log Out. 
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Practice 8-2 Using iHelp  

Goals Use Siebel iHelp to complete a Service Request 

Time 5 - 10 minutes 

Instructions: 
You are Jon Rubin, a newly-hired sales rep who is handling a call from a customer inquiring about 
your company’s products. You will use Siebel iHelp to create a new Account. 

1. Start the Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID JRUBIN 
Password JRUBIN 
Connect to Sample 

c. Click OK. 

2. Use iHelp to create an account. 
a. Select the Accounts screen tab. 
b. Click How Do I on the application toolbar. 
c. If necessary, click Install to install the iHelp browser controls. 
d. In the iHelp pane on the left, click Create a New Account. 
e. Examine the iHelp steps.  
f. Notice that the iHelp item includes what look like navigation links. 
g. In step 1, click My Accounts View. This step navigates you to the My Accounts view. 
h. Perform step 2 in the iHelp item. 
i. Click step 3 in the iHelp pane. It expands and is highlighted in yellow. 
j. Notice the form applet has several fields highlighted in a very pale yellow. This helps the 

user target the required fields. 
k. Enter: 

Account Name BAF_Oracle 
Site 123 Oracle Drive 
Main Phone # 6505551212 
Main Fax # 6505551211 

l. Click step 4 of the iHelp. 
m. Follow the instructions and add TARNOLD to the Account Team. 
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n. Click step 5 and click the Account Profile view.  
Note: You don't have to enter any data. Remember, iHelp is advisory and does not enforce 
user behavior. 

o. Follow the instructions in steps 6 and 7. Add a new contact, Jane Adderly-BAF.  
p. Close the iHelp pane when you are done. 

3. Explore another way to access iHelp. 
a. From the application menu, select Navigate > Go to iHelp Map. All available iHelp items are 

displayed in a manner similar to the Site Map. 
b. Scroll through the list to familiarize yourself with the various iHelp items. 
c. Scroll back to the top of the list. 
d. Click the Create a New Account. 
e. Click the My Accounts View hyperlink in the iHelp item's step 1. Notice that you have been 

navigated to the same view displayed when you accessed this iHelp item via the Accounts 
Home page. 

4. From the application-level menu, select File > Log Out. 
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Practice 8-3 Modifying an iHelp Item (Optional) 

Goals Use the iHelp Designer to modify an existing iHelp item 

Time 20 - 25 minutes 

Instructions: 

BAF Company's process for creating service requests (SRs) has changed: agents are expected to add 
an asset number to an SR. An asset record is created when the customer registers a product at BAF's 
Web site. This asset record tracks the product, its serial number, and configuration. BAF has 
changed its support policy so that only registered products are supported, and the new step in the SR 
process enforces this policy. 

You will modify the “Create a New Service Request” iHelp item by adding two steps that remind 
service agents to add an asset number to the SR. 

1. Start the Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Examine the existing Create a New Service Request iHelp item and gather information you will 
need when you modify the iHelp item. 
a. Click the Service screen tab. 
b. Click "How Do I" . 
c. In the iHelp pane on the left, drill down on Create a New Service Request. 
d. Click the hyperlink in the iHelp item's step 1. 
e. Click New to create a SR. 
f. Drill down on the SR #. 
g. Use the view tab drop-down and select More Info. 
h. In the lower applet, locate the Asset # control. This is the field that service agents will 

populate.  
i. In the Asset # textbox, click the Select control. 
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j. Verify that the pick applet has a Serial # column.  
Note: The service agent will ask the customer for the product serial number and query for the 
value that the customer supplies. The matching serial number should be matched with the 
Asset # of a registered product. 

k. Click Cancel. 
l. Select Help > About View from the application-level menu. 
m. Verify that the name of the view is Service Request More Info View. You will need this view 

name to add a hyperlink to the iHelp item. 
Note: the information available in About View is discussed extensively in a subsequent 
lesson. 

n. Click OK to close About View. 

3. Revise the iHelp item in the iHelp Designer and add the first new step. 
a. Navigate to Administration - iHelp > All iHelp Items. 

Note: Administration - iHelp is at the end of the list of Administrative screens in the Site 
Map. 

b. In the top applet, query for Name = Create a New Service Request. 
c. Verify that the query returns two matching items. You should see two different versions of 

the same item: the current version has Status = Active, and the prior version has Status = 
Outdated. 

d. Select the active version of Create a New Service Request. 
e. Click Revise. 
f. Confirm that there is a new version of the iHelp item with Status = In Progress. 
g. Drill down on the new version's name. 
h. If prompted, click Run in the Warning - Security dialog. This loads the iHelp Designer code. 
i. Examine the iHelp layout. Each shape in the iHelp Designer corresponds to a step in the 

iHelp items shown in the left-hand pane.  
j. In the Designer pane, double-click the Navigate step. 
k. Scroll down to examine the applet immediately below the Designer.  

Note: This applet shows step properties.  
l. Notice the Caption and View fields: they implement the hyperlink in the first step of the 

iHelp item. The Caption value is: 
Navigate to the Service Request Screen > <v>My Service Requests View</v>. 
The <v>…</v> tag is similar to an HTML tag, and signifies a hyperlink. The View field 
contains the view that the hyperlink, if any, navigates to. 

m. Scroll up an add a new step to the flow by dragging a Step from the Task palette and 
dropping it to the right of the last step, which is labeled Subarea. You should see a new flow: 
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n. Double-click the new step.  
o. Add information to the lower applet to support navigation to the Service Request More Info 

View, which you identified in an earlier step: 
Name Navigate to More Info  
View Service Request More Info View 
Caption Navigate to the <v>SR More Info View</v>. 
Section Label Add an Asset to the SR 
Note: The Section Label creates a heading before steps. Create a New Service Request has 
three headings: _Create New Record, _Affiliate a Customer, Define Service Request. 

p. In the bottom applet, select Menu > Save Record. 
q. Drag a Branch from the Task palette and drop it on both the Subarea and Navigate to More 

Info steps in the iHelp Designer. You should see: 

 
Note: The red dot indicates that the branch has connected to the Subarea step, while the white 
end of the branch indicates that it is not connected to the next step. 

r. Drag the arrow end at the right of the of the branch until it connects to the left-hand side of 
the Navigate to More Info step. This is signaled by the end turning red. 

4. Add a second step to the iHelp item. This step will ask service agents to add an Asset # to the 
SR, and will highlight this control in the More Info form applet. 
a. Drag a Step from the Task palette and drop it below the Navigate to More Info step. 
b. Double-click the new step. 
c. In the bottom applet, set: 

Name Add Asset # 
View Service Request More Info View 
Caption Add an <b>Asset #</b> to the SR by opening 

the pick applet and querying for the Serial # 
provided by the customer. 

d. In the bottom applet, select Menu > Save Record. 
e. Drag a Branch from the Task palette and drop it on the Navigate to More Info step. 
f. Drag the ends of the branch until it is connected to the bottom of the Navigate to More Info 

step and the top of the Add Asset # step: 

 
g. Highlight the Asset # control in the More Info applet for this step. 

i. Double-click the Add Asset # step. 
ii. In the bottom explorer applet at the left, select Field and Button Highlights. 
iii. In the Field and Button Highlights applet to the right of the Explorer, click New. 
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iv. In the Applet column, click the Select control. 
v. Confirm that two applets appear. 

Note: These are the two applets that appear in the Service Request More Info View. 
Because you set the View for the Add Asset # iHelp step, only the two relevant applets 
appear as choices.  

vi. Select Service Request More Info Applet and click OK. 
vii. Enter Asset Number in the Field or Button column. 
viii. Select Menu > Save Record. 

5. Add responsibilities to the modified iHelp item and activate it. 
a. In the middle of the screen, click the Responsibilities view tab. 
b. In Responsibilities list, check the Active Flag for Siebel Administrator. 

Note: An iHelp item must have one or more active responsibilities before it is activated. You 
only made the iHelp item active for the Siebel Administrator responsibility to support testing.  

c. Click the More Info view tab. 
d. In the top applet, select the In Progress version of Create a New Service Request, if 

necessary. 
e. Click Activate. 
f. Verify that the latest version of the iHelp item is now Active and older versions are Outdated. 

6. Test the modified iHelp item. 
a. Close the iHelp pane by clicking the X in its upper right corner.   
b. Click "How Do I" on the application toolbar. 
c. In the iHelp items list on the left, click Create a New Service Request. 
d. Verify that the two new steps (8 and 9) and section heading appear in the iHelp pane. 
e. Drill down on the link in step 1. 
f. Create a service request. 
g. Skip steps 3 to 7 in the iHelp item and click on the hyperlink in step 8. 
h. Verify that the new SR is shown in the upper detail applet and that you are now in the 

Service Request More Info view (the More Info tab is active). 
i. Select step 9 in the iHelp item. 
j. In the bottom applet, verify that the Asset # control is highlighted in yellow. 

Note: The highlighting is very faint, so you may have to look closely! 
k. Close the iHelp pane. 

7. From the application-level menu, select File > Log Out. 
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Practice 8-4 Using Siebel Reports  

Goals Run a report in Siebel Call Center 
Watch a recorded demonstration of advanced reports functionality 

Time 5 - 10 minutes 

Instructions: 
In this practice, you will generate a report in the Siebel sample application. More advanced reports 
behavior cannot be demonstrated in the sample application, which does not include a standalone BI 
Publisher Reports Server. 

1. Start the Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID CCHENG 
Password CCHENG 
Connect to Sample 

c. Click OK. 

2. Generate a contact report. 
a. Select Contacts > My Contacts. 
b. Click the Reports  button on the application toolbar. You see a list of reports available in 

this view. 
c. Select Alphabetic Phone List. 

Note: This will generate an alphabetic list of all the contacts in the view. 
d. In the Output Type dialog, select HTML and click Submit.  

Note: It may take a minute to generate the report. 
e. In the File Download dialog, click Open. 
f. Examine the report. It should match the information displayed in the contact list. 

Note that it is one long list (no page breaks). 
g. Close the browser displaying the report. 
h. Select All Contacts in the Visibility Filter. 
i. Query for Last Name = A. 
j. Select Reports > Alphabetic Phone List. 
k. This time select PDF as the Output Type. 
l. Click Submit.  
m. When the File Download dialog appears, click Open. 
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n. Notice that the PDF format has page breaks. 
Note: Casey could save, email, or print the report. You will not do so here. 

o. Close the report. 
p. Click Close to close the Output Type dialog. 

3. Locate the template for the report you just generated. Siebel applications ship with a number of 
pre-configured reports. Reports are administered in the Siebel client. 
a. Navigate to Administration - BIP Reports > Report Template Registration. This view lists 

available report templates. 
b. Query for Report Name = Alphabetical Phone List. 
c. Note that the report template can have specific start and end dates.  Also, examine the child 

Report Template Translation applet. A single report can support multiple translations. 
d. Drill down on the report's Template field. 
e. Click Open. 
f. Examine the report's template. It uses special codes for Contact field names, and also 

contains control codes that format the output and provide header information, such as page 
number and date. 

g. When done, close the template file. 

4. From the application-level menu, select File > Log Out. 

5. (Optional) View a recorded demonstration on advanced report features.  
Note: there is no sound. This is text only. 
a. Use Windows to navigate to D:\labs\BusinessAnalyst\Report_Features. 
b. Double-click report_features_viewlet_swf.html. 
c. View the demonstration. You can use the controls at the bottom of the browser window to 

pause, rewind, forward, or otherwise control the demo presentation. 
d. When you have finished watching the demo, close the browser. 
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Practice 8-5 Using Siebel Search and Find  

Goals Watch a recorded demonstration of Siebel Search  

Time ~5 minutes 

Instructions: 
Siebel Search functionality is not available in the sample application. You will watch a recorded 
demonstration of Siebel Search and Find functionality. 

1. Open the demonstration recording. 
a. Use Windows to navigate to D:\labs\BusinessAnalyst\Search_and_Find. 
b. Double-click search_and_find_viewlet_swf.html. 
c. View the demonstration. You can use the controls at the bottom of the browser window to 

pause, rewind, forward, or otherwise control the demo presentation. 

2. When you have finished watching the demo, close the browser. 
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Practice 9-1 Exploring Administrative Functionality 

Goals Perform administrative functions in Siebel applications 

Time 30 - 45 minutes 

Instructions: 
You will perform several application administration tasks as SADMIN, a Siebel administrator at 
BAF Company.  These tasks will introduce you to the rich functionality available to administrative 
users of Siebel applications.   

Some Siebel administrative tasks can be performed by relatively non-technical users, such as a 
member of a sales or service operations group, while other tasks require technical expertise or 
significant domain knowledge, such as pricing administration.  This practice will focus on the less 
technical administration, although you will explore the product and pricing administration screens. 
Technical administration screens used in Siebel server administration will be seen in a subsequent 
practice. 

1. Start the Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Examine the screens available in the Site Map for SADMIN. 
a. Click Site Map. 
b. Verify that SADMIN has available many administrative screens (starting with 

Administration -). A large number of these screens allow administration for a specific Siebel 
function, such as Administration - iHelp or Administration - Inbox, while others are more 
general, such as Administration - Application or Administration - Data. You will explore 
several of the latter. 

c. Navigate to Administration - Application > View Links. 
d. Examine the link bar and the link bar drop-down list.  
e. Notice that the Administration - Application screen, unlike the Accounts or Contacts screens, 

has views that show a wide range of entities.  
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3. You have been asked to create a view link on the Contacts page to allow end users to quickly 
access contacts from Gold accounts. BAF grants Gold status to its largest, most-valued 
customers. Currently, there are two Gold accounts: Honeywell and Marriott International.  
a. Before you can create a view link, you must create and save a query to find Gold contacts. 

i. Select Contacts. 
ii. What are the view links on the left side of the Contacts Home Page? 

 
              

iii. Click Contacts List on the link bar. 
iv. Click Query. 
v. Click Query Assistant. 
vi. Populate the first two rows of the query assistant with: 

Field Operator Value 

Account Contains Honeywell 

Account Contains Marriott 
vii. In the drop-down titled "Perform Query using", select OR. 
viii. Verify that the query is shown in the bottom text box as: 

Show Contacts where: Account Contains Honeywell OR Account Contains Marriott 
ix. Click Go. 
x. Notice that there are no matching records. SADMIN does not have any contacts in these 

accounts. 
xi. Select All Accounts Across Organizations in the Visibility Filter. 
xii. Verify that all records returned by the query have substrings "Honeywell" or "Marriott" 

in the Account column. 
xiii. In the applications menu, select Query > Save Query As. 
xiv. In the Save Query As dialog, set Query Name to BAF Gold Contacts and click OK. 
xv. Verify that the Saved Query is shown in the Saved Queries drop-down in the upper right. 

b. Navigate to Administration - Application > Predefined Queries. You will make the Gold 
Contacts query available to all users. 

c. Query for Name = BAF Gold Contacts. 
d. Click the Private column. Notice the query is marked as Private, which means that it is only 

available to its creator, SADMIN. 
e. Uncheck the Private field. 
f. Select View Links from the link bar drop-down list. 
g. Select Contacts in the top applet. 
h. Examine the Active view links in the bottom applet and match them with the view links you 

recorded in an earlier step. 
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i. Create a new view link with: 
Sequence 4 
Active Checked 
Name BAF Gold Contacts 
Description Contacts from Gold Accounts 
View Contact List View 
Default Query BAF Gold Contacts 

 The sequence determines the order in which the view links appear, while the View is the 
view shown when the user clicks the view link, and the Default Query operates on records 
that appear in that view. The View name, Contact List View, can be found using Help > 
About View while in the Contacts List View. 

j. Save the record. 
k. Test your work by selecting the Contacts screen tab. You should see the new view link. 
l. Click BAF Gold Contacts. Remember that SADMIN has no contacts from Gold accounts. 
m. Verify that BAF Gold Contacts appears in the Saved Queries drop-down. 
n. Select All Contacts Across Organizations in the Visibility Filter. 
o. Verify that contacts from Honeywell and Marriot accounts appear. 
p. Open a second Siebel Call Center session as Casey Cheng to verify that other users can also 

see the link. Leave SADMIN's session open. 
i. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
ii. Enter: 

User ID CCHENG 
Password CCHENG 
Connect to Sample 

iii. Click OK. 
q. In CCHENG's session, select the Contacts screen tab. 
r. Verify that the BAF Gold Contacts view link appears.  
s. Click BAF Gold Contacts.  
t. Verify that only Honeywell and Marriott contacts appear in the contacts list. Also notice that 

the BAF Gold Contacts saved query is visible for Casey Cheng. 
u. In CCHENG's session, select File > Log Out. 
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4. SADMIN has been asked to create sales reporting periods for BAF for their 2010 fiscal year, 
which starts February 1, 2010. BAF only needs to generate revenue and bookings reports 
quarterly. 
a. In SADMIN's Call Center session, navigate to Administration - Data > Periods. 
b. Create a period definition for fiscal year 2010: 

i. Click New in the top applet. 
ii. Enter: 

Period BAF FY2010 
Start 02/01/2010 
End 01/31/2011 
Type Year 
Description Fiscal year 2010 

iii. Save the record 
c. In the top applet, enter four additional records: 

Period Start End Type Description Fiscal Year 

BAF Q1 FY2010 02/01/2010 04/30/2010 Quarter Q1 of FY2010 BAF FY2010 

BAF Q2 FY2010 05/01/2010 07/31/2010 Quarter Q2 of FY2010 BAF FY2010 

BAF Q3 FY2010 08/01/2010 10/30/2010 Quarter Q3 of FY2010 BAF FY2010 

BAF Q4 FY2010 11/01/2010 01/31/2011 Quarter Q4 of FY2010 BAF FY2010 
Note: Periods use data validation to ensure that the Start date precedes the End date. This 
validation is very simple, so it does not require Siebel Data Validation Manager, but instead 
the validation criteria are configured in Siebel Tools. You will learn about validation criteria 
and messages in a subsequent lesson. 
i. Create a new Period definition with: 

Period BAF Bad Year 
Start 01/01/2010 

ii. Enter End = 01/01/2009, a date before the Start date of the period and tab out. 
iii. What happens? 

 
              

iv. Click OK in the error dialog. 
v. What is the End date? 

 
              

vi. Select Menu > Undo Record to remove the BAF Bad Year record. 
Note: You are not able to test the new quarterly periods you just created. Periods are used in 
a variety of different areas in a Siebel application, such as Time Sheets, Expense Reports, 
and Forecasts. All of these facilities are configured in the sample application to use a weekly 
period rather than a quarterly one. Changing this behavior would require configuration using 
Siebel Tools, which you will use in subsequent practices. Although the changes required in 
Siebel Tools are relatively modest, they are beyond the scope of this training. 
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5. Explore the Administration - Product screen, which allows product administrators to create 
complex, customizable product definitions. This brief exploration will give you an overview of 
product support in Siebel applications. 
a. Click the Administration - Product screen tab. 
b. Query in the Products applet for Name = PCS 6000.  

Note: This desktop computer is part of PCS Technologies' desktop product line. The PCS 
6000 can be customized by the customer as part of a purchase. The customer can accept a 
default configuration or make another choice, such as selecting a 19 inch monitor, rather than 
the default 17 inch monitor. 

c. What is the Product Line for the PCS 6000? 
 
              

d. Notice that the Structure Type field in the detail applet = Customizable. 
e. Drill down on the product name. You have navigated to a set of views that display product 

details. 
f. Select the Pricing view tab. 
g. Click Price Lists from the view tab link bar. 
h. Which price lists is the PCS 6000 listed in and at what prices? 

 
              

i. Click Product Definitions on the top link bar.  
Note: This is where a product is defined. In particular, this is where a component-based, 
customizable product is assembled from components and where available component choices 
are defined. 

j. Click the Work Space link in the Versions applet.   
Note: Product definitions are versioned, which allows a product administrator to create 
variations on an existing product without losing previous product definition versions. 

k. Examine the Structure list applet.  
Note: This applet shows the different types of components (Relationships) that make up a 
component-based product.   

l. What are the four Relationships for the PCS 6000? 
 
              

m. Select Monitor in the Structure list. 
n. Scroll down and examine the Relationship Domain (bottom applet), which represents choices 

for populating a specified component.  
o. Notice that two different monitors are available for this computer. 
p. Explore the other component choices for the PCS 6000 by selecting records in the Structure 

applet. 

6. Explore pricing administration. This administration screen offers a wide range of very powerful 
tools for setting pricing and discounting policies. 
a. Navigate to Administration - Pricing > Price Lists.  

Note: A price list has effective start and end dates and a currency, and contains product 
prices. 
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b. Query for Name = Master Price List. 
c. Drill down on this list's name. 
d. In the Price List Line Items list, query for Product = PCS 6000. 
e. Verify that the PCS 6000's price matches what you found in the Administration - Product 

screen. 
f. In the top applet, create a price list with: 

Price List BAF Test Price List 
Effective From Current date 

Effective To One year from now 
g. In the Price List Line Items list, create a record with: 

Product PCS 6000 
Query in the  pick applet and click Add 

List Price 1125.00 
h. In the top applet, click Clear Cache.  

Note: Price lists are cached by the Siebel application to provide faster quote and order 
generation. You have just flushed this price cache so that it will use the new price list. 

i. Verify that the new price is available for quotes: 
i. Navigate to Quotes > List. 
ii. Create a quote with Name = BAF PCS 6000 Test Quote. 
iii. Drill down on the quote's Name. If prompted, click Install. 
iv. In the top applet, set the Price List for the quote to BAF Test Price List. 
v. If necessary, click the Line Items view tab. 
vi. Add a line item with: 

Product PCS 6000 
Quantity 2 

vii. Save the record. 
viii. Verify that the unit Net Price is $1,125.00. 
ix. If necessary, click the + to the left of the Line #.  
x. Verify that the product components appear beneath the PCS 6000 line item. 
xi. Click the Catalog view tab. 
xii. In the catalog Navigator, click the Computer & Office link. 
xiii. In the Categories list, click the Desktops link. 
xiv. Verify that the correct price appears in the catalog entry for the PCS 6000. 
xv. If you wish to explore the catalog Navigator further, click Customize in the left applet.  

After installing the Siebel Configurator applet, you will see a page that allows a sales 
agent or a customer to configure this product. The choices available match those you saw 
in the PCS 6000 product definition. 

7. From the application-level menu, select File > Log Out. 
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Solutions 9-1  

Answers 

3.a.ii. What are the view links on the left side of the Contacts Home Page? 
My Contacts, All Contacts, Top Tier, and My Personal Contacts 

4.c.iii What happens? 
An error dialog pops up and specifies the error condition: the Start date is after the End 
date. 

4.c.v. What is the End date? 
It is empty -- the validation rule would not allow a bad value to be entered. 

5.c. What is the Product Line for the PCS 6000? 
Computers 

5.h. Which price lists is the PCS 6000 listed in and at what prices? 
Master Price List $999 and PCS Technologies Price List (HT ENU) $1099 

5.l. What are the four Relationships for the PCS 6000? 
Processor, Hard Drive, Monitor, and Memory 
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Practice 10-1 Exploring the Siebel Web Architecture 

Goals Explore major parts of the Siebel Web architecture 

Time 15 - 20 minutes 

Instructions: 

In this lab you will explore the Siebel Web architecture.  Most labs in this course use the Siebel 
Developer Web Client with a local, sample database.  This thick client depends on an executable, 
siebel.exe, on your Windows host to allow standalone access to Siebel data in the sample database.  
However, users of a production system will use the more powerful Siebel Web architecture.  

Your lab machine is also configured to provide all of the components of the Siebel Web architecture. 
As the following diagram suggests, these components include a Web server, Siebel Gateway Name 
Server, Siebel Server, and server database. 

 

Having all of these components running on one machine would typically not occur on a production 
system, but allows demonstration of the Web architecture on classroom machines. 

 Siebel Web Client Web Server 

 

Siebel Gateway Name 
Server

Database 
Server 

Enterprise

 Siebel File 
System 

 Siebel Server(s) 

Lab Machine 
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1. Start the Siebel Server, which is shut down for most practices to improve lab machine 
performance. 
a. Select Start > Programs > Administrative Tools > Services.  If you do not have this item, 

select Start > Settings > Control Panel > Administrative Tools and double-click Services. 
b. Scroll down and find a service named Siebel Server [OUEnt_OUSrvr]. 
c. Right-click this service and select Start. 

Note: It will take a minute or so for the Siebel Server to start up, and you can use Windows' 
Task Manager to monitor this process.  

d. Right-click the Windows Taskbar and select Task Manager.  Click the Performance tab.  
When the CPU Usage drops down to near 0% and stays there for a few seconds, then the 
Siebel Server has completed its startup. 

e. Minimize the Task Manager window. 
f. Minimize the Services window. 

2. Log in to Siebel Call Center using the Siebel Web client.  You will use the login for SADMIN, a 
pre-configured user with access to the complete application, including administrative screens you 
will use to explore the Siebel Web architecture. 
a. Select Start > Programs > Internet Explorer 
b. Enter Address: http://localhost/callcenter_enu. 

Note: This directs the browser to the Web server on your classroom machine (localhost) to an 
application- and language-specific page (callcenter_enu). 

c. Enter: 
User ID SADMIN 
Password SADMIN 

d. Click the arrow. 

3. Explore the data and views available to SADMIN. 
a. Click the Site Map icon. As you saw in earlier practices, SADMIN has access to almost all 

screens, including a large number of administrative screens. 
b. Navigate to Service Requests > Service Request List. 
c. Select All Service Requests across Organizations. 
d. You should see no data, unlike the large number you saw in earlier labs. This suggests that 

you are accessing a different data source than in earlier labs, where you were accessing the 
sample database. 

4. Examine the configuration of your classroom machine’s Siebel installation.  In particular, you 
will identify the Siebel Enterprise, Siebel Server, and examine available component groups. 
a. Navigate to Administration - Server Configuration > Enterprises.  

Note: The Server Configuration administrative screen is the primary place for configuring the 
Siebel Server and its components, and is typically used by a system administrator 

b. Examine the top applet.  What is the name of the Siebel Enterprise?      
c. Click Servers in the link bar. 
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d. What is the name of the Siebel Server?         
e. What is its installation directory? 

 
              

f. Click Enterprises in the link bar. 
g. The Component Groups child applet lists component groups and their state in the Siebel 

Enterprise.  Click Query in this applet. 
h. Query for Alias EAI. 
i. What is the name?  (You may have to increase the width of the column.) 

 
              

j. The lower-left applet, titled Components, displays the components that belong to the selected 
component group.  Verify that the EAI component group includes ten components. 

5. Examine some of the characteristics of server components. 
a. Click the Component Definitions view tab. This view displays all server components for a 

Siebel Enterprise, as well as component parameters that determine the component’s behavior. 
Note: An important type of server component is application object managers (AOMs).  These 
components provide support for user interactions with Siebel applications.  

b. In the Component Definitions applet, query for *Object Manager* in the Component field.  
You will see a large number of object managers, most of them for various Siebel 
applications. 

c. Select Call Center Object Manager (ENU). 
d. Examine the parameters list below in the bottom left applet.  Each component has parameters 

that condition its behavior and can be configured independently.  When you select a 
component, a detailed description appears in the bottom-right applet. 

e. Minimize the Siebel Web client. 

6. Determine the location of the Siebel Repository File (.srf), using Siebel Call Center’s 
configuration file (uagent.cfg).   
Technical Note: Parameters described in the Siebel server directory’s .cfg files (example: 
…\siebsrvr\BIN\ENU\uagent.cfg) have been mostly been replaced by server component 
parameters. Sections in the .cfg file where these replaced parameters occur are marked with 
comments stating, “client-only section”. Parameters in these marked sections are only used by 
the Siebel Web Developer Client or the Siebel Mobile Web Client.  This lab, however, will still 
find the default location of the .srf file, as this unused parameter in the .cfg file still points to the 
correct default location. 
a. Use Windows, to navigate to D:\OUSea\siebsrvr\BIN\ENU. 
b. Scroll down and right-click uagent.cfg. 
c. Select Open. 
d. Choose "Select the program from a list" and click OK. 
e. Select Notepad from the list. 
f. Leave the check mark in "Always use the selected program to open this kind of file". 
g. Click OK. 
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h. The configuration file contains parameters as name/value pairs.  What is the value of the 
ApplicationTitle parameter? 
 
              

i. What is the ApplicationName? 
 
              

j. What is the value of RepositoryFile? 
 
              

k. Return to the open Siebel Web client session. 
l. Select Help > About SRF. 
m. Confirm that the file name given in this dialog box matches what you found in uagent.cfg. 
n. In which directory is the repository file located? 

 
              

o. Click OK to close the About SRF dialog box. 
p. Close uagent.cfg, but leave your Siebel Web client open. 

7. From the application-level menu, select File > Log Out. 

8. Do not shut down the Siebel Server, as you will use it in one of the next practices. 
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Solutions 10-1  

Answers 

4.b. Examine the top applet. What is the name of the Siebel Enterprise? 
OUEnt 

4.d. What is the name of the Siebel Server? 
OUSrvr 

4.e. What is its installation directory? 
d:\OUSea\siebsrvr\ 

4.i. What is the name?  (You may have to increase the width of the column.) 
Enterprise Application Integration 

6.h. The configuration file contains parameters as name/value pairs.  What is the value of the 
ApplicationTitle parameter? 
Siebel Call Center 

5.g. What is the ApplicationName? 
Siebel Universal Agent 

5.h. What is the value of RepositoryFile? 
siebel_sia.srf 

5.l. In which directory is the repository located? 
D:\OUSea\siebsrvr\OBJECTS\ENU 

6.m. Are there any records in this table? 
No  
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Practice 11-1 Exploring Divisions and Positions 

Goals Examine division and position hierarchies 
Explore how an employee’s position and organization affect data visibility 

Time 15 - 20 minutes 

Instructions: 
In this practice, you will examine the existing division and position hierarchies in the Sample 
database. You will then log in as two different users with different positions, and examine how 
positions affect data visibility. 

1. Start the Siebel Call Center Developer Web Client.  
Note: You will log in as SADMIN, who as an administrator, has access to the views used to 
administer positions, responsibilities, divisions, and organizations. 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Explore the division hierarchy. In particular, explore the hierarchy used by our sample users, 
Casey Cheng and Vic Taylor. 
a. Navigate to Administration - Group > Internal Divisions.  

Note: that the explorer applet on the left lists all divisions and organizations. 
b. In the list applet, query for Division Name = Default Organization.  

Note: Default Organization is the top-level organization in the application. 
c. Select Default Organization and examine the form applet in the lower right. 
d. Verify that the Organization Flag is checked. 
e. Notice that Parent Division is empty. This indicates that Default Organization is a top-level 

division. (Recall that organizations are a special type of division). 
f. In the explorer on the left, expand Default Organization and select Manufacturing Default 

Organization. 
g. Notice that the Organization Flag is checked, the Organization Name is Manufacturing 

Default Organization (MAN ENU), and the Parent Division is Default Organization. 
h. In the explorer applet, click the + next to Manufacturing Default Organization to expand its 

hierarchy. 
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i. Select PCS Technologies (HT ENU). 
Note: If necessary, you can drag the right-border of the Explorer applet to expand the applet.  

j. Expand PCS Technologies (HT ENU). 
k. Notice the child divisions of PCS Technologies (HT ENU). They are AWIT System, Inc, HT 

10 Support Services Division, HT 20 Sales Division, HT 30 Marketing Division, HT 40 
Service Division, HT 50 Alliances & Channel Partners Division, and HT 60 Semiconductor 
Organization. 

l. Select and expand HT 10 Support Services Division. Notice that it does not have any child 
divisions. 

m. Is HT 10 Support Services Division an organization? 
 
              

n. Verify that HT 10 Support Services Division's parent division is PCS Technologies (HT 
ENU), and its Organization Name is PCS Technologies (HT ENU). 
Note: A division’s organization is the first organization above it in the division hierarchy. 

o. The hierarchy we examined looks like this: 
 

 

3. Explore the position hierarchy and locate the positions of Casey Cheng and Vic Taylor. 
a. Click Positions in the link bar. 
b. Click in the Last Name column. Notice that this is a multivalue field: a position may have 

multiple users. 
c. Query Last Name = Cheng. 
d. Select Casey Cheng. 

 

Manufacturing Default Organization 

Default Organization

PCS Technologies (HT ENU) 

AWIT 
System, 

Inc 

HT 10 Support 
Services 
Division 

HT 20 
Sales 

Division 

HT 30 
Marketing 
Division 

HT 40 
Service 
Division

HT 50 Alliances & 
Channel Partners 

Division 

HT 60 
Semiconductor 

Organization 

Organization 

Division 
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e. What is Casey's Position and Division? 
 
              

f. Notice the parent position is HT 10 10 Call Center Manager. 
g. Query Position = HT 10 10 Call Center Manager. 
h. Click the multivalue select control in the Last Name column to verify that only a single 

employee has this position.  Who occupies the HT 10 10 Call Center Manager position? 
 
              

i. Click OK. 
j. Notice the HT 10 10 Call Center Manager is in the HT 10 Support Services Division and has 

parent position HT 10 01 Service VP.  
k. Query for this position. 
l. Verify that Vic Taylor has the HT 10 01 Service VP position, which is in the HT 10 Support 

Services Division. 
m. Refer to the diagram above and locate the HT 10 Support Services Division, which Casey 

Cheng and Vic Taylor belong to. What Organization is closest above this division?   
 
              

n. Verify that this matches the Organization (HQ) field for Vic Taylor's and Casey Cheng's 
positions. 

o. Click Internal Divisions on the link bar. 
p. Query for Division Name = HT 10 Support Services Division. 
q. Drill down on the Division Name. 
r. Notice that the child list applet displays positions that are associated with this division.  
s. Verify that Casey Cheng, Sally Lybrand, and Vic Taylor all are listed as holding positions in 

this division. 
t. Select File > Log Out. 

4. Start the Siebel Call Center Developer Web Client:  
Note: You will log in as Casey Cheng. 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID CCHENG 
Password CCHENG 
Connect to Sample 

c. Click OK. 
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5. Examine Casey Cheng’s contacts. Access to data, such as contacts, is based on an employee’s 
position. 
a. Select Contacts > My Contacts. 
b. Notice that Avram Ahl is the first contact listed. 
c. Select Menu > Record Count. 
d. Notice that there are approximately 29 records returned. 
e. Click OK. 
f. Select All Contacts from the visibility filter drop-down list. This displays contacts based on 

Casey Cheng’s current position’s organization, PCS Technologies (HT ENU). 
g. Notice that Kathy Accinni is the first contact listed, and Avram Ahl appears in the list.  
h. Select Menu > Record Count. 
i. Note that there are approximately 1650 records returned. 
j. Click OK. 
k. From the application-level menu, select Tools > User Preferences. 
l. Click Change Position in the link bar. 
m. Notice that Casey Cheng does not have any other positions; if she did, she would be able to 

change positions here, and she would see a different set of records. 
n. Minimize Casey Chang's Siebel Call Center session. 

6. Start the Siebel Call Center Developer Web Client:  
Note: You will log in as Vic Taylor. 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID VTAYLOR 
Password VTAYLOR 
Connect to Sample 

c. Click OK. 
Note: Having two Siebel Call Center sessions open simultaneously can be confusing at times. 
There are two methods to verify the user of a session: Navigate to the Home Page and check 
the salutation, which should include the user's name, or select Help > Technical Support and 
check the User ID listed. 

7. Examine Vic Taylor’s contacts. 
a. Select Contacts > My Contacts. 
b. Select Help > About View. 
c. Notice that the view is once again the Visible Contact List View. 
d. Click OK. 
e. Notice that Joseph Armstrong is the only contact listed. 

Note: Even though you navigated to the same view as both Casey Cheng and Vic Taylor, the 
records displayed differ, based on each employee’s position. 

f. Select All Contacts from the visibility filter drop-down list. 
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g. Notice that Kathy Accinni is once again the first contact listed, and Avram Ahl appears in the 
list.  

h. Scroll down several times to locate the Joseph Armstrong record. 
Note: It should appear in the All Contacts views for both Casey Cheng and Vic Taylor. 

i. Select Menu > Record Count. 
j. Note that there are approximately 1650 records returned. This should exactly match what you 

found for Casey Cheng. 
Note: The My Contacts view was based on employee position, hence showed different 
records. The All Contacts view is based on an employee’s position’s organization, and we 
found above that Casey Cheng and Vic Taylor have the same organization, hence the listed 
records should be the same.  

k. Click OK. 

8. Log out of both Siebel Call Center sessions. 
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Solutions 11-1  

Answers 

2.m. Is HT 10 Support Services Division an organization? 
No, it does not have the Organization Flag checked 

3.e. What is Casey's Position and Division? 
HT 10 11 Call Center Agent and HT 10 Support Services Division, respectively 

3.h. Click the multivalue select control in the Last Name column to verify that only a single 
employee has this position.  Who occupies the HT 10 10 Call Center Manager position? 
Sally Lybrand 

3.m. Refer to the diagram above and locate the HT 10 Support Services Division, which Casey 
Cheng and Vic Taylor belong to. What Organization is closest above this division? 
PCS Technologies (HT ENU) 
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Practice 12-1 Exploring Responsibilities 

Goals To explore the relationship between responsibilities and views in the application 
To examine the seed responsibilities available in the application 
To create and customize a new responsibility 

Time 15 - 20 minutes 

Instructions: 
In this practice you will connect to the Siebel Server, instead of using the sample application. The 
server application has several logins that you will use to examine the seed responsibilities in the 
server database. 

1. Start the Siebel Call Center Web Client: 
a. Select Start > Programs > Internet Explorer. 
b. Enter Address: http://localhost/callcenter_enu. 

Important Note: If the browser reports that the server is busy or unavailable, you may have to 
start the Siebel Server, which was done in an earlier practice. To start the Siebel Server: 
i. Run Start > Programs > Administrative Tools > Services. 
ii. Scroll down and find Siebel Server [OUEnt_OUSrvr]. 
iii. Right-click and select Start. 
iv. Right-click on the Windows Taskbar and select Task Manager. 
v. Click the Performance tab. 
vi. Monitor the CPU usage and wait until it drops to near 0% for several seconds. 

c. Enter: 
User ID SADMIN 
Password SADMIN 

d. Click the arrow. 

2. Explore the views associated with a seed responsibility. 
a. Navigate to Administration - Application > Responsibilities. 

Note: The responsibilities shown are the seed responsibilities for the application. These 
responsibilities cannot be edited or deleted. You will learn how to create your own custom 
responsibilities later in this practice. 

b. Query for Responsibility = Business Analyst. 
c. In the bottom applet, use Menu > Record Count to verify that the Business Analyst 

responsibility has more than 100 views. 
d. Notice that both the Automation Administrator_AUT and Siebel Administrator users have 

this responsibility. 
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3. Explore the seed responsibilities associated with a single view. Not all views are associated with 
multiple responsibilities. However, commonly-accessed views such as home pages or views 
displaying common entities (contacts, accounts, and so on) are usually associated with many 
seed responsibilities. 
a. Navigate to Administration - Application > Views.  

Note: This view displays views in the top list and responsibilities associated with the selected 
view in the bottom list. 

b. Query for View Name = "Home Page View (WCC)", including the quotes. This is the 
application home page view. 
Note: Parentheses are special characters, hence you must use quotes in your query. 

c. Confirm that Home Page View (WCC) is included in multiple responsibilities, including the 
Siebel Administrator responsibility. 
Note: You have confirmed that a single responsibility may contain multiple views, and that a 
single view may be contained in multiple responsibilities. 

d. Navigate to Forecasts > All Forecasts Across Organizations.  
Note: This view shows all forecasts. No records appear, because the server database does not 
contain seed data for forecasts. 

e. Select Help > About View. 
f. Verify that this is the Forecast 2000 -- All Forecast Across Organizations view. 
g. Click OK. 
h. Navigate to Administration - Application > Views or click your browser's Back button 

several times to return to this view. 
i. Query for View Name = Forecast 2000 -- All Forecast Across Organizations. 
j. Notice that only a few responsibilities can access this view, and these responsibilities are for 

managers, executives and administrators. This is typical for "All Across Organizations" 
views, which may contain sensitive or confidential information. For example, an employee 
with access to the Forecast 2000 -- All Forecast Across Organizations view could infer a 
company's current sales success, and could accurately predict company revenues. 

4. Explore what happens when you remove all of the responsibilities for a user. 
a. Navigate to Administration - User > Employees. 
b. Query for User ID = TLSCONFIG. 
c. Click the MVG control in the Responsibilities column. 
d. Click Remove All to remove all the responsibilities from this user. 
e. Click OK. 
f. Step off the record to save it. 
g. Start a second instance of Siebel Call Center:  

Note: You will log in as TLSCONFIG. 
i. Select Start > Programs > Internet Explorer 
ii. Enter Address: http://localhost/callcenter_enu. 
iii. Enter: 

User ID TLSCONFIG 
Password TLSCONFIG 

iv. Click the arrow. 
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h. Notice that you receive an error message that “The responsibility of user ‘TLSCONFIG’ 
does not allow accessing view ‘Home Page View (WCC)’”.  

i. Notice that the application toolbar is not visible. 
j. From the application-level menu, select Navigate > Site Map.  
k. Notice that no screens or views are listed. 
l. Select File > Log Out to log out of this session.  
m. Leave the browser window open at the log in screen. 

5. Create a new responsibility and assign it to TLSCONFIG. 
a. Return to the session where you are logged in as SADMIN. 
b. Navigate to Administration - Application > Responsibilities. 
c. Query for Responsibility = "Call Center Representative - SMC", including the quotes. 
d. Notice that the Delete button is disabled in the top applet, and the Add and Delete buttons are 

disabled in the Views applet. You cannot delete or modify seed responsibilities. 
e. Scroll through the views. Notice that Home Page View (WCC) is not one of the views 

associated with this seed responsibility.  
Note: This will not prevent a user with this responsibility from using a Siebel application, but 
because the home page view is the default initial view, the user will get an error message 
immediately after logging in. Views that are associated with the user's responsibilities will be 
accessible through the Site Map and by using navigation controls, such a screen tabs and 
links on the link bar. 

f. In the top applet, from the applet-level menu select Copy Record. 
g. Enter: 

Responsibility BAF Call Center Representative - SMC 
Description Custom Call Center Representative responsibility with Home Page view

h. Step off the record to save it. 
i. Select BAF Call Center Representative - SMC. 
j. Notice that the Delete button is enabled in the top applet, and the Add and Delete buttons are 

enabled in the Views applet. You can delete and modify your custom responsibilities. 
k. Notice that the views from the Call Center Representative - SMC responsibility have been 

copied to your custom responsibility. 
l. In the Views applet, click Add. 
m. Query for View Name = "Home Page View (WCC)", including the quotes. 
n. Click OK to add the view to the responsibility.  
o. Query for View Name = Contact List View. 

Note: Recall that this was the view name for the “All Contacts” view. 
p. Notice that the Contact List View is not in the responsibility. 
q. In the Views applet, click Add. 
r. Query for View Name = Contact List View. 
s. Click OK to add the view to the responsibility. 
t. Select Contact List View and check the Read Only View checkbox. 
u. In the Users applet, click Add. 
v. Query for User ID = TLSCONFIG. 
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w. Click OK to add TLSCONFIG to the BAF Call Center Representative - SMC responsibility. 
x. Click Clear Cache in the Responsibilities applet. This will ensure that the new responsibility 

is available immediately. 

6. Test the new responsibility. 
a. Return to the browser displaying the log in screen. Enter: 

User ID TLSCONFIG 
Password TLSCONFIG 

b. Click the arrow. 
c. Notice that TLSCONFIG now has access to the Home Page (WCC) view. 
d. From the application-level menu, select Navigate > Site Map. 
e. Notice that TLSCONFIG now has access to several screens and views, including the All 

Contacts view. 
f. Drill down on All Contacts. 
g. Notice that the New and Delete buttons are disabled, indicating that TLSCONFIG has read-

only access to this view.  
h. Select File > Log Out to log out of the application. 
i. Close Internet Explorer. 

7. Log out of SADMIN's Siebel Call Center session. 
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Practice 13-1 Exploring Visibility Views 

Goals Explore data visibility using visibility views 

Time 25 - 35 minutes 

Instructions: 
In this practice, you will explore data visibility. You will access the sample database as three 
different users:  
• Terry Smythe (TSMYTHE) - a sales representative in PCS Technologies (HT ENU) 

Organization and HT20 Sales Division 
• Madison Stern (MSTERN) - Terry's sales manager in PCS Technologies (HT ENU) 

Organization and HT20 Sales Division 
• Andy Martin (AMARTIN) - sales manager in Default Manufacturing Organization, an 

organization above PCS Technologies (HT ENU).  
 
The diagram shows the part of the division and organization hierarchies that these users belong to: 
 

 
 
The position hierarchy for the HT 20 Sales Division is shown in the diagram from the Positions 
explorer applet: 

 

Manufacturing Default Organization 

Default Organization

PCS Technologies (HT ENU)

HT 20 Sales Division

Organization 
Division 

PSC Equipment (IM ENU)

O
ra

cl
e 

U
ni

ve
rs

ity
 a

nd
 (O

ra
cl

e 
C

or
po

ra
tio

n)
 u

se
 o

nl
y.

Th
es

e 
eK

it 
m

at
er

ia
ls

 a
re

 to
 b

e 
us

ed
 O

N
LY

 b
y 

yo
u 

fo
r t

he
 e

xp
re

ss
 p

ur
po

se
 S

EL
F 

ST
U

D
Y.

  S
H

AR
IN

G
 T

H
E 

FI
LE

 IS
 S

TR
IC

TL
Y 

PR
O

H
IB

IT
ED

.



Lesson 13: Controlling Access to Customer Data  

86 Siebel 8.1.x Business Analyst Oracle 

1. Start the Siebel Call Center Developer Web Client:  
Note: Log in as Terry Smythe (TSMYTHE), a sales representative. 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID TSMYTHE 
Password TSMYTHE 
Connect to Sample 

c. Click OK. 

2. Examine the visibility of opportunities for a sales representative. 
a. Select Opportunities > My Opportunities. 
b. Select ** All Opportunities in the Saved Queries drop-down to ensure that all TSMYTHE's 

Opportunities appear. 
Note: The ** All Opportunities saved query is an empty query and serves only to refresh the 
Opportunities list. This query is not the same as the All Opportunities selection in the 
visibility filter. 

c. Select Menu > Record Count.  
d. Record how many opportunities TSMYTHE sees:         
e. Click OK. 
f. Query for opportunities Sales Team = TSMYTHE. 

Note:  By default the application system preferences are set to automatically add EXISTS to 
MVG queries.  To confirm this, select Menu > Refine Query and examine the Sales Team 
query criterion. Click Cancel to return to the query results. 

g. Select Menu > Record Count. 
h. Verify that the query returns the same number of records you recorded earlier. This provides 

evidence that My Opportunities shows all records where TSMYTHE is on the Opportunity's 
Sales Team. 
Note: TSMYTHE is not the primary on the sales team for all of these Opportunities.  

i. Query for Opportunity Name = "CL-Ace Plumbing - Group Life" and click the Sales 
Team MVG control to see an Opportunity where TSMYTHE is on the Sales Team, but is not 
the primary. 

j. Select All Opportunities in the visibility filter. 
k. Execute an empty query to refresh the list. 
l. Drill down on the first record in the list. 
m. Click the More Info view tab. 
n. What Organization appears in the lower applet? 

 
              
 

o. In the top applet, select Menu > Record Count. Record the number of records:  ____  
p. Click OK. 
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q. In the lower applet, query for records with Organization ="PCS Technologies (HT ENU)". 
(Use quotes.) This query on the multivalue Organization field also uses an implicit 
EXISTS(). 

r. Select Menu > Record Count. Verify that the count matches the number of records you just 
recorded above. 

s. Recall that TSMYTHE's position, HT 20 21 Sales Representative, belongs to the PCS 
Technologies (HT ENU) organization, which is the organization closest above TSMYTHE's 
division, HT 20 Sales Division. The matching record count suggests that All Opportunities 
shows all opportunities that have Organization equal to the organization that TSMYTHE's 
position is associated with. 

t. Click OK. 

3. Select File > Log Out. 
 

Summary of findings for sales representatives: 
• The saved queries and visibility filter selections combine to determine which records appear 

in the opportunities list. 
• My Opportunities shows records where the user's position is on the Opportunity Sales Team. 
• All Opportunities shows records where the organization of the user's position is in the 

Opportunity's Organization field. 

 

4. Start the Siebel Call Center Developer Web Client:  
Note: Log in as Madison Stern (MSTERN), a sales manager. 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID MSTERN 
Password MSTERN 
Connect to Sample 

c. Click OK. 

5. Explore My Team's Opportunities for a sales manager. 
a. Refer to the position diagram at the beginning of this practice. Who are Madison Stern's 

subordinates? 
 
              

b. Select Opportunities > My Opportunities. 
c. Select ** All Opportunities in the Saved Queries drop-down. 
d. Select Menu > Record Count. Verify that MSTERN has approximately 13 Opportunities 

where she appears on the Sales Team. 
e. Select My Team's Opportunities in the visibility filter. 
f. Select Menu > Record Count. Confirm that there are many more records displayed than in 

MSTERN's My Opportunities list. 
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g. Page down the list applet and observe the entries visible in the Sales Team column. 
h. What values are shown for Sales Team? 

 
              

i. Notice that these User IDs correspond to Madison Stern's subordinates and herself. My 
Team's Opportunities displays records with the user's position or its subordinate positions in 
the Opportunity Sales Team. 

j. Query for Opportunity Name = Honeywell Automation Master SLA Renewal 2008. 
k. Drill down on the Opportunity Name. 
l. Click the More Info view tab.   
m. Click the MVG control in the Organization field.  Verify that MSTERN's organization, PCS 

Technologies (HT ENU), is not listed in the Selected column.  This confirms that My Team's 
Opportunities does not use the organization of the current user's position to filter records. 

n. Click OK. 

6. Select File > Log Out. 
 

Summary of findings for sales managers: 
• My Team's Opportunities shows records where the position of the user or one of her 

subordinates is on the Opportunity Sales Team.  
• Organization is not involved in record visibility for My Team's Opportunities. 

 

7. Start the Siebel Call Center Developer Web Client:  
Note: Log in as Andy Martin (AMARTIN) a sales manager in the Default Manufacturing 
Organization (which owns PCS Technologies (HT ENU)). 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID AMARTIN 
Password AMARTIN 
Connect to Sample 

c. Click OK. 

8. Explore All Opportunities Across My Organizations and All Opportunities Across 
Organizations. 
a. Select Opportunities > My Opportunities. 
b. Select ** All Opportunities in the Saved Queries drop-down. 
c. Verify that AMARTIN is on the sales team for a single opportunity. 
d. Select All Opportunities in the visibility filter. This selects all Opportunities in AMARTIN's 

organization, Manufacturing Default Organization. Verify that two records appear in the list. 
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e. Which organizations are subordinate to Manufacturing Default Organization in the 
organization structure? (Refer to the division diagram at the beginning of this practice.) 
 
              

f. Select All Opportunities Across My Organizations in the visibility filter. 
g. Click the Opportunity Name column header to sort by ascending Opportunity Name. This 

sorting "shuffles" the Opportunity records so that they are not grouped by Organization, and 
will make the following steps easier. 

h. Drill down on the first record. 
i. Click the More Info view tab. 

Note: The following diagram shows the complete organization structure below 
Manufacturing Default Organization.  

 
j. Move through the record set by clicking Next Record. Observe the Organization field.  
k. Verify that you see records with PCS Equipment (IM ENU) and PCS Technologies (HT 

ENU).   
Note: You will also see other entries that are child organizations of PCS Technologies (HT 
ENU) and PCS Equipment (IM ENU) such as HT 52 Active Systems - Americas. This is 
correct behavior since All Opportunities Across My Organizations shows records where the 
Organization is a subordinate organization or an organization of the user's position. 

l. Click Opportunities List on the link bar. 
m. Select All Opportunities Across Organizations in the visibility filter. 
n. Select Menu > Record Count. 
o. Verify that you receive 800+ records. 

Note: This is significantly more than you saw using the prior filter. 
p. Click OK. 
q. Query for Opportunity Name = Adjustable Rate Mortgage Oppty - Axelson USD 150K. 
r. Drill down on this record's name. 
s. Click the More Info view tab. 
t. Click the MVG control in the Organization field. 
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u. Verify that the Organizations for this opportunity are Millennium Retail Finance Services RF 
ENU and HC 30 Peninsula Health Brokerage.   
Note: Neither of these organizations is subordinate to AMARTIN's organization, 
Manufacturing Default Organization. 

v. Click OK. 
w. Select Menu > Record Count. Record this value:         
x. Click OK. 
y. Click Opportunities Administration on the link bar.  

Note: This view displays all Opportunities: notice that there is no visibility filter. 
z. Select Menu Record Count.  
aa. Verify that this value matches what you recorded for All Opportunities Across 

Organizations.   
Note: From this you conclude that All Opportunities Across Organizations displays all 
Opportunities. 

bb. Click Opportunities List from the link bar. 
cc. Click the visibility filter.  
dd. Notice that AMARTIN has other visibility applets available, such as My Clients' 

Opportunities. These visibility applets, like My Opportunities and the others we examined in 
this practice, apply a filter to the collection of all Opportunities. In the cases we looked at, the 
filter was based on the user's position, organization, or the organization or position hierarchy. 
The visibility filter for My Clients' Opportunities uses different criteria. 

9. Select File > Log Out. 
 

Summary of findings for organizations: 
• All Opportunities Across My Organizations shows records where the organization matches 

the organization of the user's position or one of its subordinate organizations. 
• All Opportunities Across Organizations shows all opportunities. 
• The visibility filter can support other visibility applets that filter records based on some other 

field(s). 
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Solutions 13-1  

Answers 

2.d. Record how many Opportunities TSMYTHE sees: 
> than 60 

2.n. What Organization appears in the lower applet? 
PCS Technologies (HT ENU) 

2.o. Record the number of records:  
> than 150 

4.a. Refer to the position diagram at the beginning of this practice. Who are Madison Stern's 
subordinates? 
Terry Smythe, Wasaka Takuda, and Kelly Wilson 

4.h. What values are shown for Sales Team? 
MSTERN, TSMYTHE, WTAKUDA, and KWILSON - User Ids for Madison Stern and her 
subordinates 

7.e. Which organizations are subordinate to Manufacturing Default Organization in the 
organization structure? (Refer to the division diagram at the beginning of this practice.) 
PCS Equipment (IM ENU) and PCS Technologies (HT ENU) 

7.w. Record this value 
Approximately 5 
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Practice 14-1 Creating a Company Structure 

Goals Create a sample organization hierarchy 

Time 10 - 20 minutes 

Instructions: 
In this practice, you will create a very simple organization hierarchy and position hierarchy for BAF 
Company. This will familiarize you with the skills necessary to create and administer divisions, 
organizations, and positions.  

1. Start Siebel Call Center Web Client: 
a. Select Start > Programs > Internet Explorer 
b. Enter Address: http://localhost/callcenter_enu. 
c. Enter: 

User ID SADMIN 
Password SADMIN 

d. Click the arrow. 

2. Create a new BAF Company organization as a child of the Default Organization. 
a. Navigate to Administration - Group > Internal Divisions. 
b. Create a new division with Division Name = BAF Company. 
c. Save the record 
d. Select BAF Company. 
e. Notice in the form applet that BAF Company is a division that belongs to the Default 

Organization. 
f. In the explorer, expand Default Organization and notice that BAF Company is not listed as a 

child. This is because you did not specify a parent division for BAF Company. 
g. Select BAF Company in the explorer. 
h. In the form applet, click the select button for Parent Division.  
i. Select Division = Default Organization and click OK.  

Note: This specifies that Default Organization is the parent division of BAF Company. 
j. In the explorer, close and expand Default Organization. Notice that now BAF Company is 

listed as a child of Default Organization. 
k. In the explorer, select BAF Company. 
l. In the list applet, select Menu. Notice that Delete Record is disabled. 
m. Notice that the Organization Name is Default Organization.  

Note: This is the organization that contains the BAF Company division. 
n. Check the Organization Flag check box and step off the record to save it. 
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o. Return to the BAF Company record. 
p. Notice that the Organization Name is now BAF Company; once a division is marked as an 

organization, then it is its own organization. 
q. Notice that you cannot uncheck the Organization Flag. Once you change a division to an 

organization, you cannot undo this. You can rename the organization and change its parent 
division to “hide” it in the hierarchy. 

r. Click Organizations in the link bar. This view displays only organizations, not divisions. 
s. In the explorer, expand Default Organization and confirm that it contains BAF Company. 

3. Create two additional internal divisions as children of BAF Company, and label one of them as 
an organization. 
a. Click Internal Divisions in the link bar. 
b. Create a new record with: 

Division Name BAF Company Western Division 
Parent Division BAF Company 
Organization Flag EMPTY (Not checked) 

c. Create a second new record with: 
Division Name BAF Company Eastern Organization 
Parent Division BAF Company 
Organization Flag Checked 

d. In the explorer, expand Default Organization  
e. Confirm the hierarchy shows BAF Company under Default Organization and BAF Company 

Eastern Organization and BAF Company Western Division under BAF Company: 

 
f. Click Organizations in the link bar. 
g. In the explorer, expand Default Organization 
h. Confirm the hierarchy shows BAF Company under Default Organization and BAF Company 

Eastern Organization under BAF Company: 
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4. Create a position hierarchy. 
Note: In a real deployment, you would most likely have several levels of positions within each 
division; for example, CEO, President, and Vice President of Sales might all be within the BAF 
Company organization (recall that an organization is a special type of division), while Sales 
Manager and Sales Representative 1 might both be within the BAF Company Western Division. 
For simplicity, you will create just one position per division. 
a. Click Positions in the link bar. 
b. Create a new record with: 

Division BAF Company 
Position BAF CEO 
Note: By failing to specify a parent position, you are setting this position to be the top-level 
position in a position hierarchy. The top-level position does not need to belong to Default 
Organization. 

c. Create a position record with: 
Division BAF Company Western Division 
Position BAF VP West 
Parent Position BAF CEO 
Note: Notice that when you are selecting a parent position, all of the positions are listed; the 
parent position does not have to be in a parent division.  

d. Create a position record with: 
Division BAF Company Eastern Organization 
Position BAF VP East 
Parent Position BAF CEO 

e. In the explorer, expand BAF CEO and confirm that both BAF VP East and BAF VP West 
appear as child positions. 

5. Assign employees to the positions you created. 
Note: Depending on how your company implements its company structure (importing it, entering 
it manually, or so forth), you might use different views to assign employees to positions. This 
step uses methods to familiarize you with both of them. 
a. Select BAF VP West in the list applet.  
b. Select the Last Name field. Notice that an MVG button is visible in this field. 
c. Click the MVG button to invoke the Assigned Employees MVG shuttle applet. 
d. Add Automation Administrator_AUT and Cameron Carlson_AUT to the BAF VP West 

position. This demonstrates that one position may have multiple employees. 
e. Specify Cameron Carlson_AUT as the primary employee for this position by selecting the 

Primary checkbox next to him. 
f. Click OK. 
g. Run a blank query to refresh. 
h. Notice that in the explorer, BAF VP West now has Cameron Carlson (AUT) in parentheses 

next to it. This indicates the primary employee in that position. 
i. Navigate to Administration - User > Employees. 
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j. Select the Siebel Administrator employee. 
k. Select the Position field for Siebel Administrator. Notice that an MVG button is visible in 

this field. 
l. Click the MVG button to invoke the Positions Occupied MVG applet.  
m. Notice that Siebel Administrator already has the Siebel Administrator position as his or her 

primary position. 
n. Add the BAF CEO position. This indicates that one employee may have multiple positions. 
o. Click OK. 

6. From the application-level menu, select File > Log Out. 

7. Shut down the Siebel Server. It is not needed for the rest of the class. 
a. Select Start > Programs > Administrative Tools > Services. 
b. Scroll down and find a service named Siebel Server [OUEnt_OUSrvr]. 
c. Right-click this service and select Stop. 

Note: This will take several minutes. You do not need to wait for it to complete. 
d. Once complete, close the Services window. 
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Practice 15-1 Using About View 

Goals Use About View to identify objects 
Observe how UI layer object definitions reference business layer object definitions 

Time 10 - 15 minutes 

Instructions: 
In this lab, you will gain a better understanding of the nature of the relationships between the user 
interface (UI) and the business layers of the Siebel application. You will map UI objects to business 
layer objects using About View. 

Use this diagram to remind yourself about the relationships between the different object types: 

 
The shaded object types are not part of this practice: you will be restricting yourself to examining UI 
layer and business layer objects. 

1. Start Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 
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2. Determine the object types that appear in an opportunities view. 
a. Select Opportunities > Opportunities List.  
b. Select Help > About View.  
c. What is the Screen?  

 
              

d. What is the View? 
 
              

e. Which business object is displayed in this view? 
 
              

f. The two applets that appear are numbered [0] and [1] from top to bottom. What two applets 
appear in the view? 
 
              

g. Which business components are displayed in the applets? 
 
              

h. Click OK to close the About View window. 
i. Query for an opportunity named Honeywell Automation Master SLA Renewal. 
j. Drill down on this record. 
k. Click the Assignment Skills view tab. 
l. Select Help > About View. 
m. Which applets appear in the Opportunity Skill View? (in top to bottom order) 

 
              
 
              

n. Which business components are displayed in this view? (in top to bottom order) 
 
              

o. Which objects remained unchanged between the two views? 
 
          `    
 
              

p. Click OK to close the About View window. 
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3. In the preceding step, the opportunity views you looked at displayed a single business object. In 
this step you will see a more complex example, where a screen's views can display different 
business objects. Remember, a single view only displays a single business object, but a 
collection of views that display different business objects can be part of a screen definition. 
a. Select Contacts. 
b. Select Help > About View. 
c. What is the Screen? 

 
              

d. What is the business object?  Screen home pages typically have their own business object 
definition. 
 
              

e. Click OK to dismiss About View. 
f. Click Contacts List on the link bar. 
g. Select Help > About View. 
h. Notice that the screen is Contacts Screen (the same as the last screen). 
i. What business object is shown in the Visible Contacts List View? 

 
              

j. Click OK. 
k. Click Consumers List on the link bar.  Use About View. 
l. What business object is shown in the Consumer List View, which is also part of the Contacts 

Screen? 
 
              

m. Click Personal Contacts List on the link bar. 
n. What business object is shown in the Consumer List View? 

 
              

4. Administrative screens also frequently contain views that display different business objects. You 
will examine a few views in the Administration - Application screen to confirm this behavior. 
a. Navigate to Administration - Application > State Models.  
b. Which business object is displayed? 

 
             

c. Navigate to Administration - Application > Responsibilities.  
d. Which business object is displayed? 

 
             

e. Navigate to Administration - Application > Predefined Queries.  
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f. Which business object is displayed? 
 
              

5. From the application-level menu, select File > Log Out. 
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Solutions 15-1  

Answers 

2.c. What is the Screen? 
Opportunities Screen 

2.d. What is the View? 
Opportunity List View 

2.e. Which business object is displayed in this view? 
Opportunity 

2.f. The two applets that appear are numbered [0] and [1] from top to bottom. What two applets 
appear in the view? 
Opportunity List Applet and Opportunity Form Applet - Child 

2.g. Which business components are displayed in the applets? 
Opportunity and Opportunity 

2.m. Which applets appear in the Opportunity Skill View? (in top to bottom order) 
Opportunity Form Applet - Child, Opportunity Skill List Applet, and Opportunity Skill Item 
List Applet 

2.n. Which business components are displayed in this view? (in top to bottom order) 
Opportunity, Opportunity Skill, Opportunity Skill Item 

2.o. Which objects remained unchanged between the two views? 
Both views were part of the Opportunities Screen and both displayed the Opportunity 
business object. The Opportunity business component was displayed in the top applet for 
each view, and the Opportunity Form Applet - Child applet was present, although in a 
different position in the view. 

3.c. What is the Screen? 
Contacts Screen 

3.d. What is the business object?  Screen home pages typically have their own business object 
definition. 
Contact Home 

3.i. Notice that the screen is unchanged. What business object is shown in the Visible Contacts 
List View? 
Contact 
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3.l. What business object is shown in the Consumer List View, which is also part of the 
Contacts screen? 
Consumer 

3.n. What business object is shown in the Consumer List View? 
Contact (Personal) 

4.b. Navigate to Administration - Application > State Models. Which business object is 
displayed? 
State Model 

4.d. Navigate to Administration - Application > Responsibilities. Which business object is 
displayed? 
Responsibility 

4.f. Navigate to Administration - Application > Predefined Queries. Which business object is 
displayed? 
Query List 
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Practice 16-1 Examining Object Definitions 

Goals Practice examining object definitions using Siebel Tools 

Time 30 - 40 minutes 

Instructions: 
Siebel Tools is an integrated development environment (IDE) for configuring Siebel applications. 
Developers use Siebel Tools to modify existing Siebel object definitions and create new object 
definitions to meet their organization’s business requirements. They do not modify the source code 
or directly write SQL. 

1. Start Siebel Tools: 
a. Select Start > Programs > Siebel_Tools_8.1 8.1 > Siebel Tools.   
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Observe how Tools indicates the active object definition.  
a. In the left-hand Object Explorer (OE) pane, select the Application object type. 
b. In the right-hand Object List Editor (OBLE) pane, select the Siebel Universal Agent object 

definition. 
c. What visual cues indicate that the definition has been selected? 

 
              

3. Explore parent-child relationships between object types.  
a. In the OE, expand the Application object type.  

Note: The Types tab in the OE shows the object hierarchy. Clicking the plus sign (+) to the 
left of an object type displays all visible child object types for the top-level type. Clicking the 
minus sign (–) to the left of an object type collapses all its child object types. 
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b. How many child object types are listed for the Application object type? 
 
             

c. Expose all Application child object types in the Object Explorer. Not object types are shown 
by default in the OE, but they can be exposed by using the Siebel Tools' option dialog. 
i. In the application bar, select View > Options. 
ii. Click The Object Explorer tab.  

Note: This tab displays the object types that are shown in the OE.  A white box with a 
check mark, as next to Business Object, indicates that all child object types are displayed. 
An empty checkbox indicates that the parent and any child object types are not shown in 
the OE. A grayed-out checkbox indicates that some, but not all child object types are 
exposed. 

iii. Expand the Application node by clicking the + sign to its left. 
iv. Observe that many child object types are not shown, and the two that are shown do not 

have their own child object types shown. 
v. Expose all Application child and grandchild objects by clicking the checkbox next to 

Application until it is a white, checked box. 
vi. Click OK. 

d. In the OE, expand Application. 
e. Verify that all of the child and grandchild object types are now displayed. 
f. To see a deeper hierarchy, expand Table in the OE, and then expand the child type User Key.   

4. Query to display all the page tabs that are included in the Siebel Universal Agent application.  
a. In the OE, select Application. 
b. From the application-level menu, select Query > New Query (or click ). 
c. In Name enter Siebel Universal*. 
d. Select Query > Execute Query (or click ) or press Enter. 
e. In the OE, expand Application and select Page Tab. 
f. Select Application :: Siebel Universal Agent | Page Tab.  

Note: This notation means to first select the Application object type in the OE, next select the 
Siebel Universal Agent record in the OBLE, and then select the Page Tab child object type in 
the OE. 

g. Perform an empty query to ensure that all the Page Tab child object definitions are listed. 
i. In the OBLE (right-side) click in the Page Tabs list to make it active. 
ii. From the application-level menu, select Query > New Query (or click ). 
iii. Select Query > Execute Query (or click ). 
iv. Look at the bottom of the screen. You should see Item: X of Y. Where X is the current 

item in the list and Y is the total number of records. 
Note: If you don't see the count, select View > Status Bar. 

5. Practice querying in the OBLE. A number of common operators are available, such as =, >, <, 
<>, LIKE, AND, OR, and NOT.  Siebel Tools queries are case-sensitive. 
a. Select Screen in the OE. 
b. Click anywhere in the OBLE. 
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c. Click New Query. 
d. In Name enter Contacts Screen. 
e. Click Execute Query. 
f. In the OE, expand Screen and select Screen View.  
g. Query for all screen view object definitions named "Contact Detail".  

i. Click in the Screen Views list. 
ii. Query for Name = *Contact Detail*.  
iii. Write down the record count, which appears at the bottom of the OBLE: 

 
              

h. Use an operator in your query.   
i. Query for Name = *Contact* AND *Detail*.  

Note: This query will return a few more records than the last query, because there are 
several screen views where "*Contact*" and "*Detail*" are not adjacent. 

a. Use the OR operator.  
ii. Query for Name = *Contact* OR *Detail*.  

Note: Your query should return many more records than the first two queries.   
iii. Confirm this by scrolling to the bottom of the returned records and examining the record 

counter at the bottom of the OBLE.  It should be over 100. 
i. Query for an object definition that contains special characters. 

i. In the OE, select Business Component. 
ii. In the Name property of the OBLE, query for 'Account (Contact Us)'. Ensure you bracket 

the query with single quotes. 

6. Use the Properties window to conveniently access object definition properties. 
a. Select Business Component :: ADS INS Property FNOL TBC. 

Note: This notation means to select Business Component in the OE and query for an object 
definition named ADS INS Property FNOL TBC in the OBLE. 

b. Scroll right in the OBLE to the Table column. What is the Table property for this business 
component? 
 
              

c. Drill down on the table hyperlink. Notice that the OBLE is now titled Tables. The hyperlink 
allowed you to quickly access a related object definition. 

d. Click Back  to return to the business component list. 
e. In the application menu, select View > Windows > Properties Window. 
f. Click and drag the Properties pane by the title bar and drop it on top of the Object Explorer 

title bar.   
g. If you are having trouble, ask your instructor or to reset and try again, select View > 

Windows > Reset Windows. 
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h. Notice the tabs at the bottom of the Properties window: 

 
Clicking a tab allows you to bring its window to the foreground. This layout is convenient if 
you are short of screen space. 

i. Examine the Properties window.  
Note:  This window displays the properties of the record currently selected in the OBLE. 
Because of its vertical layout, the Properties window is easier to use when examining an 
object definition with more than a few properties.   

j. Scroll down and find the Table property.  
Note: There is no hyperlink to navigate to a related object definition. To use hyperlinks, you 
must use the OBLE. 

k. Scroll up to the Comments property, which contains no value. 
l. Click in the Value column for Comments and type BAF Test Comment.  

Note: This demonstrates that the Properties window can also be used to change object 
definition properties. 
As a business analyst, you will probably not need to change object definitions in Siebel 
Tools. Your use of Tools will be primarily for information gathering, and read-only access 
should suffice. 

m. Notice the pencil icon in the W column of the OBLE.  This indicates that the corresponding 
definition is writable. Be careful when exploring object definitions that are so marked. 

7. Use Columns Displayed to reorder columns. When working in Siebel Tools, it is often useful to 
display and reorder columns to only display properties you seek, or to move desired properties 
into the immediately viewable area of the OBLE. You can also drag-and-drop column headers, 
but Columns Displayed is more suited to reordering several columns. 
a. Reorder columns to place the Sequence column next to the View column.  

i. Click Go Back  to return to the Screen and Screen Views display in the OLBE. 
ii. Right-click anywhere in the Screen Views window.  
iii. Select Columns Displayed. 
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iv. Select Sequence in the Displayed columns dialog box, and use the arrows to move it to 
follow immediately after View. 

 
v. Click OK. 
vi. Observe the change in the OBLE. You should see the Sequence property immediately to 

the right of the View property. If necessary, use the OBLE’s horizontal scroll bar to 
locate the columns. 

8. Use hyperlinks to quickly navigate between related objects.  
a. Select Applet :: Account Entry Applet.  
b. What is the value of the Business Component property?  

 
             

c. Drill down to the Account business component by clicking the Account hyperlink. 
d. What is the value of the Table property? 

 
             

e. Drill down on the Table property.  
Note: You have now navigated from the UI layer, through the business layer to the data layer 
via hyperlinks. 

f. Click the Back arrow to return to the Account business component. 
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9. Use the Flat tab to display object types (parent and child) in a single, alphabetically-arranged list, 
without displaying the parent-child relationship. When the Flat tab is used, if the object selected 
is the child in a parent/child relationship, additional parent information is included in the OBLE. 

 
In this screenshot, you can also see that if there are multiple parents that reference the same 
child, then the child is repeated in the flat view for each parent that references it. 
 
The Flat tab is particularly helpful in finding a child object with an unknown parent.  
a. At the top of the OE, select the Flat tab. 
b. In the OE, select Screen View. 
c. In the OBLE, query for Name  = Account List. 
d. Notice that several records are returned. 
e. Scroll all the way to the right and look at the Parent Screen property. This indicates the 

screen that the view is part of. 
f. Is Accounts Screen listed in the Parent Screen? 

 
             

g. Drill down on Accounts Screen. 
h. Notice that Screen is now selected in the OE and the OBLE now displays the parent screen. 

10. At the top of the OE, select the Types tab to restore the OE to the hierarchical display mode. 

11. Leave Siebel Tools running for the next lab. O
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Solutions 16-1  

Answers 

2.c. What visual cues indicate that the definition has been selected? 
An active record indicator  appears at the far left, and the record is highlighted. 

3.b. How many child object types are listed for the Application object type? 
Two: Page Tab and Screen Menu Item 

5.g.iii Write down the record count, which appears at the bottom of the OBLE 
19 

6.b. Scroll right in the OBLE to the Table column. What is the Table property for this business 
component? 
S_TU_LOG 

8.b. What is the value of the Business Component property? 
Account 

8.d. What is the value of the Table property? 
S_PARTY 

9.f. Is Accounts Screen listed in the Parent Screen? 
Yes 
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Practice 17-1 Exploring Data Layer Object Definitions 

Goals Explore different table types 
Examine table and column properties 

Time 15 - 20 minutes 

Instructions: 
In this practice, you will use Siebel Tools to explore table properties and system columns. You will 
then review different types of extension tables and their base tables. 

1. Return to or if necessary, start Siebel Tools: 
a. Select Start > Programs > Siebel_Tools_8.1 8.1 > Siebel Tools.   
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Inspect columns in the S_OPTY table and their properties. The Table object type represents 
database tables. The Column child object type represents columns in those tables.  
a. Rearrange the columns for easier viewing: 

i. In the OE, select Table. 
ii. In the Tables list, right-click and select Columns Displayed. 
iii. Move Name to the top. 
iv. Click OK. 

b. Select Table :: S_OPTY | Column. Recall that this means to select Table in the OE, query for 
Name = S_OPTY in the OBLE and then expand Table and select Column in the OE. 
Note: Most table columns in Siebel applications are data columns. These columns provide the 
data for fields, or serve as foreign keys that point to rows in other tables. You cannot modify 
the properties of data columns.  

c. In the Columns list, lock the Name property column in place by double-clicking the Name 
column heading. 

d. Scroll to the right to locate the Type property.  
e. Examine the values in the Type column.  
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f. What types are included in this table? 
 
             
Note: System columns are used to store information like ROW_ID or who created the record.  
These values are visible through the About Record dialog. 

g. Review the system columns that are representative of the columns that appear in all tables. In 
the Columns list, query for Type = System. Use the drop-down list to select this value, 
because this ensures that you won't make a mistake while typing the value. 

h. Which system column is the primary key? Examine the column properties to find out. 
 
              

i. Run an empty query to reset the columns list. 
j. Select the EXPECT_CLS_DT column, which holds an Opportunity's close date.  
k. Scroll to the right and locate the Physical Type and Length columns.  What physical type is 

the EXPECT_CLS_DT column? 
 
              

l. Query for Name = NAME.  
m. What is an upper limit on the length of this column which holds an Opportunity's name? 

 
              
Note: The maximum length of an Opportunity's name is determined in a business component 
(BC) field definition. The Text Length property of the Name BC field should be 100 
characters. The column length is an upper bound on this value. 

3. Use Siebel Tools to examine indices. Index object definitions are representations of indices in 
the underlying database management system. Siebel applications include a set of standard 
indices. More can be added during application implementation to tune application performance. 
a. Select Table :: S_OPTY | Index.  

Note: The displayed list constitutes all the indices used to support searches on the S_OPTY 
table. 

b. Select Table :: S_OPTY | Index :: S_OPTY_P1 | Index Column.  
c. Which column(s) make up this index? 

 
             

d. Select Table :: S_OPTY | Index :: S_OPTY_U1 | Index Column.  
e. Which column(s) make up the S_OPTY_U1 index? 
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4. Examine a 1:1 extension table to see how it relates to its base table. Base tables and extension 
tables maintain a primary key / foreign key relationship. Extension tables have a foreign key that 
references the primary key of its base table.  
a. Select Table :: S_OPTY_X.  
b. View the Type property.  
c. What is the type of the table?  

 
             

d. What is the Base Table for S_OPTY_X? 
 
             

e. Select Column in the OE. 
f. Query for Foreign Key Table = S_OPTY.  

Note: The resulting query displays the column in the extension table that is the foreign key to 
the base table.  

g. Which Column is the foreign key to the base table? 
 
             

5. Examine the 1:M extension table for opportunities and a user key. 
a. Select Table :: S_OPTY_XM.   

Note: 1:M extension tables typically have "_XM" at the end of their name. 
b.  In the OE, select Column. 
c. Query for User Key Sequence = IS NOT NULL.  

Note: A user key is a set of columns that are used to determine if a record is unique. For 
example, a Service Request Number uniquely identifies a Service Request.  

d. What columns comprise the User Key for S_OPTY_XM? 
 
              
Note: TYPE and NAME are used to specify the entity type and its name, while 
PAR_ROW_ID is a foreign key associating the record with an opportunity record. These user 
key columns are used in all 1:M extension tables.  

6. Identify the intersection table that supports the M:M relationship between opportunities and 
industries.  
a. In the OE, select Table. 
b. In the OBLE, execute a compound query with these values: 

Name *OPTY* 
Type "Data (Intersection)"

Use the drop-down 
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c. Scan the query results for an intersection table that appears to associate opportunities with 
industries.  
Note: The intersection table’s name often includes a name combination of the tables 
involved. For example, S_OPTY_CON is the intersection table for S_OPTY and 
S_CONTACT, while S_ASSET_CON is the intersection table for S_ASSET and 
S_CONTACT.  Also the User Name can be helpful. 

d. Which table appears to support the organization-industries M:M relationship? 
 
              

e. Select Table:: S_OPTY_INDUST | Column. 
f. Lock the Name column by double-clicking it. 
g. Examine the Foreign Key Table column.  
h. Which two columns are used to associate an opportunity with an industry? Look for Foreign 

Key Table columns that point to the tables that hold the opportunity (S_OPTY) and industry 
(S_INDUST) information. 
 
              

7. Leave SADMIN's Siebel Tools session running. 
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Solutions 17-1  

Answers 

2.f. What types are included in this table? 
Data(Public) and System 

2.h. Which system column is the primary key? Examine the column properties to find out. 
ROW_ID 

2.k. Scroll to the right and locate the Physical Type and Length columns.  What physical type is 
the EXPECT_CLS_DT column? 
Date Time 

2.m. What is an upper limit on the length of this column which holds an Opportunity's name? 
100 characters 

3.c. Which column(s) make up this index? 
ROW_ID 

3.e. Which column(s) make up the S_OPTY_U1 index? 
BU_ID, CONFLICT_ID, NAME, PR_DEPT_OU_ID 

4.c. What is the type of the table? 
Extension 

4.d. What is the Base Table for S_OPTY_X? 
S_OPTY (Look in the Base Table property) 

4.g. Which Column is the foreign key to the base table? 
PAR_ROW_ID 

5.d. What columns comprise the User Key for S_OPTY_XM? 
CONFLICT_ID, NAME, PAR_ROW_ID, and TYPE 

6.d. Which table appears to support the Organization-Industries M:M relationship? 
S_OPTY_INDUST (User Name = Opportunity Industry Intersection) 

6.h. Which two columns are used to associate an opportunity with an industry? Look for 
Foreign Key Table columns that point to the tables that hold the opportunity (S_OPTY) 
and industry (S_INDUST) information. 
INDUST_ID and OPTY_ID 
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Practice 18-1 Trace Relationships between Business 
and UI Layer Objects 

Goals Explore the relationship between business layer and UI layer objects 

Time 20 - 35 minutes 

Instructions: 
In this practice, you will examine a view and determine the relationships between the UI layer 
objects and business layer objects. In particular you will be mapping applets to business components 
(BCs), and then mapping list columns or controls to BC fields. The first of these two mappings is 
easily done using About View. The second mapping requires using Siebel Tools. 

As a business analyst, you are unlikely to have to perform mapping from a BC and BC field to the 
underlying data layer objects, because the implementation team is responsible for ensuring that data 
layer objects, such as tables and columns, store business layer data efficiently. However, in this 
practice you will complete a mapping from a control to a BC field to a column in a database table. 
This will reinforce what you learned about where BC data is stored. 

1. Start the Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Return to or if necessary, start Siebel Tools: 
a. Select Start > Programs > Siebel_Tools_8.1 8.1 > Siebel Tools.   
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 
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3. Examine the Quote List View in preparation for mapping list columns and controls in this view's 
applets to BC fields. 
a. In the Siebel client, navigate to Quotes > List. 
b. Select My Quotes in the visibility filter. 
c. Select Help > About View. 
d. Verify that you are viewing the Quote List View. 
e. What two applets are displayed in this view? 

 
              

f. What business components are shown in these applets? 
 
              

g. Click OK to close About View. 

4. Map a list column in the top applet to a business component field using Siebel Tools, and 
examine its properties. Observe the behavior of pre and post default values. 
a. In the Siebel client, click New to create a quote record. 
b. Without specifying a quote name, select Menu > Save Record to save the new record. 
c. What do you observe in the Name field?  

 
              

d. While on the record, select Help > About Record.  
e. Verify that the Quote # and default name are equal to the record's Row #. 
f. Click OK. 
g. Change the Name to BAF Test Quote. 

Note: Change this value by clicking in the Name column to the right of the hyperlink, and 
then changing the text. 

h. Save the record. 
i. Return to Siebel Tools. You will figure out which Quote BC field maps to the Name list 

column. 
j. Select Applet :: Quote List Applet. 
k. Right-click in the OBLE and select Edit Web Layout. 
l. Click OK in the Read-only Object dialog. 
m. Close the Palettes pane by clicking the X in its top right corner. 
n. In the Controls/Columns pane, select Mode = 3: Edit List. In the right-hand applet layout 

pane, you should see a row of buttons, such as New, Delete, and Query, and below that a row 
of column headers in bold and a row of column values. 

o. On the row below the Name column header (in bold), click Name. Notice that the text turns 
blue and is surrounded by a border. 

p. If necessary, open the Properties window by selecting View > Windows > Properties 
Window.  

q. Confirm that immediately below the Properties window title "List Column [Name]" appears. 
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r. What is the value of this column's Field property? 
 
              

s. Close the Web Layout pane by clicking in the upper right of the pane on the X. You should 
be returned to the OBLE. 

t. If necessary, click the Object Explorer tab at the bottom of the leftmost pane to return to the 
OE. 

u. Select Business Component :: Quote | Field :: Name. 
v. Display the Properties window. You may need to click the Properties tab at the bottom. 
w. What is the Type Property of the Name field? What is the Text Length? 

 
              
Note: Text Length corresponds to the maximum character length of this field. 

x. Is the Name field required? 
 
              

y. Recall that if a name wasn't given to a quote, then a default was saved. This corresponds to a 
post default value. What is the value of the Name field's Post Default Value property? 
 
              

z. Return to the OE. 
aa. Select Business Component :: Quote | Field :: Quote Number. 
bb. Return to the Properties Window. 
cc. Recall that a new quote has this value populated with the Quote's Row ID. This corresponds 

to a pre default value. What is the value of the Quote Number field's Pre Default Value 
property? 
 
              

5. Examine a Quote's account field. Map the Account control in the Quote Entry Applet to a BC 
field, and then to a Table and Column. 
a. In your Siebel client session, select BAF Test Quote. 
b. Select the Account field in the lower Quote Entry Applet.  
c. Examine the control. How many Accounts can be associated with a Quote? How do you 

know? 
 
              
 
              

d. Add Account = Brookings Funds by clicking the Select icon, using the pick applet to locate 
and select this account, and then clicking OK.  Note the appearance of the Pick Account pick 
applet. 
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e. Return to Siebel Tools. 
f. Return to the OE. 
g. Select Applet :: Quote Entry Applet. 
h. Right-click and select Edit Web Layout. 
i. Click OK in the Read-only Object dialog. 
j. Close the Palettes pane. 
k. In the Controls/Columns pane, select Mode = 3: Edit. 
l. Verify that the applet layout in the right-hand pane appears similar to that of the Quote Entry 

Applet in the client. 
m. To the right of the Account: caption, click the text box labeled Account (no colon). 
n. Open the Properties window.  Notice that below this window's title bar is displayed "Control 

[Account]". 
o. What is the Field property for this control? 

 
              

p. What is the Pick Applet property for the Account field?  This is the applet you used to select 
the Brookings Fund account. 
 
              

q. Close the Web Layout pane by clicking the X in the upper right of the layout pane. 
r. Return to the OE. 
s. Select Business Component :: Quote  
t. Return to the Properties window. 
u. Verify that the Table property is S_DOC_QUOTE.  

Note: This is the base table for the Quote BC. 
v. Return to the OE. 
w. Select Business Component :: Quote | Field :: Account. 
x. Return to the Properties window. 
y. Notice that the Join property for this field is S_ORG_EXT. This indicates that the Account 

field is a joined field and has values that are not in the Quote base table, S_DOC_QUOTE. 
z. What is the Column property for the Account field? 

 
              
Note: These last few steps have shown you how to translate a UI control to a BC field, and 
then to a Column in a Table. 

6. Leave your Siebel Tools and Siebel Call Center sessions running. 
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Solutions 18-1  

Answers 

3.e. What two applets are displayed in this view? 
Quote List Applet and Quote Entry Applet 

3.f. What business components are shown in these applets? 
Quote is shown in both applets 

4.c. What do you observe in the Name field? 
The Quote is given a name equal to the Quote # value, which appears to be a Row ID. 

4.r. What is the value of this column's Field property? 
Name 

4.w. What is the Type Property of the Name field? What is the Text Length? 
DTYPE_TEXT and 50, respectively 

4.x. Is the Name field required? 
Yes: the Required property is TRUE 

4.y. Recall that if a name wasn't given to a quote, then a default was saved. This corresponds to 
a post default value. What is the value of the Name field's Post Default Value property? 
Field: 'Quote Number' 

4.cc. Recall that a new quote has this value populated with the Quote's Row ID. This 
corresponds to a pre default value. What is the value of the Quote Number field's Pre 
Default Value property? 
Field: 'Id' 

5.c. Examine the control. How many Accounts can be associated with a Quote? How do you 
know? 
One Account can be associated with a Quote: the Account control has a Select icon, not an 
MVG Select icon. When you open the applet, you can select only one record. 

5.o. What is the Field property for this control? 
Account 

5.p. What is the Pick Applet property for the Account field?  This is the applet you used to 
select the Brookings Fund account. 
Account Pick Applet 

5.z. What is the Column property for the Account field? 
NAME 
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Practice 18-2 Specifying Business Layer Solutions 

Goals Use Siebel Tools to determine solutions to customer requirements 

Time 20 - 30 minutes 

Instructions: 
In this practice, you are a business analyst for BAF Company. You will specify solutions to two 
customer requirements. Your specification will require exploration of business and UI layer objects 
and their properties. 

1. The first requirement is for BAF Company's support division. When completing a service 
request (SR), a support agent is required to enter a summary of the SR, which can be up to 200 
characters. The requirement: 
A service request is required to have a Summary of up to 200 characters. This field must be 
displayed in the service request entry view. 
a. In your Siebel Call Center session, select to Service > Service Requests List. You have 

determined that this view is where support agents can enter SRs. 
b. Use About View to verify that both applets use the Service Request business component. 
c. What are the names of the applets in this view? 

 
              

d. Examine the lower applet. Is there a control that appears to meet the requirement above? 
 
              

e. Create a SR.  
f. In the Summary in the lower applet enter some text to verify that this control and the 

underlying BC field are not read-only.  
Note: A visual clue is that the field shows white not gray. 

g. Select Menu > Undo Record so the record is not saved. 
h. Return to Siebel Tools to determine the BC field associated with the Summary control. 
i. In Siebel Tools, select the OE. 
j. Select Applet :: Service Request Detail Applet. 
k. Right-click and select Edit Web Layout. 
l. In the Columns/Control pane, select Mode = 2: Edit. 
m. Close the Palette and Columns/Control panes. 
n. Scroll to the right in the Web Layout pane until the Summary caption and control appear. 
o. Click the Summary control box, immediately below its caption. 
p. Open the Properties window. 
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q. What is the Field property of the Summary control? 
 
              

r. Verify that the Read-Only property for the control is FALSE. 
s. Close the Web Layout pane by clicking the X in its upper right corner. 
t. Return to the OE. 
u. Select Business Component :: Service Request | Field :: Abstract. 
v. Examine this BC field's properties, especially Read Only, Required, and Text Length. 
w. Determine requirement gap(s). How does the Summary BC field fail to satisfy the 

requirement at the beginning of this step? 
 
              
 
              

x. At this point you have documented gaps between Siebel as-is functionality and the 
requirement. Now you must decide how to bridge this gap: modify the requirement to meet 
the as-is functionality, configure the application to meet the requirement, or a combination of 
the two. If the decision is to configure the application to meet the requirement, then the 
solution can be written: 
For the Service Request business component, create a single-valued field SR Summary. This 
field should be writeable, marked as required, and capable of holding up to 200 characters. 
This field should be displayed in a text control on the Service Request Detail Applet. 

2. The second requirement is for opportunities. A large number of leads for BAF Company come 
from direct customer requests for product information via the Internet. Most of these information 
requests come from paid advertisements on partner and distributor websites. BAF Company 
needs to periodically assess the effectiveness of these advertisements, so you have a requirement 
to track the referring URL of an opportunity. The requirement: 
A sales opportunity has an optional referring URL, which is writeable and can be up to 100 
characters. If this field is populated, then the opportunity must be labeled as coming from the 
Internet channel. 
a. In the Siebel client, select Opportunities > Opportunities List. 
b. Drill down on an Opportunity. 
c. Click the More Info tab. 
d. Examine the lower detail applet.  
e. Click the Channel drop-down control (in the middle towards the top). Examine the values 

that appear. You decide that this control is suitable for describing the opportunity channel. 
This drop-down should have the value "Internet" if the opportunity has a referring URL. 

f. What is the name of the lower applet? 
 
              

g. Notice the Source MVG control right below the Channel control. You discard this field as a 
candidate for the requirement, as it is a multi-value field, and it may have other uses in the 
application. 

h. Click the Referred By select control (on the right almost half-way down the form). This field 
is single-valued. 
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i. Does this control seem suitable to store the referring URL? 
 
              

j. After closely examining this applet, you don't find any suitable control to hold the referring 
URL.  Next, you will use Siebel Tools to determine if the Opportunity BC has a field not 
exposed in the detail applet you were examining that is used to store the referring URL. 

k. Return to Siebel Tools. 
l. Select the OE. 
m. Select Business Component :: Opportunity | Field. 
n. In the Fields list, query for Name = *URL*. Although there is a match, 

TeamspaceSymbolicURL, this field is not used for storing a referring URL. 
o. Scroll right and query for Comments = *URL*. You could try other searches, but you decide 

that you need a new BC field to hold the referring URL.  
p. As part of your specification, you will create a validation criterion based on the Channel 

control you examined earlier in this practice. 
i. Select Applet :: Opportunity Form Applet - Child Big. 
ii. Right-click and select Edit Web Layout. 
iii. Click OK at the Read-Only dialog. 
iv. In the Columns/Controls pane, select Mode = 2: Edit. 
v. Close the Palettes and Columns/Controls panes. 
vi. In the web layout, select the Channel control (not the caption). 
vii. Verify that the Channel control's Field property is Channel. 

Note: You want this field (Channel) to be set to Internet when the new Referring URL 
field is filled in. 

q. The solution you document is: 
For the Opportunity BC, create a new field, Referring URL, which is not required, that can 
hold 100 characters, and is displayed in the Opportunity Form Applet - Child Big. Also, if 
the Channel field's value is Internet, then the Referring URL should be non-null.  

3. Leave your Siebel Tools and Siebel Call Center sessions running. 
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Solutions 18-2  

Answers 

1.c. What are the names of the applets in this view? 
Service Request List Applet and Service Request Detail Applet 

1.d. Examine the lower applet. Is there a control that appears to meet the requirement above? 
The Summary control appears to be what the requirement asks for 

1.q. What is the Field property of the Summary control? 
Abstract 

1.w. Determine requirement gap(s). How does the Summary BC field fail to satisfy the 
requirement at the beginning of this step? 
The Abstract field can only hold 100 characters and is not marked as required. 

2.f. What is the name of the lower applet? 
Opportunity Form Applet - Child Big 

2.i. Does this control seem suitable to store the referring URL? 
No -- the Referred By control opens a picklist that appears to display Contacts, not URLs. 
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Practice 19-1 Exploring Business Objects 

Goals Explore business objects, business object components, and links 
Determine the cardinality of a relationship between entities in the user interface (UI) 
and Siebel Tools 

Time 30 - 45 minutes 

Instructions: 
A business object (BO) associates records from one business component (BC) with records of 
another BC.  In this practice you will explore the display of a BO in the Siebel user interface, and the 
underlying object definitions in Siebel Tools.   

1. Return to or if necessary, start Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Return to or if necessary, start Siebel Tools: 
a. Select Start > Programs > Siebel_Tools_8.1 8.1 > Siebel Tools.   
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

3. Examine the Opportunities screen and explore the UI presentation of a business object. 
a. In the Siebel client, navigate to Opportunities > Opportunities List. 
b. Query for Opportunity Name = Honeywell Automation Master SLA Renewal. 
c. Drill down on this record. 
d. Select Help > About View. 
e. Verify that you are in the Opportunity Detail - Contacts View and that the BO displayed is 

Opportunity. 
f. Notice that the Opportunity's master BC, Opportunity, is displayed in the top detail applet, 

while a child BC, Contact, is displayed in the lower list applet. 
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g. Click OK. 
h. Look at the data in the view.  Notice there is an opportunity record displayed at the top and 

several contacts displayed at the bottom. This tells you that one opportunity can have many 
associated contact. 

i. Before you can determine the cardinality of the Contact - Opportunity relationship, see if a 
contact can be associated with multiple opportunities. 
i. In the Contacts child applet, drill down on Thaddeus Bensley's last name. 
ii. Use Help > About View to confirm that you are now in the Contacts screen and are 

looking at the Contact BO. 
iii. Click OK. 
iv. In the middle of the view, use the view tab drop-down list to select Opportunities. 
v. Verify that you see multiple opportunity records for Mr. Bensley.  Based on what you 

have found, what is the cardinality of the Opportunity - Contact relationship? 
 1 : M 
 M : 1 
 M : M 

vi. In the thread bar, click Opportunity:Honeywell Automation Master SLA Renewal to 
return to the opportunity. 

j. In the top applet, examine the Account control.  
k. How many accounts are associated with an opportunity? 

 
              

l. Examine the view tabs and the view tab drop-down list. Notice that there is no view tab for 
Accounts. 

m. On the link bar, click Opportunities List. 
n. Drill down on the opportunity's Account hyperlink.  
o. Use Help > About View to verify that you are now in the Accounts Screen, and the current 

view's BO is Account. 
p. Use the view tab drop-down list to select Opportunities.  
q. Verify that the Honeywell Automation and Control Systems account is associated with 

multiple opportunities. 
r. Use the thread bar to return to the opportunity. 
s. Based on what you have found, what is the cardinality of the Opportunity - Account 

relationship? 
 1 : M 
 M : 1 
 M : M 

t. Drill down again on Honeywell Automation Master SLA Renewal 2008. 

4. Use Siebel Tools to examine the object definitions associated with the Opportunity BO. 
a. In Siebel Tools, select the OE. 
b. Select Business Object :: Opportunity. 
c. Expand Business Object in the OE and select Business Object Component.  
d. Notice the large number of Business Object Component definitions that appear in the OBLE. 
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e. In the Business Object Component list, query for Bus Comp = Contact. 
f. Drill down on the Opportunity/Contact Link property. 
g. Select the Properties Window. 
h. Notice that the Inter Table property of this link is S_OPTY_CON. This is the intersection 

table that associates Opportunities with Contacts and vice versa. 
Note: The presence of a non-null value for this property confirms that the Opportunity - 
Contact relationship is M:M.   

i. Select the OE. 
j. Select Link :: Account/Opportunity.  

Note: This link is used to specify Opportunities associated with an Account. 
k. Select the Properties Window. 
l. Notice that the Cascade Delete property = Clear. This indicates that if an Account is deleted, 

then all opportunities for the account will remain, but the connection between the opportunity 
and the account is cleared out. 

m. Notice that the Inter Table property is blank. This confirms that the relationship is a 1:M not 
an M:M. 

5. You have been given a requirement to explore. Telesales representatives for BAF Company 
often need to view a list of competitors when following up on an opportunity. With this 
knowledge, they can collect and transmit sales collateral and performance data that targets key 
competitors.  
a. In the Siebel Client, select Opportunities > All Opportunities. 
b. Drill down on any opportunity. 
c. Examine the view tabs and the view tab drop-down list. Verify that Competitors does not 

appear. 
d. Before going to Siebel Tools to research further, you want to find which BC is associated 

with Competitors. Use the Site Map to select Competitors > Competitor List. 
e. Use Help > About View to confirm that competitors are represented by the Competitor BC. 
f. In Siebel Tools, select the OE. 
g. Select Business Object :: Opportunity | Business Object Component. 
h. In the Business Object Components list, query for Bus Comp = Competitor. What do you 

find? 
 
              

i. Return the Siebel client. 
j. In the Site Map, select Opportunities. 
k. Scan the list of Opportunities views. Verify that there is a link to Opportunities > List > 

Competitors.  
l. Drill down on this link. 
m. In the top applet, query for Name = NorthPoint - $30M IPO. 
n. Note that two competitors appear in the bottom list applet. 

O
ra

cl
e 

U
ni

ve
rs

ity
 a

nd
 (O

ra
cl

e 
C

or
po

ra
tio

n)
 u

se
 o

nl
y.

Th
es

e 
eK

it 
m

at
er

ia
ls

 a
re

 to
 b

e 
us

ed
 O

N
LY

 b
y 

yo
u 

fo
r t

he
 e

xp
re

ss
 p

ur
po

se
 S

EL
F 

ST
U

D
Y.

  S
H

AR
IN

G
 T

H
E 

FI
LE

 IS
 S

TR
IC

TL
Y 

PR
O

H
IB

IT
ED

.



Lesson 19: Siebel Business Objects 

130 Siebel 8.1.x Business Analyst Oracle 

o. To see why the Opportunity Detail - Competitors View wasn't initially accessible, examine 
the default tab layout for SADMIN. 
i. From the application menu, select Tools > User Preferences. 
ii. Select Tab Layout from the link bar drop-down list. 
iii. Select Opportunities in the top applet.  

Note: The records that appear in the lower View Tab Layout applet are all potentially 
accessible through a view tab in the Opportunities screen. 

iv. In the bottom applet, query for Name = Competitors. 
v. Verify that the Hide flag is checked. This means that the Competitors view tab is hidden 

from SADMIN by default. However, it appears as a view tab once the user has navigated 
to the view using the Site Map and remains visible for the remainder of user's session. 
Note: Users can turn these on and off to customize what they see in screens. 

p. You conclude that the necessary business and UI layer objects are part of the as-delivered 
Siebel application, and that the requirement will be met by simply unsetting the Hide 
property for the Competitors view tab. 
Recommendation: Don't depend on the visible view tabs to determine if a business object 
component exists. Instead, start by checking the Site Map. As you saw, a user's tab layout 
may cause some view tabs to be hidden. 

6. Research a second requirement. Telesales reps occasionally need access to a wide range of 
account data when pursuing an opportunity. This can be done by drilling down an opportunity's 
account in the Opportunities List View, but this is awkward. Instead, users what a view that 
displays Opportunity detail and Account detail. 
a. Recall from an earlier step in this practice that the Opportunities Screen had no Account view 

tab. 
b. In the Siebel client, select Site Map > Opportunities. 
c. Confirm that there is no link under Opportunities that seems to go to Account. 
d. Return to Siebel Tools to determine if there are business layer object definitions to support 

the proposed Opportunity - Account detail view. 
e. Select Business Object :: Opportunity | Business Object Component. 
f. In the Business Object Component list, query for Bus Comp = Account. 
g. Notice that there is an Account business object component definition and an 

Opportunity/Account link definition.   
h. You conclude that this requirement can be supported by creating a view that displays both 

Account and Opportunity detail applets. 
Conclusion: The Siebel repository contains a large number of business object component and 
link definitions. 

7. Leave Siebel Tools and the Siebel client running. 
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Solutions 19-1  

Answers 

3.i.v. Verify that you see multiple Opportunity records for Mr. Bensley.  Based on what you have 
found, what is the cardinality of the Opportunity - Contact relationship? 
M : M 

3.k. How many accounts are associated with an opportunity? 
One 

3.s. Based on what you have found, what is the cardinality of the Opportunity - Account 
relationship? 
M : 1 (many opportunities to one account, one account per opportunity) 

5.h. In the Business Object Components list, query for Bus Comp = Competitor. What do you 
find? 
Competitor is a Business Object Component of Opportunity and there is an 
Opportunity/Competitor link definition. 
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Practice 20-1 Exploring Picklists  

Goals Explore static and dynamic picklists 
Add a value to a list of values 

Time 20 - 25 minutes 

Instructions: 
You will explore static and dynamic picklists, starting with their appearance in the UI. A very 
common and easily-solved requirement is to add or modify values that appear in a static picklist. 
You will examine a static picklist in the Siebel client and in Siebel Tools, and then use 
administrative functionality in the client to add a value to the picklist. 

Dynamic picklists are common, but a little more complex than static ones. You will use the Siebel 
client and Siebel Tools to examine a dynamic picklist. You will determine key characteristics of the 
dynamic picklist, such as which business component (BC) the pick field refers to (the Pick BC), 
which field from the Pick BC is used, and the pick applet.  

1. Return to or if necessary, start Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Return to or if necessary, start Siebel Tools: 
a. Select Start > Programs > Siebel_Tools_8.1 8.1 > Siebel Tools.   
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 
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3. Compare the appearance of static and dynamic picklists and multivalue groups (MVGs) in the 
Siebel client. 
a. In the Siebel client, select Service > Service Requests List. 
b. Ensure My Service Requests is selected in the visibility filter drop-down list. 
c. In the lower applet, locate the Status field.  
d. Notice the drop-down arrow. This is typically the visual cue for a static picklist.  
e. Click this arrow and notice a drop-down list of values. 
f. Exit the list by clicking somewhere else. 
g. In the lower applet, locate the Owner field. 
h. Notice the Select icon  in this field. This is typically the visual cue for a dynamic picklist. 

Note: The Select icon is very similar to the MVG Select icon , but it only has one dot on 
the left side, instead of two. 

i. In the Owner field, click the Select icon. A pick applet appears. Usually dynamic picklists 
use a pick applet to allow the user to select a value. 

j. Click Cancel. 

4. Use Siebel Tools to identify picklist properties for the service request Status field you examined 
in the previous step. 
a. Identify the BC field displayed in the Status control. 

i. Still in the Siebel client, click the Service Requests List on the link bar (at the top). 
ii. Select Help > About View. 
iii. Notice that the lower applet, where the Status drop-down appears, is the Service Request 

Detail Applet, and this applet displays the Service Request BC. 
iv. Click OK. 

b. In Siebel Tools, select Applet :: Service Request Detail Applet. 
c. Right-click and select Edit Web Layout.  
d. In the Controls/Columns pane, Select Mode = 2: Edit. 
e. Close the Palettes and Controls/Columns panes. 
f. In the layout, locate the Status caption and control and click in the Status text box.  
g. In the Properties window, confirm that Control [Status] appears below the Properties title. 
h. Notice that the Field property is Status. 
i. Close the Web Layout pane by clicking the X in its upper right. 
j. Select the OE. 
k. Select Business Component :: Service Request | Field :: Status. 
l. In the Fields list, scroll to the right to locate the Picklist property. What is its value? 

 
              

m. Drill down on the Picklist value. Verify that you are now looking at a Picklist object 
definition in the OBLE. 
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n. Select the Properties Window. 
o. Two properties are important when locating the picklist's list of values (LOV) are Business 

Component and Type Value. Verify that Business Component = PickList Generic and Type 
Value = SR_STATUS. 
Note: Business Component = PickList Generic means that the list of values for the picklist is 
stored in the S_LST_OF_VAL table and is administered in the List of Values view in the 
Siebel client. The Type Value is used to identify LOV records in this table for this list. 

5. Add a value to the Status picklist's LOV. 
a. In the Siebel client, navigate to Administration - Data > List of Values.  

Note: This view displays a list containing records for all LOV values in the Siebel 
application. Each LOV is distinguished by its Type Value. 

b. Query for records with Type = SR_STATUS. Each record in the query result set corresponds 
to a value in the SR Status drop-down list. 
Note: An alternate, possibly faster method to locate a picklist's type is to query in this list 
without using Siebel Tools. Select a unique-looking value in the picklist, such as Re-Opened 
for SR Status, and query for this value in the Display Value column. If there are multiple 
records with this Display Value, then use the Type as a guide. In this example, only one LOV 
entry has Display Value = Re-Opened, and this record has Type = SR_STATUS, which can 
be used in a query to locate other records in the LOV. 

c. Create a new record with: 
Type SR_STATUS 
Display Value Acknowledged 
Language-Independent Value Acknowledged 
Language Name English-American 
Order 1 
Active Checked 
Translate Not-checked 

d. Save the record. 
e. Click Clear Cache, which ensures that the new value is available immediately in the Siebel 

client. 
f. Select Service > Service Requests List. 
g. Select the first SR record. 
h. In the lower applet, click the Status drop-down control. 
i. Verify that Acknowledged now appears in the drop-down list. 

6. Use Siebel Tools to explore the picklist associated with the Owner of a service request.  

Note: The Owner Control maps to the Owner field in the Service Request 
BC.  You could have determined this, but you are given this information to save time.  
a. In Siebel Tools, select the OE. 
b. Select Business Component :: Service Request | Field :: Owner. 
c. Select the Properties Window. 
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d. What is value of the Picklist property for the Owner field? 
 
              

e. In the Fields list, scroll to the right and locate the Picklist property. 
f. Drill down on the PickList SR Owner hyperlink. 
g. Examine the Picklist's properties in the OBLE or Properties Window.  
h. Notice that the Business Component value is Employee. This is the BC that the dynamic 

picklist draws data from. This is referred to as the pick BC, while Service Request is the 
invoking BC. 

i. Select Business Component :: Service Request | Field :: Owner. 
j. In the OE expand Field and select Pick Map.  

Note: This object definition specifies the field mapping between the invoking BC (Service 
Request) and the pick BC (Employee).  

k. In the Pick Maps list, select Field = Owner. 
l. Confirm that Picklist Field = Login Name. This is the BC field in the Employee BC that is 

used to populate the SR Owner field. 
m. Now determine the pick applet used for the Service Request Owner field. 

i. Select Applet :: Service Request Detail Applet | Control :: Owner. This is the control that 
displays the Owner field in the SR detail applet. 

ii. In the Controls list, scroll to the right and confirm that the Pick Apple t= SR Owner Pick 
Applet. This applet is used to select the SR Owner. 

iii. Drill down on the Pick Applet property hyperlink. 
iv. Right-click and select Edit Web Layout. 
v. Click OK. 
vi. In the Controls/Columns pane, verify Mode = 1: Edit List. 
vii. Close the Controls/Columns and Palette panes. 
viii. Return to the Siebel client, open the Owner field in the service request. Compare it to 

the layout you see in Siebel Tools 
ix. In the client, click Cancel. 
x. In Siebel Tools, close the Web Layout pane.  

 
Conclusions regarding the Owner control/field and its picklist: 
Invoking BC Service Request 
Invoking BC Field Owner 
Picklist PickList SR Owner 
Pick BC Employee 
Pick BC Field Login Name 
Pick Applet SR Owner Pick Applet 

7. Leave your Siebel Call Center and Siebel Tools sessions open. 
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Solutions 20-1  

Answers 

4.l. In the Fields list in the OBLE, scroll to the right to locate the Picklist property. What is its 
value? 
FIN PickList Service Request Status 

6.d. What is value of the Picklist property for the Owner field? 
PickList SR Owner 
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Practice 20-2 Exploring MVGs (Optional) 

Goals Explore MVGs and supporting objects 

Time 10 - 15 minutes 

Instructions: 
A MVG associates with a record multiple related records from another BC. For example, the 
Business Address MVG for the Service Request BC associates one or more business addresses with 
an SR. The MVG allows display of multiple fields associated with a MVG to be displayed in a form 
applet. As you will see in this practice, the address, city, state, country, and postal code of an SR's 
business addresses can be displayed in a form applet 

Here is an example of a requirement related to MVGs: 
Allow quick access to address information  for a Service Request and display the street address, city, 
state, postal code, country, longitude, and latitude for an address. 

In this practice you will start by looking at the visual appearance of MVGs, and then use Siebel 
Tools to gather the information needed to specify the solution to a requirement. 

1. Use the Siebel client to examine the visual appearance of an MVG. 
a. In the Siebel client, navigate to Service Requests > Service Requests List. 
b. Create a service request. 
c. Drill down on the SR #. 
d. In the middle of the screen, select the Service Details view tab. 
e. In the top applet, select Last Name = Aamos. 
f. In the lower applet, in the Contact Service Location area, click in the Address field. 
g. Notice the MVG Select icon . This is the visual cue for an MVG. 
h. Click the MVG Select icon. The Account Addresses shuttle applet should appear.  

Note: This type of applet is commonly used to allow a user to select one or more BC records 
to associate with an MVG. Notice that both lists in the shuttle applet display multiple 
columns. 

i. In the Available list, query for Street Address = 200 Handler Road. 
j. Select it and click Add. 
k. Click OK. 
l. Verify that values in the Address, Address Line 2, City, State, Zip Code, and Country 

controls have changed to match the selection you made in the MVG pick applet.  
Note: An MVG can be associated with several multivalue fields (MVFs). 
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2. Use Siebel Tools to explore the MVG associated with the Address of a service request. This 
column displays the "Personal Street Address (Service Detail)" field of the Service Request BC. 
You could have determined this on your own, but you are given this information to save time.  
a. In Siebel Tools, select Business Component :: Service Request | Field :: Personal Street 

Address (Service Detail). 
Note: Use double quotes or asterisk when querying for the field name, because the field name 
contains parentheses. 

b. Select the Properties Window. 
c. Notice that the Picklist property is blank. However, the Multi Valued property for this field is 

TRUE, and the Multi Value Link property is Personal Address. 
d.  Query for other Service Request BC fields that share the same multivalue link. 

i. In the Fields list, query for Multivalue Link = Personal Address.  
ii. Verify that you receive six records. 

Note: These Fields map to the Control Captions in the applet at the beginning of this 
practice as follows: 
Service Request BC Field Name UI: Control Caption 

Personal Street Address (Service Detail) Address 

Personal Street Address 2 Address Line 2 

Personal City (Service Detail) City 

Personal State (Service Detail) State 

Personal Postal Code (Service Detail) Zip Code 

Personal Country (Service Detail) Country 
If you need to map additional fields to the MVG, such as longitude and latitude 
mentioned in the requirement at the top of this lab, then these fields could be added 
through this link. 

e. Select Business Component :: Service Request | Multi Value Link :: Personal Address.  
Note: This child definition governs the multi value fields associated with the Address MVG. 

f. Examine the Multi Value Link properties. Verify that the value of this link's Destination 
Business Component property is CUT Address. 

g. Determine the MVG applet used for the Address MVG control. The applet this control was 
displayed in is "FS Service Request Detail Applet NB' and the control is 
PersonalStreetAddress.  
i. Select Applet :: FS Service Request Detail Applet NB | Control :: PersonalStreetAddress.  
ii. In the Controls list, scroll to the right and confirm that the MVG Applet property = 

Address Mvg Applet.  
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You have looked at the following key MVG characteristics: 
Invoking BC Service Request 
Invoking BC Field Personal Street Address (Service Detail) 
Multi Value Link Personal Address 
Destination BC CUT Address 
Fields mapped with this MV Link Refer to table earlier in this step 

MVG Applet Address Mvg Applet 

3. Select File > Log Out to exit the Siebel client. 

4. Leave your Siebel Tools open. 
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Practice 21-1 Customizing Screen and View Tabs 

Goals Customize screen and view tabs for a single user 
Customize screen and view tab layout for a responsibility 

Time 30 - 40 minutes 

Instructions: 
In this practice you will customize the screen and view tab layout at two different levels: for an 
individual user and for a responsibility. You can use the first to quickly prototype tab layout as part 
of an implementation project, or simply to allow you to quickly access the screens and views you 
frequently visit. Modifying tab layout for a responsibility allows you to present a more efficient user 
interface to different types of users. For example, employees with the Telesales Representative 
responsibility may constantly access Opportunities, Contacts, Quotes, and Sales Orders, but only 
rarely access Service Requests. Their screen tab layout can be tailored to reflect those use patterns. 
Similar considerations hold for view tabs. 

1. Start Siebel Call Center Developer Web Client:   
Note: You will log in as APPADMIN a user you have not used before. 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID APPADMIN 
Password APPADMIN 
Connect to Sample 

c. Click OK. 

2. You are APPADMIN, a Siebel administrator for BAF Company. You wish to customize your tab 
layout as follows: 
Screen tabs, in order from left to right, should be Home, Administration - Application, 
Administration - Data, Administration - Group, Administration - User, Inbox, and Contacts. 
Only view tabs in the Contacts screen should be changed. The default view for the Contacts 
screen tab should be the All Contacts list instead of the Contact Home Page. The view tab layout 
when drilling down from a record in the Contact list applet should be: More Info, Activities, 
Assets, and Service Requests. 
a. Verify the current screen tab layout: Home Accounts, Contacts, Opportunities, Sales Orders, 

Service, Quotes, Administration - Product. 
b. Select Tools > User Preferences. 
c. From the link bar drop-down list, select Tab Layout.  

Note: This is how an individual user can modify tab layout. 
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d. In the top applet query for Hide = unchecked. This will return all screen tabs that are visible 
when APPADMIN logs in. 

e. Select Query > Save Query As. 
f. Enter Query Name = BAF Visible Screen Tabs and click OK. You will use this query 

several times. 
g. Verify that the screen tab results are sorted by Order in ascending order and that the Names 

match the order of the screen tabs that are visible, except for User Preferences. 
h. Click Hide for all query results except for Home and Contacts. 
i. Select Menu > Refine Query and then click Go. This reruns the query for visible screen tabs. 

You should see only two screen tabs listed. 
j. Query for Name = Administration - *. You will see many results.  
k. Widen the Name column so that you can see the full screen tab name. 
l. Sort by Name. 
m. Scroll down and uncheck the Hide flag for Administration - Application, Administration - 

Data, Administration - Group, and Administration - User. 
n. Execute the BAF Visible Screen Tabs saved query.  
o. Confirm that you have six screen tabs that are not hidden. 
p. Query for Name = Inbox. 
q. Uncheck the Hide column for this screen tab. 
r. Rerun the Visible Screen Tabs saved query. You should see all seven of the required screen 

tabs. 
s. Run a blank query. 
t. Click the Order column twice to sort by descending. You should see a value of 181 in the top 

row. 
u. Rerun the Visible Screen Tabs saved query. 
v. You need to put the screen tabs in the required order by putting Contacts last. Change the 

Contacts screen Order value to 190. 
w. Save the record. 
x. In the top applet, select Contacts. 
y. In the bottom applet, query for Name = "All Contacts". 
z. Check the Default View column. 
aa. Query in the bottom applet for Hide = unchecked. This query shows view tabs that are visible 

by default in the Contacts screen. 
bb. Select Query > Save Query As. 
cc. Enter Query Name = BAF Visible View Tabs and click OK. 
dd. In the bottom applet, hide all view tabs: 

i. Press CTRL-A to select all records. 
ii. In the application-level menu, select Edit > Change Records. 
iii. In the 1st Field to Change area, set: 

Field Hide 
VALUE Y 

iv. Click OK. The View Tab Layout applet should now be empty. 
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ee. Query for and uncheck Hide for the following view tabs: 

• More Info 
• Activities 
• Service Requests 
• Assets 
• All Contacts 

ff. Execute the BAF Visible View Tabs saved query.  
gg. Select Contacts in the top applet to see the results. 
hh. In he bottom applet, verify that you see the desired view tabs in the correct order: More Info, 

Activities, Assets, and Service Requests. 
Note: All Contacts appears out of order, as it is the default view, but it does not appear as a 
view tab, but instead is the default setting of the visibility filter. 

3. Confirm that APPADMIN has the correct tab layout. 
a. Select File > Connect. 
b. Re-log in to Siebel Call Center by entering: 

User ID APPADMIN 
Password APPADMIN 
Connect to Sample 

c. Click OK. 
d. Verify that the screen tab layout meets the above requirement: 

 
e. Select the Contacts screen tab. 
f. Confirm that the All Contacts list appears. 
g. Drill down on a contact record. 
h. Confirm that the view tab layout meets the above requirement: 

 

4. Field service dispatchers at BAF Company need quick access to the Service Orders screen. This 
screen is used to manage orders for on-site product installation and maintenance.  Dispatchers 
need to view this data when communicating with field service technicians. You, as APPADMIN, 
have been tasked with making this screen accessible through a screen tab. 
a. Select the Administration - Application screen tab. 
b. From the view link drop-down list, select Responsibilities. 
c. Query for Responsibility = "Dispatcher". All BAF dispatchers are assigned this 

responsibility. 
d. Notice the list of Users with this responsibility in the bottom right applet. 
e. Select the Tab Layout view tab. 
f. Explore the Responsibility Detail - Tab Layout View, which displays four applets. The top 

applet displays a responsibility. The second applet down allows you to select a Siebel 
application: each responsibility can define a set of screen and view tabs per application. The 
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next two applets are familiar from the previous steps in this practice: they present the screen 
and view tab layouts. 

g. With Dispatcher selected in the Responsibilities applet, query for Application Name = Siebel 
Universal Agent in the second applet. This is the Siebel Call Center application. 

h. Query in the Screen Tab Layout applet for Hide = unchecked. 
i. Verify that Service Orders is not among the visible screen tabs. 
j. Query for Name = Service Orders in the Screen Tab Layout applet. 
k. Uncheck the Service Orders' Hide flag and save the record. This screen tab's order is not 

important to meet the requirement. 
l. Click Clear Cache in the top applet. 

5.  Test the new screen tab for BAF employee Casey Cheng. 
a. Still in APPADMIN's session, select the Administration - User screen tab. 
b. Select Employees on the link bar. 
c. Query for User ID = CCHENG. 
d. In the Responsibilities column, click the Select control. 
e. Verify that CCHENG has the Dispatcher responsibility. 
f. Click OK. 
g. Start a second Siebel Call Center Developer Web Client session:   

Note: You will log in as Casey Cheng (CCHENG): 
i. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
ii. Enter: 

User ID CCHENG 
Password CCHENG 
Connect to Sample 

iii. Click OK. 
h. Confirm that you do not see the Service Orders screen tab! 
i. Select File > Log Out to end CCHENG's session. 
j. Return to APPADMIN's Siebel Call Center session to figure out why. 
k. Select the Administration - User screen tab. 
l. Select Employees on the link bar. 
m. Query for User ID = CCHENG. You must requery to refresh the data. 
n. In the Responsibilities column, click the Select control. 
o. Notice that the HT Call Center Agent responsibility has a check mark under Primary. This 

means that it is the primary responsibility for the user and it controls the screen/tab layout. 
p. Check Primary next to the Dispatcher responsibility and step off the record. 
q. Click OK. 
r. Save the record. 
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s. Start a new Siebel Call Center Developer Web Client session:   

Note: You will log in again as Casey Cheng (CCHENG): 
t. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
i. Enter: 

User ID CCHENG 
Password CCHENG 
Connect to Sample 

ii. Click OK. 
u. Look in the screen tabs list. You may need to use the drop-down at the right. Verify Service 

Orders now appears. 

6. Leave the CCHENG session running. 

7. Return to the APPADMIN session and select File > Log Out. 
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Practice 21-2 Examining Drilldowns  

Goals Examine drilldown behavior in a list applet 
Explore required information for specifying a static drilldown 

Time 5 - 10 minutes 

Instructions: 
Navigation aids -- such as drilldowns, the thread bar, and screen and view tabs -- have an important 
role in increasing user productivity and speeding application adoption by end users. A business 
analyst will identify navigation devices in meeting requirements and specify key data for these 
navigation aids. 

In this practice, you will examine the behavior of static drilldowns in the Contact List applet. Then, 
in Siebel Tools, you will identify key characteristics of these drilldown objects, such as the list 
column (and associated BC field) that is hyperlinked and the destination view for the hyperlink. This 
information is needed to formulate requirements.  

1. Return to the CCHENG Call Center session. 

2. Explore drilldown behavior in the Contact List View. 
a. Select Contacts > All Contacts. 
b. Notice that there are hyperlinks, displayed in blue, in three list columns of the Contact List 

Applet: Last Name, Account, and Email. 
c. Select Help > About View. 
d. Verify that the view = Contact List View, and the list applet = Contact List Applet. 
e. Click OK. 
f. Drill down on Last Name = Ahl. 
g. Use About View to confirm that the following objects are displayed: 

Business Object Contact 
View Contact Detail View 
Applet[0] (top) Contact Form Applet 
Applet[1] (bottom) Contact Activity List Applet 
BC[0] Contact 
BC[1] Action 

h. Click Contacts List on the link bar. 
i. Drill down on Avram Ahl's Account, 3Com. 
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j. Use About View to confirm the objects that are displayed: 

Business Object Account 
View Account Detail - Activities View 
Applet[0] (top) SIS Account Entry Applet 
Applet[1] (bottom) Account Activity List Applet 
BC[0] Account 
BC[1] Action 
Note: One important difference between these drilldowns is that they navigate to views 
displaying different business objects. The Last Name drilldown navigates to another view in 
the Contacts screen, while the Account drilldown navigates to a different screen and business 
object. 

k. Use your browser's Back button to return to the contacts list.  
l. Select All Contacts in the visibility dropdown filter. 
m. Drill down on Avram Ahl's Email hyperlink.  What happens? 

 
              

n. Click Cancel and Yes to exit the email dialogs. 
o. If you see an email, select File > Close. 

3. Leave CCHENG's Siebel Call Center session open. 

4. Return to or if necessary, start Siebel Tools: 
a. Select Start > Programs > Siebel_Tools_8.1 8.1 > Siebel Tools.   
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

5. Examine the Last Name drilldown in the Contact List Applet in Siebel Tools.   
Note: Recall the following information about the drilldown destination: 
Business Object Contact 
View Contact Detail View 
Applet[0] (top) Contact Form Applet 
Applet[1] (bottom) Contact Activity List Applet 
BC[0] Contact 
BC[1] Action 

a. In Siebel Tools, select the OE. 
b. Select Applet :: Contact List Applet. 
c. In the OE, expand Applet and select Drilldown Object. 
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d. In the Drilldown Objects list, select Name = Original.  
e. Notice that the View property  = Contact Detail View 

Note: This is the view the user sees after drilling down.  It matches the value listed above. 
f. Verify that the drilldown's Hyperlink Field property =  Last Name.  

Note: This is the Contact BC field that is displayed in the Last Name list column. 

6. Explore the Account drilldown in the Contact List Applet in Siebel Tools. .   
Note: This example is more complicated, because the drilldown destination displays a different 
business object. Recall the following information about the drilldown destination: 
Business Object Account 
View Account Detail - Activities View 
Applet[0] (top) SIS Account Entry Applet 
Applet[1] (bottom) Account Activity List Applet 
BC[0] Account 
BC[1] Action 
a. Select Applet :: Contact List Applet | Drilldown Object :: Account. 
b. Examine this drilldown object in the Properties Window. 
c. Confirm that this object's View property = Account Detail - Activities View, as you found 

earlier in the practice.  
d. Notice that the Business Component property = Account, which is the master BC in the 

destination view. 

7. Examine the Email hyperlink in the Contact List Applet in Siebel Tools. 
a. Select Applet :: Contact List Applet | Drilldown Object. 
b. Notice that there is no drilldown object with Hyperlink Field = Email Address. 
c. Select Applet :: Contact List Applet | List :: List | List Column :: Email Address. This is the 

definition of the List Column with the hyperlink that opens an email form. 
d. In the Properties Window, examine the list column's properties. 
e. Confirm that the HTML Type property = Mailto.  This property dictates how the list column 

is displayed.  
f. Click the drop-down arrow in the HTML Type property. 
g. Notice that there are quite a few formatting options, such as URL (a Web link), a label, many 

types of button, and so on 
Note: the Email list column resembles a drilldown, however the navigation to an email form 
is done in the list column's HTML code. 

8. In Siebel Call Center, select File > Log Out to exit the application. 

9. Leave Siebel Tools running. 
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Solutions 21-2  

Answers 

2.m. Drill down on Avram Ahl's Email hyperlink.  What happens? 
The Siebel application does not navigate to another view: instead it opens an email form 
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Practice 22-1: Specifying a Workflow Process 

Goals Gather information from the Siebel application needed to specify an automation 
solution using Siebel Workflow 

Time 15 - 20 minutes 

Instructions: 

As a business analyst, you will often need to interpret automation requirements and specify a 
workflow that will meet these requirements. By accurately translating automation requirements into 
workflow processes, you will be able to provide meaningful specifications to the configuration team. 

In this lab, you will put together a specification for a workflow for the following requirement: 

"When the user creates or modifies a contact record, create a contact identifier formed from the 
first letter of the contact's first name prepended to the contact's last name." 

 
For example, a contact named Sam Mailer would have contact identifier SMailer.  

Note that the specification does not address how the contact identifier appears in the user interace, 
and does not discuss how the identifier is represented in the business layer. You decide that the 
contact identifier should be visible in the Contacts List > More Info applet, and that it will be stored 
as a business component field for Contact. 

Implementation Note: This simple requirement could be implemented without using a workflow by 
using a calculated field. This means that the contact identifier field could be constructed at run-time 
by appending the contact's Last Name to the first character of his or her First Name.  However, if the 
rules for constructing the identifier were more complex, or if the identifier had to be unique across 
all contacts, then using a workflow might be the best solution. The implementation in this practice is 
used to illustrate Siebel Workflow. 

1. Start the Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

O
ra

cl
e 

U
ni

ve
rs

ity
 a

nd
 (O

ra
cl

e 
C

or
po

ra
tio

n)
 u

se
 o

nl
y.

Th
es

e 
eK

it 
m

at
er

ia
ls

 a
re

 to
 b

e 
us

ed
 O

N
LY

 b
y 

yo
u 

fo
r t

he
 e

xp
re

ss
 p

ur
po

se
 S

EL
F 

ST
U

D
Y.

  S
H

AR
IN

G
 T

H
E 

FI
LE

 IS
 S

TR
IC

TL
Y 

PR
O

H
IB

IT
ED

.



Lesson 22: Introducing Siebel Workflow 

152 Siebel 8.1.x Business Analyst Oracle 

2. Examine the view and applets that will display the contact identifier. You will gather information 
to use in the workflow specification. 
a. Select Contacts > Contacts List. 
b. Create a record with: 

Last Name BAF_Adams 
First Name Aileen 

c. Step off the record to save or select Menu > Save Record. 
d. Drill down on the new contact's Last Name. 
e. Click the More Info view tab. 
f. Select Help > About View. 
g. What is the Business Object for this view? 

 
              
This information is required when specifying a workflow. 

h. What is the upper applet's name? 
 
              

i. What is the lower applet's name? 
 
              

j. What business component is displayed in both applets? 
 
              

k. Examine each control in the lower applet. Verify that there is no Contact Identifier control 
displayed.   

3. Describe the conditions that trigger the specified workflow's execution. 
a. When you created the contact record for Aileen BAF_Adams, when should the contact 

identifier have been assembled by the workflow? 
 
              

b. Should the contact identifier be created when an existing Contact record is modified? Why or 
why not? 
 
              
 
              

c. Leave your Siebel Call Center session open. 
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4. Return to or if necessary, start Siebel Tools: 
a. Select Start > Programs > Siebel_Tools_8.1 8.1 > Siebel Tools.   
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

5. Verify the business component fields of Contact that store first and last name. You will need to 
identify these fields in the specification of the workflow. You will go through the same 
procedure you used in a prior practice: mapping a list column or control to a business component 
field. 
a. In Siebel Tools, select the OE. 
b. Select Applet :: Contact Form Applet.  

Note: You could use any other applet that displays the contact's first and last name, but you 
are already familiar with this applet from earlier steps in this practice. 

c. In the OBLE, right-click the applet definition and select Edit Web Layout. 
d. Click OK in the Read-only Object dialog. You will not be changing the applet layout, so 

read-only access is fine. 
e. Close the Palettes and Controls/Columns panes. 
f. Open the Properties Window. 
g. In the rightmost pane, locate the control with caption Last Name. 
h. Click the text control to the right of the Last Name caption. The text in the control should 

turn blue.   
i. In the Properties window, what is the value of the Field property? 

 
              

j. Click the First Name text control/box. 
k. What is the value of the Field property? 

 
              

l. Close the Web Layout pane by clicking the X in its upper right. 
m. Select the OE. 
n. Select Business Component :: Contact | Field :: Last Name. 
o. What is the value of the Text Length property for this field?       

Note: This is the maximum length last name. 
p. What should the Text Length be for the new Contact Identifier field? 
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6. Examine the following workflow specification using the information you gathered, as well as the 
original requirement: 

"When the user saves a Contact record, create a contact identifier formed from the first letter of 
the contact's First Name field prepended to the contact's Last Name field. Store this identifier in 
a new business component field for Contact, and display its value in the Contact Form Applet - 
Child applet with label Contact Identifier. The contact identifier field should have text length 
sufficient to accomodate the longest last name (50 characters) without truncation. The contact 
identifier should be created when a new or existing Contact is saved. " 

7. Leave your Siebel Call Center and Siebel Tools sessions running. 
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Solutions 22-1  

Answers 

2.g. What is the Business Object for this view? 
Contact 

2.h. What is the upper applet's name? 
Contact Form Applet 

2.i. What is the lower applet's name? 
Contact Form Applet - Child 

2.j. What business component is displayed in both applets? 
Contact 

3.a. When you created the contact record for Aileen BAF_Adams, when should the contact 
identifier have been assembled by the workflow? 
When the new Contact record was saved. 

3.b. Should the contact identifier be created when an existing Contact record is modified? Why 
or why not? 
Yes, the identifier should be recreated when an existing record is modified. If a Contact is 
created with a misspelled name, then the initial contact identifier may be incorrect. If a 
user changes the Contact name, the contact identifier should be re-assembled to be 
consistent with the new name. 

5.g. In the Properties window, what is the value of the Field property? 
Last Name 

5.j. What is the value of the Field property? 
First Name 

5.m. What is the value of the Text Length property for this field? 
50 

5.n. What should the Text Length be for the new Contact Identifier field? 
51 characters: one for the first letter in the first name, plus the maximum length last name 
(50). 
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Practice 22-2: Verifying a Workflow Process 

Goals Execute and explore a prototype workflow process 
Verify that a workflow meets specifications 

Time 10 - 20 minutes 

Instructions: 
In this practice, you will execute and validate a workflow process based on the specification you 
developed in the last practice. The implementation team has provided you with a prototype 
workflow to examine and to verify that it meets the specification you developed. 

The workflow you will explore, BAF Create Contact Identifier, is a proof-of-concept 
implementation. Rather than creating a new business component field and exposing it in the UI, the 
configurator stored the contact identifier in an existing, unused field in the Contact business 
component.  This field, Mail Stop, appears in the Contact Form Applet - Child, so the results of 
workflow execution can be monitored in the Siebel client. 

If the workflow meets the specification, the configurator will add a new business component field 
and expose it in the Contact Form Applet - Child applet. 

1. Deploy the workflow in the Siebel client. You will activate an already-loaded workflow and then 
reload runtime events, which are used to trigger the workflow.  These actions would typically be 
performed during Siebel application deployment by a system or application administrator.   
a. Return to your Siebel Call Center session. 
b. Navigate to Administration - Business Process > Workflow Deployment. 
c. Click the Active Workflow Processes view tab.  

Note: The top applet displays workflows that have been published in Siebel Tools and are 
available for activation in the Siebel client.  The bottom applet lists workflows that have been 
activated and are available for execution. 

d. In the top applet, query for Name = BAF*. You should see a single matching record: BAF 
Create Contact Identifier. This is the prototype workflow that you will be examining. 

e. Click Activate. 
f. In the lower applet, query for Name = BAF*. 
g. Verify that BAF Create Contact Identifier appears, with Deployment Status = Active. 
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2. Reload runtime events. BAF Create Contact Identifier is triggered by a runtime event, and 
reloading events will ensure that the newly activated workflow is recognized by the runtime 
event handling system. 
a. Navigate to Administration - Runtime Events > Events. 
b. Select Menu > Reload Runtime Events. 
c. Verify that the workflow is now associated with an event. 

i. Query for: 
Object Type BusComp 
Object Name Contact 
Event "WriteRecord" 

Use quotes to get an exact match 
ii. Verify that there is an event with Sequence = -1 and Action Set Name = Workflow_<*>, 

where the remainder of the action set name should resemble a Row ID. 

3. Test the workflow. 
a. Select Contacts > Contacts List. 
b. If necessary, execute an empty query to populate the list. 
c. Create a record with: 

Last Name BAF_Nunez 
First Name Nate 

d. Step off the record to save it. 
Note: The list may change to display only one contact. This is a result of the way the 
workflow is written. 

e. Drill down on the new contact's last name. 
f. Click the More Info view tab. 
g. Locate the Mail Stop control in the bottom right of the More Info applet. 
h. Verify that this control contains contact identifier NBAF_Nunez. 
i. In the top applet, change the name to BAF_Nunes.  
j. Select Menu > Save Record. 
k. Verify that the Mail Stop value changes to NBAF_Nunes. 

4. Examine the BAF Create Contact Identifier in Siebel Tools. You will not be examining the 
workflow in great detail, but will use Siebel Tools' Workflow Design Canvas to trace the logical 
flow of the workflow solution. 
a. In Siebel Tools, select Workflow Process 
b. In the Workflow Processes list query for Process Name = BAF Create Contact Identifier. 
c. What is the Business Object property for this workflow definition? 

 
              

d. Right-click the workflow definition in the OBLE and select Edit Workflow Process. 
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e. Verify that you see this workflow diagram: 

 
f. What type of steps are the ones labeled "Get First and Last Name" and "Save Ientifier"?  

(Please disregard the misspelling of Identifer) 
 

 
              

g. If necessary, display the Properties pane by selecting View > Windows > Properties 
Window. 

h. Click on the workflow step labeled "Save Ientifier". 
i. What is the Operation property for this step (in the Properties window)?  

 
              

j. Look at the bottom list in Siebel Tools, the "Multi Value Properties Window".  
k. Click the Field Input Arguments tab. 
l. Verify that the Mail Stop field is listed.  

Note: This is where the workflow writes the contact identifier. The ContactCode process 
property is written to this field.  A process property is similar to a variable in programming.  
In this example, the workflow process uses a process property named ContactCode to as 
temporary storage for the contact identifier. 

m. What type of steps are labeled "Truncate First Name" and "Concatenate Names"? 
 
              

n. Notice the linear logic of this workflow, which has no branching or Decision Point steps. 
o. Explore the runtime event that triggers this workflow. 

i. Click on the connector extending from the Start step. 
ii. Verify that the Properties window displays the following connector properties: 

Event Object Type BusComp 
Event Object  Contact 
Event WriteRecord 
These values define the runtime event used to execute the workflow.   

p. Click the drop-down arrow for Event in the Properties window.  Inspect the possible values 
for this property. Verify that WriteRecordNew and WriteRecordUpdated appear in this list. 
These events occur when a new or existing record, respectively, are written to the database. 

q. Close the Workflow Design Canvas by clicking X in the upper right corner of the pane. 

5. Leave your Siebel Call Center and Siebel Tools sessions running. 
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Solutions 22-2  

Answers 

2.g. What is the Business Object for this view? 
Contact 

4.b. What is the Business Object property for this workflow definition? 
Contact 

4.f. What type of steps are the ones labeled "Get First and Last Name" and "Save Identifier"? 
Siebel Operation steps 

4.i. What is the Operation property for this step (in the Properties window)? 
Update 

4.m. What type of steps are labeled "Truncate First Name" and "Concatenate Names"? 
Business Service steps 
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Practice 23-1: Exploring Assignment Rules 

Goals Specify the components of an assignment rule 

Time 10 - 15 minutes 

Instructions: 
To accurately describe an assignment rule to the configuration team, a business analyst should be 
able to specify the rule's assignment object, candidates, and criteria. In this lab, you will examine 
each of these components for existing rules in the Sample database. 

1. Return to or if necessary, start Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Examine a simple sales assignment rule where assignment is based on geography. 
a. Navigate to Administration - Assignment > Assignment Rules List. 
b. Query for Name = "Territory 8".  

Note: Use quotes to get an exact match. 
c. Drill down on the Name. 

Note: The rule detail includes Objects to be Assigned, which specifies the assignment object.  
d. Verify that the Object to be Assigned for this rule = Account. 
e. The view tabs provide access to other critical rule information: candidates and rule criteria. 

Which tab(s) do you think specify candidates? 
 
              

f. Click the Employee Candidates, Position Candidates, and Organization Candidates view 
tabs. Which type(s) of candidate is specified for this rule? 
 
              
Often only a single type of candidate is specified for an assignment rule. 

g. List the rule candidate(s). 
 
              

h. Click the Criteria view tab. 
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i. Verify that there are two criteria for this rule. 
j. In the Criteria applet, select Account Zip Code. 
k. The Comparison Method = Compare to Object. This value means that the value provided in 

the rule will be compared to the Account Zip Code from an Account record.  
l. Scroll down to the grandchild applet.  
m. Verify that four Zip Code intervals (each containing only one Zip Code) are specified. These 

Zip Codes comprise the sales territory (Territory 8). 
n. Examine the Contact Zip Code criterion and verify that it is similar to the other criterion. 

3. Compare the rule fields that you have looked at with the following rule specification: 
"Create an assignment rule for Accounts for sales territory 8. The position candidate for the rule 
is PH 70 Pulsar ENU. Assign an account to this position if the Account Zip Code and the 
Contact Zip Code is one of 12145, 32209, 32890, or 33604." 
Verify that the Territory 8 rule meets this specification. 
Note: both rule criteria are marked as Required = Always, which means that for a given Account 
record, both criteria must be met if the Account is to be assigned to PH 70 Pulsar ENU. 

4. Explore a rule that assigns activities to service personnel based on a match between agent 
expertise and the activity's type and product. 
a. Click Assignment Rules List on the link bar. 
b. In the top applet, query for Name = COM Installation. 
c. Drill down on the Name. 
d. What is the Objects to be Assigned for this rule?          
e. In the top applet, verify that the Assignee Filter = One, Best Fit. This ensures that only the 

best-scoring candidate is assigned a given Activity record. This is needed if, for example, 
you only wish to assign a single employee to a field service activity. 

f. Click the view tabs: Employee Candidates, Position Candidates, and Organization 
Candidates. 

g. Which types of candidates are defined for the COM Installation rule? 
 
              

h. Click the Criteria tab. 
i. The first rule compares rule-provided values for Activity Type with that field in an Activity 

assignment object record. Look at the bottom applet. What values of Activity Type are 
provided in the rule? 
 
              

j. Notice that the Comparison Method for the second criteria = Compare Object to Person.  
This means that an Activity attribute will be compared with a set of corresponding candidate 
attributes. 

k. In the Criteria applet, select Product. 
l. Examine the records in the grandchild applet. Which two person attributes are specified in 

this criterion? (Do not include the Score column, which is not a person attribute.) 
 
              

m. To better understand this assignment rule, navigate to Administration - User > Employees. 
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n. Query for employee Steven Glimer. 
o. Drill down on Mr. Glimer's last name. 
p. Click the Assignment Skills tab.   

Note: The Assignment Skills applet is used to track employee proficiencies, such as language 
fluency; ability to perform different activity types, such as Installation or Field Repair; or 
product expertise. 

q. In the Assignment Skills applet, select Product. 
r. Scroll down to the bottom applet and examine Mr. Glimer's product expertise.   
s. What values are available in the Expertise dropdown? 

 
              

t. Use your browser's Back button several times to return to the COM Installation assignment 
rule detail. 

5. Compare the rule detail that you have explored with the following rule specification: 
"Create an assignment rule for Activities for COM Installation. The employee candidates for the 
rule are Luis Cheadle, Gary Conner, and so on. Assign an Activity to the highest-scoring 
candidate based on the assignment object's Activity Type field (values = Installation, Field 
Repair, or Maintenance) and a match between candidate employees' Product Skill and the 
Activity's Product field." 
Verify that the COM Installation rule meets this specification. 
Note: A full specification of this rule would include the scoring system used to pick the best 
candidate, and would weight each scoring criterion appropriately.  However, an initial rule 
specification may chose to leave some of the scoring details to be determined after 
implementation, when the rule can be tested empirically to see if it assigns candidates to 
assignment objects correctly. 

6. Leave your Siebel Call Center session running. 

7. Leave your Siebel Tools session running. 
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Solutions 23-1  

Answers 

2.e. The view tabs above the child applet provide access to other critical rule information: 
candidates and rule criteria. Which tab(s) do you think specify candidates? 
The view tabs titled Employee Candidates, Position Candidates, and Organization 
Candidates. 

2.f. Click the Employee Candidates, Position Candidates, and Organization Candidates view 
tabs. Which type(s) of candidate is specified for this rule? 
This rule defines position candidates only 

2.g. List the rule candidate(s). 
The PH 70 Pulsar ENU position 

4.d. What is the assignment object for this rule? 
Activity 

4.g. Which types of candidate are defined for the COM Installation rule? 
Employee candidates 

4.i. The first rule compares rule-provided values for Activity Type with that field in an Activity 
assignment object record. Look at the bottom applet. What values of Activity Type are 
provided in the rule? 
Installation, Field Repair, and Maintenance - these are listed in the bottom applet. 

4.l. Examine the records in the grandchild applet. Which two person attributes are specified in 
this criterion? (Do not include the Score column, which is not a person attribute.) 
Product and Expertise Code 

4.s. What values are available in the Expertise dropdown? 
Novice, Intermediate, and Expert 
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Practice 24-1 Executing a Task  

Goals To execute a task using the Task UI framework 

Time 10 - 20 minutes 

Instructions: 
In this practice you will invoke and execute a task that was created to demonstrate several key 
concepts about the Task UI framework. You will use this task to create a new contact and optionally 
add notes, add activities, assign accounts, and assign contact team members. The task flow has been 
constructed to loop back after and allow you to make further choices before you complete the task. 

1. Return to or if necessary, start Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Display the task pane in order to invoke the task. 
a. Click the Task button in the global toolbar to display the task pane. 

Note it is to the right of the iHelp icon:  

 
b. Observe that the Tasks Pane appears on the left side of the screen, and that it lists a task with 

the name BAF Create Contact - Demo: 
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3. Invoke the task. 
a. In the task pane, click BAF Create Contact - Demo. 
b. Verify that a task view replaces the normal Siebel view. 
c. Set: 

First Name Scott 
Last Name BAF 
Home Phone 510-555-9119 
Mobile Phone 510-555-1199 
Email Address scott.tiger@oracle.com 
Note: You can enter different values if you wish.  

d. Click Next. 
e. The task displays existing contacts that match what you entered in the top applet. Verify that 

no contacts appear in the top applet, and that No is selected in the lower left applet. 
f. Click Next. 
g. The shuttle applet displays existing addresses to select from.  
h. Query for Street Address = 8888 Orange Road. 
i. Select it and click Add. 
j. Click Next. 

 
The task reaches a point where the user can select from several choices about the next action to 
perform. You will explore each of these choices in the following steps. After each choice completes, 
the task loops back to this task view to allow the user to make another choice. 

4. Add a new note for the contact. 
a. Select Add a Note, and click Next. 
b. Set Note = Great first meeting!. 
c. Accept the other default values. 
d. Click Next. 

5. Add a new activity for the contact 
a. Select Create an Activity, and click Next. 
b. Set Description = Make sure to follow up next week. 
c. Set Type to Follow-Up using the drop-down list. 
d. Accept the other default values. 
e. Click Next. 

6. Add an account to the contact. 
a. Select Associate an Account, and click Next. 
b. Click the Query button on the Add Accounts list on the left side of the shuttle applet. 
c. Query for Oracle Corp. 
d. Click Add to assign the account to the contact. 
e. Click Next. 
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7. Add contact team members to the contact. 
a. Select Manage Contact Team, and click Next. 
b. Select Mike Austin in the Add Employees list. 
c. Click Add to assign the employee to the contact team. 
d. Click Next. 

 
You may continue to add further notes, activities, accounts, and team members if you wish. When 
you have completed these further additions, you will review and submit the contact record. 

8. Finish the contact record. 
a. Select Review and Submit Contact, and click Next. 
b. Verify that the final view shows all the data you entered.  
c. Open the Contact Team and verify that Mike Austen appears.  Click OK. 
d. Open the Account multi value group and verify that Oracle Corp appears.  Click OK. 
e. Click the Submit button.  
f. Observe that the task view disappears and the previous Siebel view reappears. 

9. Verify that the new contact record is now accessible in the regular Siebel application. 
a. Select Contacts > My Contacts. 
b. Query for the contact you created above (Scott BAF). 
c. Drill down on the record to navigate to the contact detail view. 
d. Select the drop down in the middle of the view and select Notes.   
e. Click Private Notes. 
f. Verify that the data you entered is now displayed in a standard Siebel view. 

10. Create a new contact. However you will pause and then resume the task. 
a. In the task pane, click BAF Create Contact - Demo. 
b. Enter Zoe BAF and click Next. 
c. Click Next. 
d. In the Add Address pane, click Pause to suspend execution of the task. 
e. Click OK to dismiss the dialog box.  
f. Observe that the task view disappears and is replaced by the previous Siebel view. 
g. Select Accounts > All Accounts 
h. Query for Name = Parker Healthcare System.  

Note: This simulates an interruption that you might encounter while working on a task. 

11. Resume the task and verify that you did not lose any data you entered. 
a. At the bottom of the task pane, click the Go to Inbox link to navigate to the Inbox to resume 

the task 
b. Locate the paused task (with the most recent timestamp) and drill down on it. 
c. Verify that the task resumes where you paused it (at adding the address). 
d. Click Next, Next, and Submit to complete the task. 

Note:  This may take a moment. 
e. Select Contacts > My Contacts. 
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f. Query for the new contact you entered (Zoe BAF). 
g. Verify the data you entered appears. 

12. Return to or if necessary, start Siebel Tools: 
a. Select Start > Programs > Siebel_Tools_8.1 8.1 > Siebel Tools.   
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

13. Examine the task: 
a. Select the OE. 
b. Select Task. 
c. Query for Task Name = BAF Create Contact - Demo. 
d. Right-click the record and select Edit Task Flow. 
e. Observe that the Task Designer is displayed in the editing pane, and that it displays the task 

flow. 
f. Locate the Start step in the upper left of the task flow. 
g. Observe the Decision Point step three steps to right of the Start step. This step determines if 

user has located an existing contact or wishes to create a new contact and branches 
accordingly. 

h. Locate the What Next? Decision point step in the lower left of the task flow. This step has 
multiple branches and controls the flow to the action the user has selected. 

i. Notice that several of the branches invoke subtasks.  
j. When you have finished examining the task flow, close the task flow editor by clicking the X 

in the upper right. 

14. Leave Siebel Tools running. 

15. Leave Siebel Call Center running. 
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Practice 25-1 Exploring Internationalized Formats 

Goals To use the internationalized features of Siebel CRM Applications 

Time 20 - 30 minutes 

Instructions: 
You will use Siebel Call Center to see the effects of locale.  In particular, you will examine phone, 
date, and number conventions and how they differ with locale.   

The method for setting the locale and its conventions varies depending on client type. In the Siebel 
Web architecture, where users access Siebel applications using the Siebel Web client, locale is a 
parameter of the Application Object Manager server component.  For the Siebel Mobile Web Client 
or the Siebel Developer Web Client, the locale is set through the Microsoft Windows Control Panel.  
You will use this latter method with the Siebel Developer Web Client to modify the locale. 

1. For this lab to work as intended, the regional setting on your system must be initially set to 
English (United States). In this step you will make certain that this regional setting is set 
correctly. 
a. Log out of all Siebel applications, including Siebel Tools. 
b. Select Start > Settings > Control Panel. 
c. Double-click Regional and Language Options. 
d. If necessary, click the Regional Options tab. 
e. In the upper drop-down list, make sure that English (United States) is selected. If it is not, 

select it. 
f. Click OK. 

2. Observe the behavior for telephone number, date, and number formats in English (United States). 
a. Start Siebel Call Center Developer Web Client: 

i. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 
Center – ENU. 

ii. Enter: 
User ID SADMIN 
Password SADMIN 
Connect to Sample 

iii. Click OK. 
b. Select Accounts > My Accounts. 
c. Select the first record, 3 Com. 
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d. In the form applet, replace the Main Phone #, typing it in exactly as it appears here: 
+33865526301. Tab out of the field. What do you observe?  
 
             
 
             

e. In the form applet, replace the Main Fax # with 33865526991, without a plus sign. Tab out of 
the field. What do you observe?  
 
             
 
             
 
             

f. Select Service > All Service Requests. 
g. For the first record, what is the value/format of the Opened field? 

 
              

h. Select Opportunities > My Opportunities. 
i. For the first record, what is the value/format of the Revenue field?  

 
              

3. Select File > Log Out. 

4. Investigate what happens when you change the regional setting in the operating system.  
a. Select Start > Settings > Control Panel. 
b. Double-click Regional and Language Options. 
c. If necessary, click the Regional Options tab. 
d. Select French (France) from the upper drop-down and click OK. 
e. Start the Siebel Call Center Developer Web Client: 

i. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 
Center – ENU. 

ii. Enter: 
User ID SADMIN 
Password SADMIN 
Connect to Sample 

iii. Click OK. 
f. Select Account > My Accounts.  

Note: If a dialog concerning “Problems with this Web page” appears, click OK and continue. 
This may appear because you are using the English-language Siebel application in a 
computer with French regional settings. 
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g. How are the telephone and fax numbers for the 3 Com account now formatted?  
 
             
 
              

h. How are US phone numbers formatted?  
Hint: Query in the detail applet for Accounts with Site = US.  
 
             

i. Select Service > All Service Requests. 
j. For the first record, what is the value/format of the Opened field? 

 
              

k. Select Opportunities > My Opportunities. 
l. For the first record, what is the value/format of the Revenue field?  

 
              

5. Select File > Log Out. 

6. Reset the regional settings to English (United States). 
a. Select Start > Settings > Control Panel. 
b. Double-click Regional and Language Options. 
c. Click the Regional Options tab. 
d. Select English (United States) from the upper drop-down and click OK. 
e. Close the Control Panel window. 
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Solutions 25-1  

Answers 

2.d. In the form applet, replace the Main Phone # for the 9 Telecom account, typing it in exactly 
as it appears here: +33865526301. Tab out of the field. What do you observe?  
The number was formatted as +33865526301 – exactly as entered. 

2.e. In the form applet, replace the Main Fax # with 33865526991, without a plus sign. Tab out 
of the field. What do you observe? 
Without the + sign, the number was considered to be a phone number in the current region 
setting (English, United States) and was formatted accordingly. 

2.h. For the first record, what is the value/format of the Opened field? 
Should be similar in format to: 4/9/2004 7:23:00 AM.  This is day/month/year 

2.i. For the first record, what is the value/format of the Revenue field? 
Should be similar in format to $595,000.00  

4.g. How are the telephone and fax numbers for the 3 Com account now formatted? 
The French phone numbers for 3 Com are formatted without the +33 international codes. 
In other words, phone numbers are formatted from the perspective of a resident of France.  
Similar to 865526301 

4.h. How are US phone numbers formatted? 
The US phone numbers now have +1 preceding the area code. Similar to +1(222) 998-
7564 

4.k. For the first record, what is the value/format of the Opened field? 
Should be similar in format to 09/04/2004 07:23:00.  This is month/day/year 

4.m. For the first record, what is the value/format of the Revenue field? 
Should be similar in format to 595 000,00 $ 
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Practice 25-2 Examining Localization Support for 
Administrative Data 

Goals Examine localization support for important administrative data 

Time 5 - 15 minutes 

Instructions: 

The Siebel application can display application graphical elements in different languages.  This multi-
language support requires installation of language packs for parts of the Siebel architecture, such as 
the Siebel Server, Siebel Database Server, Siebel Tools, and the Siebel Mobile Web Client or 
Developer Web Client.   

Language support in a Siebel application includes multi-lingual support for graphical elements, such 
as column headings, screen and view tabs, menu items, and so on.  Siebel applications also provide 
multi-lingual support for user-created administrative data in two critical areas: lists of values and 
iHelp. You will examine the multi-lingual support in these two facilities. 

1. Start the Siebel Call Center Developer Web Client: 
a. Select Start > Programs > Siebel_Web_Client _81 > Siebel Web Client 8.1 > Siebel Call 

Center – ENU. 
b. Enter: 

User ID SADMIN 
Password SADMIN 
Connect to Sample 

c. Click OK. 

2. Examine multi-lingual support in static picklists.  
a. Navigate to Administration - Data > List of Values.   

Note: This is the view where static picklist values are administered.  A list of values is a 
collection of values that are displayed in a drop-down list, and may be used in many applets. 
Each list of values has a unique Type.  

b. Execute an empty query to refresh the list. 
c. Query for Type = MR_MS.  

Note: This list of values contains titles, such as Mr., Ms., Mrs., and so on, and may be 
modified by an application administrator to meet user requirements. 

d. Examine the records. The Type and Language-Independent Code fields are the same in all 
languages, but the Display Value and Language Name fields may vary to provide language 
support.   

O
ra

cl
e 

U
ni

ve
rs

ity
 a

nd
 (O

ra
cl

e 
C

or
po

ra
tio

n)
 u

se
 o

nl
y.

Th
es

e 
eK

it 
m

at
er

ia
ls

 a
re

 to
 b

e 
us

ed
 O

N
LY

 b
y 

yo
u 

fo
r t

he
 e

xp
re

ss
 p

ur
po

se
 S

EL
F 

ST
U

D
Y.

  S
H

AR
IN

G
 T

H
E 

FI
LE

 IS
 S

TR
IC

TL
Y 

PR
O

H
IB

IT
ED

.



Lesson 25: Preparing for a Global Deployment 

174 Siebel 8.1.x Business Analyst Oracle 

e. Query for Type = "EVENT_STATUS" (use quotes to get an exact match) and Language 
Name=English-American. 

f. Confirm that approximately 70 records result from the query. 
g. Notice the values in the Display Value column. 
h. From the application-level menu, select Query > Refine Query. 
i. Change the Language Name to German and re-execute the query. 
j. How do the returned records vary from the English records? 

 
              

k. Query for Type = "EVENT_STATUS" and Language-Independent Code = Confirmed. 
l. Which languages are supported for this list of values? 

 
              
 
              
Note: the PSL language code refers to a "dummy" locale and can be used to provide a 
placeholder for future translations during application implementation. 

3. You will look at an iHelp item, focusing on the multi-lingual support provided. iHelp includes 
support for multiple translations of an iHelp item. 
a. Navigate to Administration - iHelp > All iHelp items. 

Hint: this is the last Administration screen listed in the Site Map. 
b. Query for Name = Create a Marketing Plan. 
c. Drill down Name for the record that is Active. 
d. If prompted, click Run. 
e. Select the Translations view tab. This shows to which languages this iHelp item has been 

translated.  How many translations are there? 
 
              
Note: PSL is the pseudo-localization language code. This language code and its associated 
locale data are placeholders for locale data during application implementation, when fully 
localized data may not be ready. 

f. Select the Designer view tab. 
g. In the Designer applet, select the Enter Plan details step. 
h. In the explorer applet below the Designer, expand Enter Plan details. 
i. Select the Translations folder. 
j. In the Step Translations list applet (below the designer), you will see translations for the step. 

Verify that there is the same number of translations for this step as there are for the iHelp 
item. 

4. Select File > Log Out. 
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Solutions 25-2  

Answers 

2.j. How do the returned records vary from the English records? 
The Display Value is in German and the Language Name is German 

2.l. Which languages are supported for this list of values? 
German, Spanish (Modern), French, and English-American 

3.e. Click the Translations view tab. This shows to which languages this iHelp item has been 
translated.  How many translations are there? 
2 
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